LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-13-2012, 12:37 PM   #1
permalac
Member
 
Registered: Jul 2007
Location: Barcelona
Posts: 115

Rep: Reputation: 16
FC multipath says "device busy " when connecting again. SLES 11 - netapp - emulex


Hello there,

I have a weird issue.

sles 11
emulex FC
netapp fas 2xxx

100G LUN is ok.
Multipath enabled, multipathd and device-mapper seem to work properly.

multipath -t shows this output of the config => http://pastebin.com/bmEBhdeX

When both FC are connected I get this output from multipath -ll

360a98000572d5073538f68484c4c512f dm-0 NETAPP,LUN
[size=200G][features=1 queue_if_no_path][hwhandler=0][rw]
\_ round-robin 0 [prio=8][active]
\_ 1:0:0:70 sdc 8:32 [active][ready]
\_ 2:0:0:70 sde 8:64 [active][ready]
\_ round-robin 0 [prio=2][enabled]
\_ 1:0:1:70 sdb 8:16 [active][ready]
\_ 2:0:1:70 sdd 8:48 [active][ready]

When I unplug one FC everything goes fine.

The issue appears when connecting again, on the desktop a sdb or sdc "device is busy" . And then it does not appear on multipath -ll.

I though it could be that automount or similar tries to mount the sdb or sdc device, put they are not in the fstab and automount is not running.

Any suggestions?

thanks.

PD: the messages file => http://pastebin.com/2PfxSDKE (look arround 13pm and 15pm.
 
Old 01-13-2012, 05:45 PM   #2
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
I don't have a direct answer to your question, but may I ask why you're (physically? or via switch control?) disconnecting fibre cable and then connecting it again?

If possible, do not do that. After such an action you may need to re-scan the SCSI bus, restart the multipath daemon, and/or reboot the system.

---

edit: If you're doing this simply to test multipathd(8), then disable the port via switch control.

Last edited by anomie; 01-13-2012 at 05:46 PM.
 
  


Reply

Tags
fibre, multipath


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian 5 mdadm "device or resource busy" raid edwardzc Debian 1 12-27-2010 05:52 AM
The "init_module: Device or resource busy" message in the 2.4.26 kernel. tommyclee Linux - Kernel 3 12-30-2008 08:09 PM
Wireless RT2500, "Device or resource busy" in Ubuntu puggers Linux - Hardware 2 10-22-2006 02:18 PM
xine "Audio output unavailable. Device is busy." shellshock Linux - Software 3 05-13-2006 01:19 PM
samba - smbmount freezing my terminals -> "Device is busy" Yntarius Linux - Networking 4 05-21-2004 08:19 AM


All times are GMT -5. The time now is 05:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration