LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   FC multipath says "device busy " when connecting again. SLES 11 - netapp - emulex (http://www.linuxquestions.org/questions/linux-server-73/fc-multipath-says-device-busy-when-connecting-again-sles-11-netapp-emulex-923626/)

permalac 01-13-2012 11:37 AM

FC multipath says "device busy " when connecting again. SLES 11 - netapp - emulex
 
Hello there,

I have a weird issue.

sles 11
emulex FC
netapp fas 2xxx

100G LUN is ok.
Multipath enabled, multipathd and device-mapper seem to work properly.

multipath -t shows this output of the config => http://pastebin.com/bmEBhdeX

When both FC are connected I get this output from multipath -ll

360a98000572d5073538f68484c4c512f dm-0 NETAPP,LUN
[size=200G][features=1 queue_if_no_path][hwhandler=0][rw]
\_ round-robin 0 [prio=8][active]
\_ 1:0:0:70 sdc 8:32 [active][ready]
\_ 2:0:0:70 sde 8:64 [active][ready]
\_ round-robin 0 [prio=2][enabled]
\_ 1:0:1:70 sdb 8:16 [active][ready]
\_ 2:0:1:70 sdd 8:48 [active][ready]

When I unplug one FC everything goes fine.

The issue appears when connecting again, on the desktop a sdb or sdc "device is busy" . And then it does not appear on multipath -ll.

I though it could be that automount or similar tries to mount the sdb or sdc device, put they are not in the fstab and automount is not running.

Any suggestions?

thanks.

PD: the messages file => http://pastebin.com/2PfxSDKE (look arround 13pm and 15pm.

anomie 01-13-2012 04:45 PM

I don't have a direct answer to your question, but may I ask why you're (physically? or via switch control?) disconnecting fibre cable and then connecting it again?

If possible, do not do that. After such an action you may need to re-scan the SCSI bus, restart the multipath daemon, and/or reboot the system.

---

edit: If you're doing this simply to test multipathd(8), then disable the port via switch control.


All times are GMT -5. The time now is 01:31 AM.