LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 07-10-2012, 08:25 AM   #1
makoshark
LQ Newbie
 
Registered: Jun 2009
Location: Laurinburg, NC
Distribution: ubuntu 10.4 LTS
Posts: 11

Rep: Reputation: 0
fatal: get_service_attr: unknown username: vmail


Hello
I have followed several tutorials and the all are about the same. I am on ubuntu 10.04 LTS Using postfix and dovecot. In each tutorial I get stuck with a postfix error fatal: get_service_attr: unknown username: vmail fallowed by a devecot error. My mail log as follows:
Code:
Jul  8 19:47:59 nilandsplace postfix/smtpd[16456]: connect from cdptpa-omtalb.mail.rr.com[75.180.132.120]
Jul  8 19:48:00 nilandsplace postfix/smtpd[16456]: AB7FFA4713: client=cdptpa-omtalb.mail.rr.com[75.180.132.120]
Jul  8 19:48:00 nilandsplace postfix/cleanup[16461]: AB7FFA4713: message-id=<1341791342.3451.19.camel@james-desktop>
Jul  8 19:48:00 nilandsplace postfix/oqmgr[16332]: AB7FFA4713: from=<nilandjp@roadrunner.com>, size=1092, nrcpt=1 (queue active)
Jul  8 19:48:00 nilandsplace postfix/pipe[16462]: fatal: get_service_attr: unknown username: vmail
Jul  8 19:48:01 nilandsplace postfix/oqmgr[16332]: warning: private/dovecot socket: malformed response
Jul  8 19:48:01 nilandsplace postfix/oqmgr[16332]: warning: transport dovecot failure -- see a previous warning/fatal/panic logfile record for the problem description
Jul  8 19:48:01 nilandsplace postfix/master[16330]: warning: process /usr/lib/postfix/pipe pid 16462 exit status 1
Jul  8 19:48:01 nilandsplace postfix/master[16330]: warning: /usr/lib/postfix/pipe: bad command startup -- throttling
Jul  8 19:48:01 nilandsplace postfix/error[16463]: AB7FFA4713: to=<nilandjp@nilandsplace.com>, relay=none, delay=1.8, delays=0.83/1/0/0.01, dsn=4.3.0, status=deferred (unknown mail transport error)
Jul  8 19:48:05 nilandsplace postfix/smtpd[16456]: disconnect from cdptpa-omtalb.mail.rr.com[75.180.132.120]
Instructions are the same set up a user with uid = 5000 and gid = 5000, some the numbers are different but the idea is the same. I have redone everything 3 times and always get the same error. I don't know if it is related but postfix dose not see the user nilandjp:user either. I have searched the web High and Low and have no answer. the latest tutorial //wiki.vpslink.com/HOWTO:_ISP-style_Email_Server_with_Debian-Etch_and_Postfix_2.3]HOWTO: ISP-style Email Server with Debian-Etch and Postfix 2.3 - VPSLink Wiki is similar. Is this a Postfix version 2.7.0 problem? How do I solve it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] unknown groups and username? samuel882 Linux - Newbie 9 09-02-2011 01:55 PM
Unknown username? Knightron Slackware 4 07-04-2011 08:20 PM
Unknown login username and password Gaby Wilkens Linux - Newbie 22 04-24-2010 03:13 PM
Debian Etch - Postfix+Courier+MySQL+VMail problem - VMail is not created vargadanis Linux - Networking 0 08-30-2007 04:35 AM
Squirrelmail Unknown username gallet Linux - Software 1 08-11-2003 08:20 PM


All times are GMT -5. The time now is 05:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration