LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   fatal error -- 117 (http://www.linuxquestions.org/questions/linux-server-73/fatal-error-117-a-4175454871/)

Gray345 03-20-2013 12:28 PM

fatal error -- 117
 
Hi
Hit a problem on one of our server, unable to mount a directory.
I think the problem happened after mounting a Qnap file system onto this file system.
Maybe we've hit a limit or something.

This is from fdisk -l

Disk /dev/sda: 3999.9 GB, 3999999721472 bytes
255 heads, 63 sectors/track, 486305 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 267350 2147483647+ ee EFI GPT


After running xfs_repair -L /dev/sda1 this is the tail end.

disconnected inode 2691081530, moving to lost+found
disconnected inode 2691081531, moving to lost+found
disconnected inode 2691081532, moving to lost+found
disconnected inode 2691081533, moving to lost+found
corrupt dinode 2691081533, extent total = 1, nblocks = 0. This is a bug.
Please capture the filesystem metadata with xfs_metadump and
report it to xfs@oss.sgi.com.
cache_node_purge: refcount was 1, not zero (node=0x2aaadca691d0)

fatal error -- 117 - couldn't iget disconnected inode

I am running Linux version 2.6.18-194.32.1.el5.centos.plus
With the file system that will not mount in a raid array of 6 disks.

Any ideas please as Google is not being my friend today with this one.
Many Thanks in advance
Gray

Gray345 03-21-2013 10:53 AM

Hi Anyone with thoughts regarding this please?


All times are GMT -5. The time now is 05:40 PM.