LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   "failed to free base memory" when boot with PXE (http://www.linuxquestions.org/questions/linux-server-73/failed-to-free-base-memory-when-boot-with-pxe-623714/)

hondo 02-25-2008 11:31 AM

"failed to free base memory" when boot with PXE
 
Hi

Im installing a server by using PXE. The server gets an IP adress from the DHCP server and gets contact with the TFTP server. It loads the installation and starts to load the kernel. After a short period of time i et the following error messages:
"failed to free base memory"

Ive searched on the net and it seems like there is some kernel problem here? ..Does someone know how to fix this problem?

All help is appericiated.

p_s_shah 02-27-2008 11:04 AM

Hello,

All the googling shows, that it is not harmful at all.

Please refer following if you haven't referred already.

Quote:

{ Basically all PXE implementations }
A fair number of PXE implementations has problems with releasing base memory once booting is complete. This should not affect you if you're running Linux, but other operating systems, such as DOS under MEMDISK, may have less memory available than they should. PXELINUX 1.65 or higher will display a message:

Failed to free base memory, sorry...

... when that happens. It should not cause problems other than the loss of some memory; usually about 64K worth. PXELINUX 2.03 or later will display an error code in conjunction with the message; reporting that error code might assist in identifying the location of the problem.


Most, possibly all, PXE implementations are completely broken if they receive fragmented IP packets; also, a lot of them will request a blksize of 1468 or thereabouts, corresponding to an MTU of 1500. Therefore, your boot server should never use an MTU that is larger than the MTU the packets may encounter during the transfer (typically 1500), and you should disable the blksize option (-r blksize in tftp-hpa) if you have to use an MTU smaller than 1500. Fortunately it's rare these days that you'll have that kind of network between your TFTP server and your clients.

Link :
http://syslinux.zytor.com/hardware.php

hondo 02-27-2008 01:19 PM

Thank you for replying.. eventhough this seems like an information message now that i know a little about it.. the installation didnt continue after this message was displayed. But, ive found a solution to it now though.


All times are GMT -5. The time now is 10:26 AM.