-   Linux - Server (
-   -   fail2ban install issue (

glennbtn 01-26-2013 04:31 AM

fail2ban install issue
Hi all

I am trying to install fail2ban on my ubuntu 10.4 server running zimbra. I have tried a manual install and apt-get install and get the following errors if anyone can help

Setting up fail2ban (0.8.4-1ubuntu1) ...
update-rc.d: warning: fail2ban start runlevel arguments (2 3 4 5) do not match LSB Default-Start values (3 5)
update-rc.d: warning: fail2ban stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (0 1 2 6)
.: 30: Can't open /etc/rc.status
invoke-rc.d: initscript fail2ban, action "start" failed.
dpkg: error processing fail2ban (--configure):
subprocess installed post-installation script returned error exit status 2
Processing triggers for python-central ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)



descendant_command 01-26-2013 04:37 AM


Originally Posted by glennbtn (Post 4877845)
I have tried a manual install and apt-get install

Looks like you picked a version not compatible with your system.
You should stick with the official repo's.

glennbtn 01-26-2013 04:47 AM

I did try the apt-get install first and have not changed any repo's



descendant_command 01-26-2013 05:31 AM

What is a "manual install".

glennbtn 01-26-2013 08:05 AM


As in download the tar.gz and run the ./ /install

descendant_command 01-26-2013 05:04 PM

Downloaded from ... ?
Was it designed to work with U10.04's LSB framework?

Habitual 01-26-2013 05:27 PM

descendant_command 01-26-2013 05:53 PM

So you followed those links back to the ubuntu repo's?

You could file a bug against that package, although is Universe not supported by ubuntu? (even on LTS release?)

Maybe just edit the init-scripts yourself.

All times are GMT -5. The time now is 08:27 PM.