LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-16-2007, 08:03 AM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Rep: Reputation: 53
fail to telnet localhost 106


Hi folks,


Ubuntu 7.04 server amd64


On running;

$ telnet localhost 106
Code:
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused

$ netstat -an | grep 106
$ sudo netstat -an | grep 106
both no printout


Pls advise where shall I check and how to fix the problem. TIA


P.S. confirmed with ISP port 106 is open


B.R.
satimis
 
Old 12-16-2007, 08:06 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
isp? what has your isp got to do with a localhost connection? what are you even using port 106 for? there is clearly nothing listening on it so i've no idea what you're expecting to happen... maybe you still need to read up on what a tcp actually is and how they function within the linux tcp/ip stack?
 
Old 12-16-2007, 08:20 AM   #3
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by acid_kewpie View Post
isp? what has your isp got to do with a localhost connection? what are you even using port 106 for? there is clearly nothing listening on it so i've no idea what you're expecting to happen... maybe you still need to read up on what a tcp actually is and how they function within the linux tcp/ip stack?
I'm adding "change password" plugin on SquirrelMail. After installing poppassd on repo I tested it whether works according to /usr/local/squirrelmail/www/plugins/change_pass/INSTALL
Code:
Be sure to test and make certain your poppass daemon is working properly.
To test, try telneting into the daemon and changing a password:

$ telnet localhost 106
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
200 poppassd v1.8.1 hello, who are you?
user <username>
200 Your password please.
pass <oldpassword>
200 Your new password please.
newpass <newpassword>
200 Password changed, thank-you.
quit
200 Bye.
Connection closed by foreign host.
satimis
 
Old 12-16-2007, 08:39 AM   #4
digen
Member
 
Registered: Dec 2005
Location: India
Distribution: Ubuntu Feisty Fawn
Posts: 107

Rep: Reputation: 15
You need to start the courierpassd daemon. Check the /etc/xinetd.d directory for a configuration file for courierpassd.
 
Old 12-16-2007, 08:58 AM   #5
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by digen View Post
You need to start the courierpassd daemon. Check the /etc/xinetd.d directory for a configuration file for courierpassd.
I have this problem after running;

$ sudo apt-get remove xinetd


Remark: have "netkit-inetd" reinstalled.


Before I have another problem when xinetd was running;
Code:
$ telnet localhost 106
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
Connection closed by foreign host.
I can't proceed further. Please help


satimis
 
Old 12-16-2007, 11:58 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
this is where your 2,500 posts of troubleshooting experience comes in... what does the logfile say? what if you run it in a foreground mode instead of through (x)inetd?
 
Old 12-16-2007, 12:31 PM   #7
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by acid_kewpie
what does the logfile say?
$ telnet localhost 16
Code:
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused

$ tail /var/log/mail.log
Code:
Dec 17 02:15:33 mail imapd: LOGOUT, user=satimis, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=491, sent=1035, time=0
Dec 17 02:25:33 mail imapd: Connection, ip=[::ffff:127.0.0.1]
Dec 17 02:25:33 mail imapd: LOGIN, user=satimis, ip=[::ffff:127.0.0.1], protocol=IMAP
Dec 17 02:25:33 mail imapd: LOGOUT, user=satimis, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=491, sent=1035, time=0
Dec 17 02:28:46 mail postfix/smtpd[6046]: warning: 76.187.204.174: hostname cpe-76-187-204-174.tx.res.rr.com verification failed: Name or service not known
Dec 17 02:28:46 mail postfix/smtpd[6046]: connect from unknown[76.187.204.174]
Dec 17 02:28:48 mail postfix/smtpd[6046]: warning: support for restriction "reject_maps_rbl" will be removed from Postfix; use "reject_rbl_client domain-name" instead
Dec 17 02:28:48 mail postfix/smtpd[6046]: NOQUEUE: reject: RCPT from unknown[76.187.204.174]: 554 5.7.1 Service unavailable; Client host [76.187.204.174] blocked using bl.spamcop.net; Blocked - see http://www.spamcop.net/bl.shtml?76.187.204.174; from=<seisin@gdzilla.com> to=<satimis@satimis.com> proto=SMTP helo=<mhrdbc>
Dec 17 02:28:48 mail postfix/smtpd[6046]: lost connection after RCPT from unknown[76.187.204.174]
Dec 17 02:28:48 mail postfix/smtpd[6046]: disconnect from unknown[76.187.204.174]

Quote:
what if you run it in a foreground mode instead of through (x)inetd?
Started SM with;
https://localhost/squirrelmail

login and change password. It popup a warning;
Code:
ERROR:Connection refused (111)
 
Old 12-16-2007, 12:53 PM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
ok, well that's the wrong log, or you've not set the poppassd daemon to log. and running squirellmail isn't runnign poppassd in a foreground mode in any way. note that (x)inetd opens the tcp socjet regardless of the successful invocation of the backend process, so an incorrect config on inetd will still give you that open connection, and then close it whn your config fails.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
telnet localhost 25 trouble papitu76 Linux - Software 9 12-23-2008 02:21 AM
telnet - FAIL: telnet address from=15.8.29.14 gruell Linux - Software 1 06-28-2007 03:41 PM
Fail to telnet localhost 25 satimis Linux - Server 19 11-27-2006 09:43 AM
can not telnet localhost 25 but telnet dowell.exper.dynserv.com 25 exper Linux - Software 0 02-25-2004 05:13 AM
Telnet localhost and telnet not from localhost for IMAP services seb77 Linux - Networking 1 10-15-2003 01:20 PM


All times are GMT -5. The time now is 01:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration