LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 02-11-2011, 08:04 AM   #1
dracuss
Member
 
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Rep: Reputation: 29
Exim SMTP problem delivering mail to gmail.


We have a server, that works at the same time as a internet gateway and also is our mail server. Recently, we have some very strange problems with Gmail and other popular local mail service, mail.ru. We keep receiving these errors:
Code:
2011-02-11 11:17:28 Received from mail1@domen1.com H=(336GCurmei) [192.168.235.57] P=esmtpa A=login:mail1@domen1.com S=41752
2011-02-11 11:17:38 SMTP error from remote mail server after initial connection: host gmail-smtp-in.l.google.com [74.125.79.27]: 451 too many connection attempts
2011-02-11 11:17:38 SMTP error from remote mail server after initial connection: host alt1.gmail-smtp-in.l.google.com [74.125.53.27]: 451 too many connection attempts
2011-02-11 11:20:47 alt2.gmail-smtp-in.l.google.com [209.85.225.27] Connection timed out
2011-02-11 11:20:47 SMTP error from remote mail server after initial connection: host alt3.gmail-smtp-in.l.google.com [74.125.159.27]: 451 too many connection attempts
2011-02-11 11:20:47 SMTP error from remote mail server after initial connection: host alt4.gmail-smtp-in.l.google.com [74.125.91.27]: 451 too many connection attempts
2011-02-11 11:20:47 mail2@gmail.com R=dnslookup T=remote_smtp defer (0): SMTP error from remote mail server after initial connection: host alt4.gmail-smtp-in.l.google.com [74.125.91.27]: 451 too many connection attempts
2011-02-11 11:40:31 SMTP error from remote mail server after initial connection: host alt3.gmail-smtp-in.l.google.com [74.125.159.27]: 451 too many connection attempts
2011-02-11 11:40:31 mail2@gmail.com R=dnslookup T=remote_smtp defer (0): SMTP error from remote mail server after initial connection: host alt3.gmail-smtp-in.l.google.com [74.125.159.27]: 451 too many connection attempts
2011-02-11 12:37:22 SMTP error from remote mail server after initial connection: host alt3.gmail-smtp-in.l.google.com [74.125.159.27]: 451 too many connection attempts
2011-02-11 12:37:22 mail2@gmail.com R=dnslookup T=remote_smtp defer (0): SMTP error from remote mail server after initial connection: host alt3.gmail-smtp-in.l.google.com [74.125.159.27]: 451 too many connection attempts
2011-02-11 14:37:22 SMTP error from remote mail server after initial connection: host alt3.gmail-smtp-in.l.google.com [74.125.159.27]: 451 too many connection attempts
2011-02-11 14:37:22 mail2@gmail.com R=dnslookup T=remote_smtp defer (0): SMTP error from remote mail server after initial connection: host alt3.gmail-smtp-in.l.google.com [74.125.159.27]: 451 too many connection attempts
I googled for any possible ways to solve this problem, but could find no satisfying answer. Any help would be appreciated. Thank you for your attention.
 
Old 02-11-2011, 08:17 AM   #2
jcalzare
Member
 
Registered: Aug 2009
Location: Chicago
Distribution: CentOS
Posts: 114

Rep: Reputation: 34
It means that google has throttled you for attempting to connect to their servers too many times. You should probably make it a priority to locate the source of the emails that you are flooding gmail with.

http://www.google.com/support/appsec...&answer=134416

They are not accepting mail from your server. Are you spamming?
 
1 members found this post helpful.
Old 02-12-2011, 12:50 AM   #3
dracuss
Member
 
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Original Poster
Rep: Reputation: 29
jcalzare, no I don't. But there is certainly a possibility that any of approximatively 150 Pc's in there have a spambot installed. Thanks for your help.
 
Old 02-13-2011, 12:44 AM   #4
wetech3
LQ Newbie
 
Registered: Feb 2011
Posts: 7

Rep: Reputation: 1
Google refuses the connction from your IP, becase of spamming or too many connection requestes ggole may consider this IP as a spammer and they tag mails as SPAM. Tis error also happen if you are using some mail scripts with out authentication. So check any spamming from your server.
 
1 members found this post helpful.
Old 02-21-2011, 04:53 AM   #5
dracuss
Member
 
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Original Poster
Rep: Reputation: 29
I scanned the gateway traffic with tcpdump, both on the Internet interface eth0, and from the "inside" interface eth1, but couldn't find any suspect activity. As a measure of precaution I disabled masquerading and redirected all the Internet traffic through squid, but anyway these messages didn't disappear. Are there any other reasons why such kind of messages are received? Thank you very much for your help.
 
Old 02-22-2011, 08:43 AM   #6
dracuss
Member
 
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Original Poster
Rep: Reputation: 29
Marking problem as solved. There was a rootkit on the machine. We disabled it, blocked the 465 port (which was the cause of the messages) an everything now works just fine. Thank you very much for your help
 
  


Reply

Tags
connections, exim, gmail, mail


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix not delivering to dovecot for local users (delivering to default user mail) Awalsh Linux - Server 0 07-27-2009 11:13 AM
PHP SMTP connection to gmail SMTP protocol violation ratcateme Programming 9 02-23-2009 03:58 AM
EXIM mail server problem tamilm Linux - Server 0 02-06-2009 08:15 AM
exim+gmail alessnet Linux - Newbie 1 02-21-2005 07:59 PM
Exim masquerading mail to AOL users with broadband SMTP server llamakc Linux - General 0 12-13-2003 08:58 AM


All times are GMT -5. The time now is 01:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration