LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   "error in nfs server" exportfs -v command giving error (http://www.linuxquestions.org/questions/linux-server-73/error-in-nfs-server-exportfs-v-command-giving-error-843580/)

piyusharora420 11-10-2010 11:52 PM

"error in nfs server" exportfs -v command giving error
 
hi everybody
i am trying to use nfs server but its not working for me
when i run command exportfs -v i get the error "/rhome/nis1 <world>(rw,wdelay,root_squash,no_subtree_check,annouid=65534,anongid=65534)
my export list is
/rhome/nis1 *(rw,sync)

please tell me where i am wrong?

prayag_pjs 11-10-2010 11:58 PM

Quote:

Originally Posted by piyusharora420 (Post 4155404)
exportfs -v i get the error "/rhome/nis1 <world>(rw,wdelay,root_squash,no_subtree_check,annouid=65534,anongid=65534)
my export list is
/rhome/nis1 *(rw,sync)

Why you think this is an error?I don't think this is error?
It gives "wdelay,root_squash,no_subtree_check" permission are by default permissions until and unless you give other permissions
Did you try mounting it on any of client linux system?

piyusharora420 11-12-2010 12:34 AM

you are right
 
yes that was not an error
but i was not able to mount in client side
i gave 777 permission to /rhome only
instead of /rhome/nis1 that was the problem
now its successfully running.
thanx alot

boroberts203337 01-15-2011 11:29 PM

Quote:

Originally Posted by piyusharora420 (Post 4156489)
yes that was not an error
but i was not able to mount in client side
i gave 777 permission to /rhome only
instead of /rhome/nis1 that was the problem
now its successfully running.
thanx alot

I have been having a problem on the client side and I keep running end to dead ends could you be a little more clear on what you did to resolve your problem


All times are GMT -5. The time now is 04:33 AM.