LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Email with Postfix,Dovecot & MySQL on CentOS 5-CentOS 6 issues (http://www.linuxquestions.org/questions/linux-server-73/email-with-postfix-dovecot-and-mysql-on-centos-5-centos-6-issues-943518/)

redhat19 05-06-2012 09:45 AM

Email with Postfix,Dovecot & MySQL on CentOS 5-CentOS 6 issues
 
We have CentOS 6.2 running on our VPS server (provided by Linode VPS hosting), but since the only instructions for setting up Email with Postfix, Dovecot and MySQL in the Linode library (or on Linode's site) is for the configuration on CentOS 5 [ http://library.linode.com/email/post...mysql-centos-5 ], I followed it for the installation/configuration of Email with Postfix, Dovecot and MySQL on our CentOS 6.2

Everything seemed to work fine until I got to the editing of the dovecot.conf file..
I replaced the content of the dovecot.conf file with stuff that the instruction asked to use to replace the dovecot.conf, but unsurprisingly, there were warnings.

......
........

Bye
[root@myserver1 /]# service mysqld restart
Stopping mysqld: [ OK ]
Starting mysqld: [ OK ]
[root@myserver1 /]# chmod o= /etc/postfix/mysql-virtual_*.cf
[root@myserver1 /]# useradd -g vmail -u 5000 vmail -d /home/vmail -m
useradd: group 'vmail' does not exist
[root@myserver1 /]# chgrp postfix /etc/postfix/mysql-virtual_*.cf
[root@myserver1 /]# groupadd -g 5000 vmail
[root@myserver1 /]# useradd -g vmail -u 5000 vmail -d /home/vmail -m
[root@myserver1 /]# clear
[root@myserver1 /]# postconf -e 'myhostname = myserver1.kuiperhost.com'
[root@myserver1 /]# postconf -e 'mydestination = $myhostname, localhost, localhost.localdomain'
[root@myserver1 /]# postconf -e 'mynetworks = 127.0.0.0/8'
[root@myserver1 /]# postconf -e 'inet_interfaces = all'
[root@myserver1 /]# postconf -e 'message_size_limit = 30720000'
[root@myserver1 /]# postconf -e 'virtual_alias_domains ='
[root@myserver1 /]# postconf -e 'virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf'
[root@myserver1 /]# postconf -e 'virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf'
[root@myserver1 /]# postconf -e 'virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf'
[root@myserver1 /]# postconf -e 'virtual_mailbox_base = /home/vmail'
[root@myserver1 /]# postconf -e 'virtual_uid_maps = static:5000'
[root@myserver1 /]# postconf -e 'virtual_gid_maps = static:5000'
[root@myserver1 /]# postconf -e 'smtpd_sasl_type = dovecot'
[root@myserver1 /]# postconf -e 'smtpd_sasl_path = private/auth'
[root@myserver1 /]# postconf -e 'smtpd_sasl_auth_enable = yes'
[root@myserver1 /]# postconf -e 'broken_sasl_auth_clients = yes'
[root@myserver1 /]# postconf -e 'smtpd_sasl_authenticated_header = yes'
[root@myserver1 /]# postconf -e 'smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination'
[root@myserver1 /]# postconf -e 'smtpd_use_tls = yes'
[root@myserver1 /]# postconf -e 'smtpd_tls_cert_file = /etc/pki/dovecot/certs/dovecot.pem'
[root@myserver1 /]# postconf -e 'smtpd_tls_key_file = /etc/pki/dovecot/private/dovecot.pem'
[root@myserver1 /]# postconf -e 'virtual_create_maildirsize = yes'
[root@myserver1 /]# postconf -e 'virtual_maildir_extended = yes'
[root@myserver1 /]# postconf -e 'proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps'
[root@myserver1 /]# postconf -e 'virtual_transport = dovecot'
[root@myserver1 /]# postconf -e 'dovecot_destination_recipient_limit = 1'
[root@myserver1 /]# service sendmail stop
sendmail: unrecognized service
[root@myserver1 /]# chkconfig sendmail off
error reading information on service sendmail: No such file or directory
[root@myserver1 /]# chkconfig postfix on
[root@myserver1 /]# service postfix start
Starting postfix: [ OK ]
[root@myserver1 /]# cd /etc/dovecot
You have new mail in /var/spool/mail/root
[root@myserver1 dovecot]# chgrp dovecot /etc/dovecot-sql.conf
chgrp: cannot access `/etc/dovecot-sql.conf': No such file or directory
[root@myserver1 dovecot]# chgrp dovecot /etc/dovecot/dovecot-sql.conf
[root@myserver1 dovecot]# chmod o= /etc/dovecot/dovecot-sql.conf
[root@myserver1 dovecot]# chkconfig dovecot on
[root@myserver1 dovecot]# service dovecot start
Starting Dovecot Imap: doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:3: protocols=imaps is no longer necessary, remove it
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:3: protocols=pop3s is no longer necessary, remove it
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:7: ssl_cert_file has been replaced by ssl_cert = <file
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:8: ssl_key_file has been replaced by ssl_key = <file
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:10: namespace private {} has been replaced by namespace { type=private }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:26: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:27: auth_user has been replaced by service auth { user }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:29: passdb sql {} has been replaced by passdb { driver=sql }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:33: userdb static {} has been replaced by userdb { driver=static }
[ OK ]
[root@myserver1 dovecot]# telnet localhost pop3
-bash: telnet: command not found


and the /var/log/maillog file looks like this

Code:

May 4 23:26:21 myserver1 postfix/postqueue[15764]: warning: Mail system is down -- accessing queue directly
May 4 23:26:36 myserver1 postfix/postqueue[15902]: warning: Mail system is down -- accessing queue directly
May 5 01:05:40 myserver1 postfix/postdrop[17280]: warning: unable to look up public/pickup: No such file or directory
May 5 07:03:39 myserver1 postfix/postqueue[2519]: warning: Mail system is down -- accessing queue directly
May 5 08:21:04 myserver1 postfix/postfix-script[3400]: starting the Postfix mail system
May 5 08:21:04 myserver1 postfix/master[3402]: daemon started -- version 2.6.6, configuration /etc/postfix
May 5 08:21:04 myserver1 postfix/pickup[3404]: warning: BA7DF3C3BB: message has been queued for 12 days
May 5 08:21:04 myserver1 postfix/pickup[3404]: BA7DF3C3BB: uid=0 from=<root>
May 5 08:21:04 myserver1 postfix/cleanup[3406]: BA7DF3C3BB: message-id=<20120505122104.BA7DF3C3BB@myserver1.kuiperhost.com>
May 5 08:21:04 myserver1 postfix/qmgr[3405]: BA7DF3C3BB: from=<root@myserver1.kuiperhost.com>, size=502, nrcpt=1 (queue active)
May 5 08:21:04 myserver1 postfix/pickup[3404]: BE5833C3BC: uid=48 from=<apache>
May 5 08:21:04 myserver1 postfix/cleanup[3406]: BE5833C3BC: message-id=<20120505122104.BE5833C3BC@myserver1.kuiperhost.com>
May 5 08:21:04 myserver1 postfix/qmgr[3405]: BE5833C3BC: from=<apache@myserver1.kuiperhost.com>, size=1364, nrcpt=1 (queue active)
May 5 08:21:04 myserver1 postfix/pickup[3404]: warning: BF1A53C3BD: message has been queued for 13 days
May 5 08:21:04 myserver1 postfix/pickup[3404]: BF1A53C3BD: uid=0 from=<root>
May 5 08:21:04 myserver1 postfix/cleanup[3406]: BF1A53C3BD: message-id=<20120505122104.BF1A53C3BD@myserver1.kuiperhost.com>
May 5 08:21:04 myserver1 postfix/qmgr[3405]: BF1A53C3BD: from=<root@myserver1.kuiperhost.com>, size=502, nrcpt=1 (queue active)
May 5 08:21:04 myserver1 postfix/local[3412]: BA7DF3C3BB: to=<root@myserver1.kuiperhost.com>, orig_to=<root>, relay=local, delay=1053360, delays=1053360/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
May 5 08:21:04 myserver1 postfix/qmgr[3405]: BA7DF3C3BB: removed
May 5 08:21:05 myserver1 postfix/local[3414]: BF1A53C3BD: to=<root@myserver1.kuiperhost.com>, orig_to=<root>, relay=local, delay=1140058, delays=1140057/0.01/0/1, dsn=2.0.0, status=sent (delivered to mailbox)
May 5 08:21:05 myserver1 postfix/qmgr[3405]: BF1A53C3BD: removed
May 5 08:21:07 myserver1 postfix/smtp[3413]: BE5833C3BC: to=<Jimmyadelanwa@yahoo.com>, relay=mta7.am0.yahoodns.net[98.139.54.60]:25, delay=26128, delays=26125/0.01/0.34/2.5, dsn=2.0.0, status=sent (250 ok dirdel)
May 5 08:21:07 myserver1 postfix/qmgr[3405]: BE5833C3BC: removed
May 5 08:21:11 myserver1 postfix/smtpd[3415]: connect from mail1215.grapevine.mkt2356.com[208.85.49.60]
May 5 08:21:12 myserver1 postfix/smtpd[3415]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:21:12 myserver1 postfix/smtpd[3415]: fatal: no SASL authentication mechanisms
May 5 08:21:13 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3415 exit status 1
May 5 08:21:13 myserver1 postfix/master[3402]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May 5 08:22:13 myserver1 postfix/smtpd[3420]: connect from mail.swiftng.com[41.222.70.242]
May 5 08:22:13 myserver1 postfix/smtpd[3420]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:22:13 myserver1 postfix/smtpd[3420]: fatal: no SASL authentication mechanisms
May 5 08:22:14 myserver1 postfix/smtpd[3422]: connect from 61-221-92-243.HINET-IP.hinet.net[61.221.92.243]
May 5 08:22:14 myserver1 postfix/smtpd[3422]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:22:14 myserver1 postfix/smtpd[3422]: fatal: no SASL authentication mechanisms
May 5 08:22:14 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3420 exit status 1
May 5 08:22:14 myserver1 postfix/master[3402]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May 5 08:22:15 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3422 exit status 1
May 5 08:23:55 myserver1 postfix/anvil[3418]: statistics: max connection rate 1/60s for (smtp:208.85.49.60) at May 5 08:21:12
May 5 08:23:55 myserver1 postfix/anvil[3418]: statistics: max connection count 1 for (smtp:208.85.49.60) at May 5 08:21:12
May 5 08:23:55 myserver1 postfix/anvil[3418]: statistics: max cache size 2 at May 5 08:22:14
May 5 08:24:24 myserver1 postfix/smtpd[3439]: connect from mail.firstcitygroup.com[41.223.147.140]
May 5 08:24:24 myserver1 postfix/smtpd[3439]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:24:24 myserver1 postfix/smtpd[3439]: fatal: no SASL authentication mechanisms
May 5 08:24:25 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3439 exit status 1
May 5 08:24:25 myserver1 postfix/master[3402]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May 5 08:25:38 myserver1 postfix/smtpd[3470]: connect from mail1215.grapevine.mkt2356.com[208.85.49.60]
May 5 08:25:38 myserver1 postfix/smtpd[3470]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:25:38 myserver1 postfix/smtpd[3470]: fatal: no SASL authentication mechanisms
May 5 08:25:39 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3470 exit status 1
May 5 08:25:39 myserver1 postfix/master[3402]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May 5 08:26:39 myserver1 postfix/smtpd[3473]: connect from mail1215.grapevine.mkt2356.com[208.85.49.60]
May 5 08:26:39 myserver1 postfix/smtpd[3473]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:26:39 myserver1 postfix/smtpd[3473]: fatal: no SASL authentication mechanisms
May 5 08:26:40 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3473 exit status 1
May 5 08:26:40 myserver1 postfix/master[3402]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May 5 08:27:40 myserver1 postfix/smtpd[3477]: connect from intranet.swiftng.com[41.222.70.243]
May 5 08:27:40 myserver1 postfix/smtpd[3477]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:27:40 myserver1 postfix/smtpd[3477]: fatal: no SASL authentication mechanisms
May 5 08:27:41 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3477 exit status 1
May 5 08:27:41 myserver1 postfix/master[3402]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May 5 08:29:21 myserver1 postfix/anvil[3441]: statistics: max connection rate 1/60s for (smtp:41.223.147.140) at May 5 08:24:24
May 5 08:29:21 myserver1 postfix/anvil[3441]: statistics: max connection count 1 for (smtp:41.223.147.140) at May 5 08:24:24
May 5 08:29:21 myserver1 postfix/anvil[3441]: statistics: max cache size 1 at May 5 08:24:24
May 5 08:30:41 myserver1 postfix/smtpd[3543]: connect from mail1215.grapevine.mkt2356.com[208.85.49.60]
May 5 08:30:41 myserver1 postfix/smtpd[3543]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:30:41 myserver1 postfix/smtpd[3543]: fatal: no SASL authentication mechanisms
May 5 08:30:42 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3543 exit status 1
May 5 08:30:42 myserver1 postfix/master[3402]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May 5 08:31:55 myserver1 postfix/smtpd[3554]: connect from mail1215.grapevine.mkt2356.com[208.85.49.60]
May 5 08:31:55 myserver1 postfix/smtpd[3554]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:31:55 myserver1 postfix/smtpd[3554]: fatal: no SASL authentication mechanisms
May 5 08:31:56 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3554 exit status 1
May 5 08:31:56 myserver1 postfix/master[3402]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May 5 08:32:56 myserver1 postfix/smtpd[3557]: connect from mail1215.grapevine.mkt2356.com[208.85.49.60]
May 5 08:32:56 myserver1 postfix/smtpd[3557]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:32:56 myserver1 postfix/smtpd[3557]: fatal: no SASL authentication mechanisms
May 5 08:32:57 myserver1 postfix/master[3402]: warning: process /usr/libexec/postfix/smtpd pid 3557 exit status 1
May 5 08:32:57 myserver1 postfix/master[3402]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
May 5 08:34:36 myserver1 dovecot: master: Dovecot v2.0.9 starting up (core dumps disabled)
May 5 08:34:36 myserver1 dovecot: config: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
May 5 08:34:36 myserver1 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:3: protocols=imaps is no longer necessary, remove it
May 5 08:34:36 myserver1 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:3: protocols=pop3s is no longer necessary, remove it
May 5 08:34:36 myserver1 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:7: ssl_cert_file has been replaced by ssl_cert = <file
May 5 08:34:36 myserver1 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:8: ssl_key_file has been replaced by ssl_key = <file
May 5 08:34:36 myserver1 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:10: namespace private {} has been replaced by namespace { type=private }
May 5 08:34:36 myserver1 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:26: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely
May 5 08:34:36 myserver1 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:27: auth_user has been replaced by service auth { user }
May 5 08:34:36 myserver1 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:29: passdb sql {} has been replaced by passdb { driver=sql }
May 5 08:34:36 myserver1 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:33: userdb static {} has been replaced by userdb { driver=static }
May 5 08:34:37 myserver1 postfix/anvil[3545]: statistics: max connection rate 1/60s for (smtp:208.85.49.60) at May 5 08:30:41
May 5 08:34:37 myserver1 postfix/anvil[3545]: statistics: max connection count 1 for (smtp:208.85.49.60) at May 5 08:30:41
May 5 08:34:37 myserver1 postfix/anvil[3545]: statistics: max cache size 1 at May 5 08:30:41

Question #1: Can I go on and use the email like this/this way/with the current configuration (notwithstanding the warnings)?
Question #2: Does anybody have a more up-to-date dovecot.conf file or can anybody point me to one?

I would appreciate any help I can get.

Thanks in advance.

Noway2 05-07-2012 08:05 AM

Quote:

doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:3: protocols=imaps is no longer necessary, remove it
I have seen this appear when using a Dovecot 1.x configuration file with Dovecot 2.x application. If you use the dovecot -n command, it should convert and clean up these entries for you.

My Dovecot 2.0 configuration can be found in this thread: http://www.linuxquestions.org/questi...oforge-940578/

sanjay87 05-07-2012 10:15 AM

Hi
Have u install dovecot-pop3d dovecot-imap package. Just few hour back i tried out the below link in insatllation ubuntu 10.04 lucid works without any sort of error



Did u got the output as below

#telnet localhost 25
ehlo localhost

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 plato.example.com ESMTP Postfix
ehlo localhost
250-beetel.example.com
250-PIPELINING
250-SIZE 30720000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN
250-AUTH=PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN




http://library.linode.com/email/post...tu-10.04-lucid

I Guess problem is in dovecot.conf file.check once again the configuration as below edited in dovecot.conf

protocols = imap imaps pop3 pop3s
log_timestamp = "%Y-%m-%d %H:%M:%S "
mail_location = maildir:/home/vmail/%d/%n/Maildir

ssl_cert_file = /etc/pki/dovecot/certs/dovecot.pem
ssl_key_file = /etc/pki/dovecot/private/dovecot.pem

namespace private {
separator = .
prefix = INBOX.
inbox = yes
}

protocol lda {
log_path = /home/vmail/dovecot-deliver.log
auth_socket_path = /var/run/dovecot/auth-master
postmaster_address = postmaster@example.com
}

protocol pop3 {
pop3_uidl_format = %08Xu%08Xv
}

auth default {
user = root

passdb sql {
args = /etc/dovecot-sql.conf
}

userdb static {
args = uid=5000 gid=5000 home=/home/vmail/%d/%n allow_all_users=yes
}

socket listen {
master {
path = /var/run/dovecot/auth-master
mode = 0600
user = vmail
}

client {
path = /var/spool/postfix/private/auth
mode = 0660
user = postfix
group = postfix
}
}
}


May 5 08:21:12 myserver1 postfix/smtpd[3415]: warning: SASL: Connect to private/auth failed: No such file or directory
May 5 08:21:12 myserver1 postfix/smtpd[3415]: fatal: no SASL authentication mechanisms


do u started sasl service

#service saslauthd start

redhat19 05-07-2012 03:49 PM

Thanks Sanjay87..

I started the sasl service..then I created an email and sent a test mail.
Here are is the error I got from my Mail Queue..

EE2A03C425

2012/05/07 16:27

root@myserver1.myhost.com
me@mydomain.com

476 bytes

temporary failure. Command output: doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:3: protocols=imaps is no longer necessary, remove it doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:3: protocols=pop3s is no longer necessary, remove it doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:7: ssl_cert_file has been replaced by ssl_cert = <file doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:8: ssl_key_file has been replaced by ssl_key = <file doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:10: namespace private {} has been replaced by namespace { type=private } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:26: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:27: auth_user has been replaced by service auth { user } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:29: passdb sql {} has been replaced by passdb { driver=sql } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:33: userdb static {} has been replaced by userdb { driver=static }

Noway2 05-07-2012 06:41 PM

Quote:

Originally Posted by redhat19 (Post 4672740)
temporary failure. Command output: doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf

If you run the command in bold above, it should clean up your configuration and stop the error / warning messages. The new, updated, configuration will be titled dovecot-new.conf. Save your old dovecot.conf and rename this newfile dovecot.conf. Restart Dovecot and try again.

redhat19 05-10-2012 12:12 PM

Request for help with Dovecot configuration to work with MySQL and Postfix
 
Hi all,

I want to convert this Dovecot configuration file for Dovecot 1.x to a dovecot file for Dovecot 2.x

=========== /etc/dovecot.conf =======================
protocols = imap imaps pop3 pop3s
log_timestamp = "%Y-%m-%d %H:%M:%S "
mail_location = maildir:/home/vmail/%d/%n/Maildir

ssl_cert_file = /etc/pki/dovecot/certs/dovecot.pem
ssl_key_file = /etc/pki/dovecot/private/dovecot.pem

namespace private {
separator = .
prefix = INBOX.
inbox = yes
}

protocol lda {
log_path = /home/vmail/dovecot-deliver.log
auth_socket_path = /var/run/dovecot/auth-master
postmaster_address = postmaster@example.com
}

protocol pop3 {
pop3_uidl_format = %08Xu%08Xv
}

auth default {
user = root

passdb sql {
args = /etc/dovecot-sql.conf
}

userdb static {
args = uid=5000 gid=5000 home=/home/vmail/%d/%n allow_all_users=yes
}

socket listen {
master {
path = /var/run/dovecot/auth-master
mode = 0600
user = vmail
}

client {
path = /var/spool/postfix/private/auth
mode = 0660
user = postfix
group = postfix
}
}
}

======================================================

I run CentOS 6 on my server and I am trying to get my Dovecot to work with MySQL and Postfix to handle multiple virtual domains/users.

I am currenty following the instructions here: http://library.linode.com/email/post...mysql-centos-5
but the instructions are for Dovecot 1.x.

Thanks in advance.

colucix 05-12-2012 09:15 AM

Two threads on the same topic have been merged here. Please keep discussion in one place in order to avoid confusion and to receive a more effective help. Thank you.


All times are GMT -5. The time now is 03:38 AM.