LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Easy question about tutorial (http://www.linuxquestions.org/questions/linux-server-73/easy-question-about-tutorial-4175411084/)

Jonathan_Frias 06-12-2012 03:40 PM

Easy question about tutorial
 
I've been following this tutorial:

http://www.howtoforge.com/perfect-se...ispconfig-3-p6

I got down to the section where it says:

Code:

If you want to use a /webmail or /squirrelmail alias that you can use from your web sites, this is a bit more complicated than for Apache because nginx does not have global aliases (i.e., aliases that can be defined for all vhosts). Therefore you have to define these aliases for each vhost from which you want to access SquirrelMail.

To do this, paste the following into the nginx Directives field on the Options tab of the web site in ISPConfig:

It tells me to edit some files, but it doesn't really say where they are. I know it seems silly, but how am I suppose to get to them.

frankbell 06-12-2012 09:04 PM

Try locate [filename] in a terminal.

Jonathan_Frias 06-13-2012 08:50 AM

I think I solved this issue, but it lead me to another

The file is located at:
/etc/nginx/sites-available/ispconfig.vhost

Assuming the directions were following correctly all you have to do is uncomment the configuration section for squirrel mail. For me it was line 58, and it starts with

Code:

location /squirrelmail {....
...
}

The problem is the ssl listen port, which was set to 8080 by default(non-privileged port) but if I change to the 443(default privileged port for ssl), it seems to barf.

Side note: I am sure this is the configuration I have to change. I tested it out by changing it to 9090 to see if that's all I had to change.

Could it be that nginx is not running as root?

Noway2 06-13-2012 11:46 AM

What is the error message that it barfs with? Not launching as a privileged user will causes errors when trying to bind a process to a low numbered port. Normally, processes such as servers are started from init as root and then the root privilege is dropped. I haven't used ngix, but I imagine it would be the same way. Looking at some sample configurations (e.g. http://nginx.org/en/docs/http/config...s_servers.html) there doesn't seem to be anything magical about setting up port 443, which would seem to confirm your privilege suspicion.

Jonathan_Frias 06-13-2012 03:08 PM

I feel dumb sometimes.

I decided to try running lynx @ localhost:443 and it works correctly.

So then it has to be a firewall issue. I go to check and sure enough, there is the problem!

Thanks for all your help guys.


All times are GMT -5. The time now is 07:31 AM.