LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 06-04-2012, 11:54 PM   #1
hrs.blr89
LQ Newbie
 
Registered: Jun 2012
Posts: 2

Rep: Reputation: Disabled
Downgrade php from 5.3 to 5.1.6 in RHEL 6.2


I'm trying to downgrade php in RHEL 6.2 from version 5.3 to 5.1.6 since I need the 5.1.6 version for running a customized software.

my repository file has following details in it

[RHEL]
name = RHEL
baseurl = http://ftp.iitm.ac.in/centos/5.8/os/x86_64/
enabled=1
gpgcheck = 1
gpgkey = http://ftp.iitm.ac.in/centos/RPM-GPG-KEY-CentOS-5


I'm trying to use a old repository for the downgrading.
I installed the yum-allowdowngrade package also for this purpose.

The problem is, the php-5.1.6 package has dependencies of old versions, for e.g openssl-0.9 but the one installed in my machine by default is openssl-1.0 it says there is a conflict with the installed version.

Can anyone please help in this regard.

Thanks
 
Old 06-05-2012, 07:21 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,669

Rep: Reputation: 1684Reputation: 1684Reputation: 1684Reputation: 1684Reputation: 1684Reputation: 1684Reputation: 1684Reputation: 1684Reputation: 1684Reputation: 1684Reputation: 1684
odd that 5.3 is so different than 5.1.6
the two are rather close

first WHY do you think you NEED just that and ONLY that version ?
was their a very old and unused call that was removed from 5.1.7 and up ?

or

dose the documentation for this old program state to install ( the THEN current) 5.1.6


this IS red hat so you DO have the required support contract
have you asked red hat seeing as you ARE paying them $$$$ every year
http://www.redhat.com/support/customer-portal.html



if it is some function that was removed from newer versions of php

then install the old version from source
but that might " null and void" your Red hat license and contract
so ask them .

Last edited by John VV; 06-06-2012 at 09:02 PM.
 
Old 06-06-2012, 08:57 PM   #3
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,239

Rep: Reputation: 2024Reputation: 2024Reputation: 2024Reputation: 2024Reputation: 2024Reputation: 2024Reputation: 2024Reputation: 2024Reputation: 2024Reputation: 2024Reputation: 2024
You say RHEL 6.2, but your repo points to Centos 5.8.
You definitely can't mix version nums like that AND if this really RH, they will not support Centos either.

You need to decide

1. are you running/going to run RHEL (needs paid support/updates) OR Centos (free updates/no support)
2. which version 6.x or 5.x and the sub-version nums matter as well.
 
Old 06-09-2012, 04:22 AM   #4
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,188
Blog Entries: 4

Rep: Reputation: 219Reputation: 219Reputation: 219
Quote:
Originally Posted by hrs.blr89 View Post
I'm trying to downgrade php in RHEL 6.2 from version 5.3 to 5.1.6 since I need the 5.1.6 version for running a customized software.

my repository file has following details in it

[RHEL]
name = RHEL
baseurl = http://ftp.iitm.ac.in/centos/5.8/os/x86_64/
enabled=1
gpgcheck = 1
gpgkey = http://ftp.iitm.ac.in/centos/RPM-GPG-KEY-CentOS-5


I'm trying to use a old repository for the downgrading.
I installed the yum-allowdowngrade package also for this purpose.

The problem is, the php-5.1.6 package has dependencies of old versions, for e.g openssl-0.9 but the one installed in my machine by default is openssl-1.0 it says there is a conflict with the installed version.

Can anyone please help in this regard.

Thanks

Many times while installing Oracle database even I come across such problems when we need to use gcc and php of lower versions as compatible by Oracle. But I am surprise about one thing as I am using CentOS 6.2 and my PHP is by default 5.1.6

Firstly I would advise it is not at all a god idea to remove the dependencies of php package instead you can install the php version you want from any of the rpm sites available on net.
If the rpm package doesn't asks for any dependencies or doesn't prompts for any error (which i don't think is possible) then you are good to go but if you find any error messages like

already a file exists or dependencies required then you can use

Code:
#rpm -ivh rpm_file --nodeps --force
once it is installed you can create a symlink from /usr/bin/php to the newly installed rpm and check the version.

Last edited by deep27ak; 06-09-2012 at 04:24 AM.
 
Old 07-09-2012, 06:29 AM   #5
hrs.blr89
LQ Newbie
 
Registered: Jun 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thanks for the replies,


There's a specific reason for me to trying to downgrade to php version 5.1.6, the zend optimizer that supports the application I work with seem to support only with php 5.1.6

Understanding that I cannot mix the repositories of CentOS 5.8 with RHEL 6.2, I'm not trying to install using rpm anymore.

I need help with installing from source files of php. The installation procedure should install all modules of php just like it's been installed while OS installation.


I am not using a paid version of RHEL so, I cannot ask for support from Red Hat.

Thanks in advance for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need php-devel for php-5.1.6-23.2 on RHEL Workstation glt Red Hat 11 02-24-2011 09:47 AM
RHEL 4.6 kernel downgrade hophilip Red Hat 5 01-24-2009 09:24 AM
Fedora Core 6 Downgrade PHP 5.1.6 to 4.4.4 Randvegeta Linux - Server 7 02-03-2007 02:51 PM
how do you downgrade php plainusdonuticus Linux - Newbie 3 01-04-2007 04:41 PM
Is there a PHP 5 rpm for RHEL 4? Swakoo Red Hat 4 10-20-2006 05:44 AM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration