LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 04-04-2012, 02:48 PM   #1
mwjones
LQ Newbie
 
Registered: Mar 2010
Posts: 22

Rep: Reputation: 0
Unhappy Dovecot no listener


Dovecot is not binding or listening on port 993 when I start it.

Code:
$ sudo netstat -tlnp | grep -c 993
0
Dovecot starts fine and runs without complaints.

Code:
$ sudo service dovecot restart
Restarting IMAP/POP3 mail server: dovecot.

$ sudo tail /var/log/mail.log
Apr  4 13:42:39 mwjones dovecot: master: Warning: Killed with signal 15 (by pid=16238 uid=0 code=kill)
Apr  4 13:42:39 mwjones dovecot: master: Dovecot v2.0.18 starting up (core dumps disabled)

$ sudo ps -ef | grep -i [d]ovecot
root     16243     1  0 13:42 ?        00:00:00 /usr/sbin/dovecot -c /etc/dovecot/dovecot.conf
dovecot  16245 16243  0 13:42 ?        00:00:00 dovecot/anvil
root     16246 16243  0 13:42 ?        00:00:00 dovecot/log
root     16248 16243  0 13:42 ?        00:00:00 dovecot/config
Still no listener

Code:
$ sudo netstat -tlnp | grep -c 993
0
Other infos for your scrutiny.

Code:
$ sudo dovecot --version
2.0.18

$ doveconf -n
# 2.0.18: /etc/dovecot/dovecot.conf
# OS: Linux 3.2.5-grsec x86_64 Debian wheezy/sid ext4
auth_debug = yes
auth_mechanisms = plain login
auth_verbose = yes
first_valid_uid = 1000
log_timestamp = "%Y-%m-%d %H:%M:%S "
mail_debug = yes
mail_location = maildir:/home/vmail/%d/%n/Maildir
passdb {
  args = /home/vmail/%d/etc/passwd
  driver = passwd-file
}
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
  user = root
}
service imap-login {
  service_count = 1
}
service ssl-params {
  type = startup
}
ssl_cert = </etc/apache2/ssl/GandiStandardSSLCA.pem
ssl_key = </etc/apache2/ssl/ssl.key
userdb {
  args = /home/vmail/%d/etc/passwd
  driver = passwd-file
}
verbose_ssl = yes

What am I missing and how do I fix this?
 
Old 04-05-2012, 05:29 AM   #2
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
You are missing part of your dovecot configuration, the part where it tells it to use IMAPS.
Code:
service imap-login {
  executable = /usr/libexec/dovecot/imap-login
  inet_listener imap {
    address = *
    port = 143
  }
  inet_listener imaps {
    address = *
    port = 993
  }
}
 
Old 04-05-2012, 11:09 AM   #3
mwjones
LQ Newbie
 
Registered: Mar 2010
Posts: 22

Original Poster
Rep: Reputation: 0
Thanks so much all. I was missing a few items:

Code:
protocols = imap # thanks to Timo Sirainen

# thanks to Noel Butler
service imap-login {
  inet_listener imap {
    port = 0
  }
  inet_listener imaps {
    address = *
    port = 993
  }
  service_count = 1
}
Here is my final doveconf -n with listener successfully running on 993:

Code:
# 2.0.18: /etc/dovecot/dovecot.conf
# OS: Linux 3.2.5-grsec x86_64 Debian wheezy/sid ext4
auth_debug = yes
auth_mechanisms = plain login
auth_verbose = yes
first_valid_gid = 1030
first_valid_uid = 1030
info_log_path = /var/log/dovecot-info.log
last_valid_gid = 1030
last_valid_uid = 1030
log_path = /var/log/dovecot.log
log_timestamp = "%Y-%m-%d %H:%M:%S "
mail_debug = yes
mail_location = maildir:/home/vmail/%d/%n/Maildir
passdb {
  args = /home/vmail/%d/etc/passwd
  driver = passwd-file
}
protocols = imap
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
  user = root
}
service imap-login {
  inet_listener imap {
    port = 0
  }
  inet_listener imaps {
    address = *
    port = 993
  }
  service_count = 1
}
service ssl-params {
  type = startup
}
ssl_cert = </etc/apache2/ssl/cert-mwjones.com.crt
ssl_key = </etc/apache2/ssl/mwjones.key
userdb {
  args = /home/vmail/%d/etc/passwd
  driver = passwd-file
}
verbose_ssl = yes
 
Old 04-12-2013, 09:34 PM   #4
rgarcialvarez
LQ Newbie
 
Registered: Apr 2013
Posts: 1

Rep: Reputation: Disabled
solved core dump dovecot

if use redhat/fedora/centos just only run those command with root privileges

/etc/init.d/dovecot stop

echo 'DAEMON_COREFILE_LIMIT="unlimited"' >> /etc/sysconfig/dovecot

/etc/init.d/dovecot start
 
  


Reply

Tags
dovecot, imap, listen, ssl


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VirtualBox + Serial Listener to db jrahma Linux - Software 1 11-01-2011 11:32 AM
Listener for Network Connection quotenschwarze Linux - Networking 1 12-07-2008 07:40 AM
A way to test for a fifo listener? lumix Linux - Newbie 1 05-17-2008 06:23 PM
usb to serial listener? tnrooster Linux - Software 1 05-01-2007 12:04 PM
RIP listener for Linux rodda Linux - Networking 1 02-06-2003 04:21 AM


All times are GMT -5. The time now is 05:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration