LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-14-2013, 07:10 PM   #1
monojeffrey
Member
 
Registered: May 2012
Posts: 64
Blog Entries: 1

Rep: Reputation: Disabled
Domain not bound


boot.JPG


am new to linux, while booting this process continues , couldn't complete the booting process , guide me to stop this process, also help me find the file where all the services has been mentioned , so we can enable or disable the services we need during the system start up

---
thanks for the help
 
Old 01-14-2013, 07:36 PM   #2
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,287

Rep: Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034
It depends on which distro you have; do you know the name/version?
IF you can get to the cmd line you can use
Code:
cat /etc/*release*

uname -a
Otherwise, check your Install media or watch the boot process carefully from the top; it should tell you there.
That screen dump looks like RHEL/Centos, but it could be something else.

The YPBIND issue is because its looking for a remote NIS based authentication server eg http://www.linuxhomenetworking.com/w...onfiguring_NIS.

Many distros use the chkconfig cmd http://linux.die.net/man/8/chkconfig to set the services to start at boot time.

HTH
 
Old 01-14-2013, 07:43 PM   #3
netnix99
Member
 
Registered: Jun 2011
Distribution: redhat, CentOS, OpenBSD
Posts: 252

Rep: Reputation: 89
monojeffrey,

The service that is holding you up is ypbind, located at /sbin/ypbind. It is the client service for NIS. It can be started different ways depending on your configuration. You will probably have to use a rescue CD, and boot from it, make the necessary changes, and then reboot again. ypbind can be started from either the /etc/rc.local file and/or chkconfig. You will also want to comment out any information in the /etc/yp.config file such as domainname and servername. This is assuming you don't want to use NIS. If you intend to use NIS, you will want to correct any inforamtion that may be incorrect in these files, such as servername or domain name.
 
Old 01-20-2013, 08:57 PM   #4
monojeffrey
Member
 
Registered: May 2012
Posts: 64
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Rescue mode

I entered into rescue mode , as you said c couldn't find the files (configs) to edit and i have taken the info about the distro

is it possible to edit the configs and make changes to the files (through which we can enable specific services for each runlevels
for
example ,In init 2 certain services we can start additionally
and in init 3 , we should be able to stop some services


--
thanks for the reply
Attached Images
File Type: jpg uname -a.JPG (50.5 KB, 11 views)
 
Old 01-21-2013, 11:47 AM   #5
netnix99
Member
 
Registered: Jun 2011
Distribution: redhat, CentOS, OpenBSD
Posts: 252

Rep: Reputation: 89
When you entered rescue mode (assuming this is a Red Hat based distro from the looks of the images) did you
Code:
 chroot /mnt/sysimage
before you took the screen shots? This takes the actual installed system and mounts it at /mnt/sysimage for editing. In rescue mode, when it dumps you to the shell, I am pretty sure you will be missing the specified system files because the resuce mode will not perform those options (such as: NIS functions, etc)
 
Old 01-22-2013, 06:26 AM   #6
monojeffrey
Member
 
Registered: May 2012
Posts: 64
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Solution to stop

What is the solution to stop Yp (NIS) and to restore the server to normal running state
am using Red hat 5
 
Old 01-22-2013, 08:21 AM   #7
netnix99
Member
 
Registered: Jun 2011
Distribution: redhat, CentOS, OpenBSD
Posts: 252

Rep: Reputation: 89
Once you perform the chroot, you have to find out what is starting the ypbind service and stop it. It could be many things or a combination of several things. Check the /etc/rc.local to see if ypbind is starting there (there will be a line with /sbin/ypbind). You can also edit the /etc/yp.conf file and remove the statement that defines the domainname and the NIS server. You should also be able to access chkconfig from here.

Code:
 chkconfig --list
if ypbind is on, you should see:
Code:
  ypbind         	0:off	1:off	2:on	3:on	4:on	5:on	6:off

Code:
 chkconfig ypbind off
should provide:
Code:
  ypbind         	0:off	1:off	2:off	3:off	4:off	5:off	6:off
 
1 members found this post helpful.
Old 01-23-2013, 08:33 PM   #8
monojeffrey
Member
 
Registered: May 2012
Posts: 64
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Stopped the yp bound service

Successfully stopped the yp bound service

also how to do this
adding reputation(after this i would close the thread)
help me to add your repution
thanks for the timely help

Last edited by monojeffrey; 01-23-2013 at 08:34 PM.
 
Old 01-24-2013, 01:30 AM   #9
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,287

Rep: Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034
In the left hand side box, there's a 'Rep' button; click that.
On the bottom right of the msg box, there's also a 'Did you find this post helpful? Yes' button; you can click that too if you want.
 
2 members found this post helpful.
Old 01-24-2013, 03:45 AM   #10
monojeffrey
Member
 
Registered: May 2012
Posts: 64
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
to chrism01

thank u ..
 
Old 01-24-2013, 07:28 AM   #11
netnix99
Member
 
Registered: Jun 2011
Distribution: redhat, CentOS, OpenBSD
Posts: 252

Rep: Reputation: 89
Glad to help!!
 
  


Reply

Tags
boot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ypbind - YPBINDPROC_DOMAIN: Domain not bound schurt Linux - Networking 2 03-27-2009 04:08 AM
YPBINDPROC_DOMAIN: Domain not bound Destrey Linux - Newbie 3 02-08-2008 01:19 AM
ftp answer domain not bound gggbogota Linux - Networking 0 03-29-2004 03:07 PM
Domain bound to network ? phoeniXflame Linux - Networking 0 06-13-2003 06:29 PM
YPBINDPROC_DOMAIN: Domain not bound nio99 Linux - Networking 1 10-27-2002 01:43 AM


All times are GMT -5. The time now is 07:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration