LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 04-14-2009, 05:30 PM   #1
machismo64
LQ Newbie
 
Registered: Apr 2009
Posts: 2

Rep: Reputation: 0
DNS BIND--Forwarding Not Working


I am running BIND 9.3 which I configured exclusively using the system-config-bind GUI.

I have a master zone on this server (.c) and it works perfectly--meaning that clients pointing to this server can resolve names in that zone.

I also have two zones set up for forwarding. They both work from the server itself (meaning if I type in hostname.xxxxx.com, the name resolves as it should). However, remote clients are unable to resolve names on the forward zones (meaning if they try to hit hostname.xxxxx.com or hostname.yyyyy.com, they do not get a hit)

Any ideas?



Here is my named.config file:






// Enterprise Linux BIND Configuration Tool
//
// Default initial "Caching Only" name server configuration
//

options {


directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};





zone "xxxxx.com." IN {
type forward;
forwarders { 10.120.117.13;
10.132.201.50;
};
};


zone "yyyyy.net." IN {
type forward;
forwarders { 10.208.160.13;
10.208.160.14;
};
};










zone "c." IN {
type master;
file "c.db";
};
zone "." IN {
type hint;
file "named.root";
};

zone "localdomain." IN {
type master;
file "localdomain.zone";
allow-update { none; };
};

zone "localhost." IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa." IN {
type master;
file "named.local";
allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa." IN {
type master;
file "named.ip6.local";
allow-update { none; };
};





include "/etc/rndc.key";
 
Old 04-15-2009, 12:50 PM   #2
archangel_617b
Member
 
Registered: Sep 2003
Location: GMT -08:00
Distribution: Ubuntu, RHEL/CentOS, Fedora
Posts: 234

Rep: Reputation: 42
Anything in your system logs about why queries are being denied? You may need to add an allow-query option (or allow-recursion, or something like that) for either the server or the zones in question.

- Arch
 
Old 04-15-2009, 05:46 PM   #3
machismo64
LQ Newbie
 
Registered: Apr 2009
Posts: 2

Original Poster
Rep: Reputation: 0
I am not sure what logging I would look at for this, but allow-query is not a valid option for a forwarding zone. I am really looking for something that would restrict remote users from using this kind of zone by default but allow local users to properly resolve to forwarding zones.
 
Old 04-15-2009, 07:17 PM   #4
archangel_617b
Member
 
Registered: Sep 2003
Location: GMT -08:00
Distribution: Ubuntu, RHEL/CentOS, Fedora
Posts: 234

Rep: Reputation: 42
/var/log/messages in RedHat (and derived) systems, /var/log/syslog under Debian.

- Arch
 
  


Reply

Tags
bind, conditional, dns, forwarding


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BIND/DNS setup working(kinda) yah0m Linux - Networking 2 09-25-2008 10:30 AM
How to get Windows Clients to be served DNS from a Linux BIND-DNS Server texmansru47 Linux - Networking 12 07-10-2008 08:06 PM
stopping dns forwarding requests in BIND shreeram.vk Linux - Server 3 07-10-2008 07:40 AM
LXer: DNS: The Bind Leading the Bind LXer Syndicated Linux News 0 06-15-2006 11:33 PM
forwarding Public IP address in BIND DNS on RedHat Linux EL3 pudhiyavan Linux - Networking 0 05-19-2005 05:16 AM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration