LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 06-18-2008, 02:37 PM   #1
halvorls
Member
 
Registered: Jun 2008
Posts: 78

Rep: Reputation: 15
Disable xserver (grahics) on server


Hi!

How can i disable th x server (graphics)?

Halvor
 
Old 06-18-2008, 03:16 PM   #2
marwansherin
LQ Newbie
 
Registered: May 2008
Posts: 6

Rep: Reputation: 0
try sudo telinit - 1 at the terminal

for more details take a look at man telinit
just open a terminal and type man telinit

it works fine on ubuntu
 
Old 06-19-2008, 10:04 AM   #3
yawe_frek
Member
 
Registered: Sep 2005
Distribution: feather 0.72-usb, DSL,CentOS,Ubuntu, Redhat 9
Posts: 144

Rep: Reputation: 15
what flavour of linux are u on
 
Old 06-19-2008, 11:12 AM   #4
mtimbro
Member
 
Registered: Feb 2008
Location: Montreal, Canada
Distribution: RedHat 3/4, Ubuntu 7.10
Posts: 86

Rep: Reputation: 15
Hi,

I'll assume that what you're trying to do is boot in non-graphical mode permanently.

I'll also assume that you're on a RH / Fedora / Centos / Suse / OpenSuse platform. Other platforms do it differently I believe.

Edit the /etc/inittab file and alter the following line:

id:3:initdefault:

The number you probably have instead of 3 is 5, which is graphical mode.

Hope this helps,
 
Old 06-20-2008, 03:18 AM   #5
halvorls
Member
 
Registered: Jun 2008
Posts: 78

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by mtimbro View Post
Hi,

I'll assume that what you're trying to do is boot in non-graphical mode permanently.

I'll also assume that you're on a RH / Fedora / Centos / Suse / OpenSuse platform. Other platforms do it differently I believe.

Edit the /etc/inittab file and alter the following line:

id:3:initdefault:

The number you probably have instead of 3 is 5, which is graphical mode.

Hope this helps,
Hi!

I use debain linux, how can i disable xserver at boot?
 
Old 06-20-2008, 03:44 AM   #6
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Quote:
Originally Posted by halvorls View Post
Hi!

I use debain linux, how can i disable xserver at boot?
Depends which program is starting it. Do you use kdm/gdm? kde or gnome or something else?

update-rc.d -f gdm remove
update-rc.d -f kdm remove
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia, grahics card to buy samuelmp Linux - Hardware 3 03-10-2007 01:17 PM
xserver-xfree86: Xserver could not start on my ATI-radeon video card Shankarrajus Debian 2 07-17-2006 08:00 AM
xserver-xorg config warning: migrating xserver-xfree86 templates doctorwebbox Debian 9 07-27-2005 08:24 PM
How to disable the xserver. wellander Red Hat 2 01-27-2005 10:00 PM
how to disable xserver xtian500 Linux - Newbie 7 01-27-2002 07:35 AM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration