LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-15-2008, 03:45 PM   #1
paganinipro
LQ Newbie
 
Registered: Dec 2006
Location: USA
Distribution: Debian Etch Linux Kernel 2.6.18 AMD64X
Posts: 13

Rep: Reputation: 0
Digest Authentication Glitch


Hello!
I'm trying to setup Digest authentication and I come up with the following error when running a config test for apache

Invalid command 'AuthDigestFile', perhaps misspelled or defined by a module not included in the server configuration

My configuration file for the protected section is as follows:

AuthType Digest
AuthName "webdav"
AuthDigestFile /where/my/file/is/file-name
Require valid-user

The interesting thing is that if I put AuthUserFile in place of AuthDigestFile, it works fine. However, the passwords that are used are from a different password file that I use for basic authentication. Plus, the passwords that work are in a file with a completely different name.

Thanks for the help!
 
Old 01-16-2008, 04:29 AM   #2
ledow
Member
 
Registered: Apr 2005
Location: UK
Distribution: Slackware 13.0
Posts: 241

Rep: Reputation: 34
Have you got mod_auth_digest loaded in your apache config?
 
Old 01-18-2008, 04:09 PM   #3
paganinipro
LQ Newbie
 
Registered: Dec 2006
Location: USA
Distribution: Debian Etch Linux Kernel 2.6.18 AMD64X
Posts: 13

Original Poster
Rep: Reputation: 0
Yes I do have auth_digest enabled. One thing I noticed is that I'm using this to control a webdav domain. Would this conflict with digest?

My config file, in other words, includes:

DAV On
(rest of config listed above)

Thanks for the help!
 
Old 02-01-2008, 08:40 PM   #4
baldur_the_god
Member
 
Registered: Feb 2007
Posts: 54

Rep: Reputation: 15
dav

I searched for that and what I found is that most browsers do not support digest authentication...specifically our friends in Redmond...I could never get that working at all, but I am having a lot of problems getting dav to work even with no authentication...I keep getting 403 and have searched and searched...can you help me...I have it set the same as I had it on fc6 but now that I have upgraded to fc8...I cannot get it to work...

Last edited by baldur_the_god; 02-01-2008 at 08:43 PM. Reason: wanted to add info
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Digest authentication with Squid (need MsIE6 instructions) n_f General 1 09-01-2009 03:41 PM
apache hangs when starting -> Digest: generating secret for digest authentication ... jma Linux - Networking 4 02-22-2007 02:02 AM
squid as reverse proxy for microsoft IIS with Advanced Digest Authentication mikmok Linux - Networking 0 10-19-2006 10:43 AM
PHP and Apache Digest Authentication newuser455 Programming 3 08-17-2006 08:05 AM
Is it a glitch? qulnxsh Linux - Software 1 04-28-2003 02:58 AM


All times are GMT -5. The time now is 06:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration