LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   DHCPD will start in debug but will not start as a normal service (http://www.linuxquestions.org/questions/linux-server-73/dhcpd-will-start-in-debug-but-will-not-start-as-a-normal-service-812610/)

jwsnl 06-07-2010 03:32 AM

DHCPD will start in debug but will not start as a normal service
 
Hi,

I have setup a CentOS 5.5 server as a DHCP server.
That will be it's only task in a Cisco callmanger VoIP environment
The DHCP server that comes with CentOS 5.5 is from ISC V3.0.5 -redhat.

The server (HP DL360) has two physical NIC's of which only NIC1 is used (ETH0)

ifconfig shows:
Code:

[root@localhost ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:23:7D:A2:2B:D0
          inet addr:10.1.0.15  Bcast:10.1.3.255  Mask:255.255.252.0
          inet6 addr: fe80::223:7dff:fea2:2bd0/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:114 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1650 (1.6 KiB)  TX bytes:7404 (7.2 KiB)
          Interrupt:185 Memory:f8000000-f8012800

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2385 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2385 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2928790 (2.7 MiB)  TX bytes:2928790 (2.7 MiB)

The interface has a fixed IP setup.

My dhcp.conf file looks like this:
Code:

# DHCP Server Configuration file.
#  see /usr/share/doc/dhcp*/dhcpd.conf.sample 
# to run in debug mode use the -f parameter /usr/sbin/dhcpd -d -f
# see /etc/sysconfig/dhcpd to see at what interface DHCP server is bound

#database with active lease is located at /var/lib/dhcpd/dhcpd.leases
#after a change the DHCP server needs a restart: 'prompt# service dhcpd restart'

ddns-update-style interim;
ignore client-updates;

#global settings
shared-network name {
        option domain-name                        "company.voip.nl";
#        option ntp-servers        --need to work out proper context later --  "0.nl.pool.ntp.org"  1.nl.pool.ntp.org  2.nl.pool.ntp.org  3.nl.pool.ntp.org;
        option time-offset                        7200; #Central European Time  +0200 UTC

        #RNL6677 = colocation
        subnet 10.1.0.0 netmask 255.255.252.0 {
                option routers                        10.1.0.1;
                option subnet-mask                255.255.252.0;
                range dynamic-bootp                10.1.0.32 10.1.0.35; #4 hosts for guest on the VOIP network and testing
                default-lease-time                21600; #6 hours
                max-lease-time                        43200; #12 hours       
        }

# next part is not active yet
        #RNL1519 = zwolle
#        subnet 10.12.0.0 netmask 255.255.252.0 {
#                option routers                        10.12.0.1;
#                option subnet-mask                255.255.252.0;
#                range dynamic-bootp                10.12.0.32 10.12.0.160; #128 hosts
#                default-lease-time                21600; #6 hours
#                max-lease-time                        43200; #12 hours       
#        }
}

/etc/sysconfig/dhcpd looks like:
Code:

# Command line options here
# blank foor all
DHCPDARGS=ETH0

When I start (try to) dhcpd via the service interface or via the prompt
as
Code:

service dhcpd start
I get an [FAILED] message and the following is in /var/log/messages
Code:

Jun  7 10:07:26 localhost dhcpd: Internet Systems Consortium DHCP Server V3.0.5-RedHat
Jun  7 10:07:26 localhost dhcpd: Copyright 2004-2006 Internet Systems Consortium.
Jun  7 10:07:26 localhost dhcpd: All rights reserved.
Jun  7 10:07:26 localhost dhcpd: For info, please visit http://www.isc.org/sw/dhcp/
Jun  7 10:07:26 localhost dhcpd: Wrote 1 leases to leases file.
Jun  7 10:07:26 localhost dhcpd:
Jun  7 10:07:26 localhost dhcpd: No subnet declaration for ETH0 (0.0.0.0).
Jun  7 10:07:26 localhost dhcpd: ** Ignoring requests on ETH0.  If this is not what
Jun  7 10:07:26 localhost dhcpd:    you want, please write a subnet declaration
Jun  7 10:07:26 localhost dhcpd:    in your dhcpd.conf file for the network segment
Jun  7 10:07:26 localhost dhcpd:    to which interface ETH0 is attached. **
Jun  7 10:07:26 localhost dhcpd:
Jun  7 10:07:26 localhost dhcpd:
Jun  7 10:07:26 localhost dhcpd: Not configured to listen on any interfaces!
Jun  7 10:07:26 localhost dhcpd:
Jun  7 10:07:26 localhost dhcpd: If you did not get this software from ftp.isc.org, please
Jun  7 10:07:26 localhost dhcpd: get the latest from ftp.isc.org and install that before
Jun  7 10:07:26 localhost dhcpd: requesting help.
Jun  7 10:07:26 localhost dhcpd:
Jun  7 10:07:26 localhost dhcpd: If you did get this software from ftp.isc.org and have not
Jun  7 10:07:26 localhost dhcpd: yet read the README, please read it before requesting help.
Jun  7 10:07:26 localhost dhcpd: If you intend to request help from the dhcp-server@isc.org
Jun  7 10:07:26 localhost dhcpd: mailing list, please read the section on the README about
Jun  7 10:07:26 localhost dhcpd: submitting bug reports and requests for help.
Jun  7 10:07:26 localhost dhcpd:
Jun  7 10:07:26 localhost dhcpd: Please do not under any circumstances send requests for
Jun  7 10:07:26 localhost dhcpd: help directly to the authors of this software - please
Jun  7 10:07:26 localhost dhcpd: send them to the appropriate mailing list as described in
Jun  7 10:07:26 localhost dhcpd: the README file.
Jun  7 10:07:26 localhost dhcpd:
Jun  7 10:07:26 localhost dhcpd: exiting.

But when I start the DHCPD on the comamnd prompt in debug mode it looks as follows:
Code:

[root@localhost ~]# /usr/sbin/dhcpd -d -f
Internet Systems Consortium DHCP Server V3.0.5-RedHat
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
Wrote 1 leases to leases file.
Listening on LPF/eth0/00:23:7d:a2:2b:d0/name
Sending on  LPF/eth0/00:23:7d:a2:2b:d0/name
Sending on  Socket/fallback/fallback-net

and /var/log/messages shows:
Code:

Jun  7 10:09:02 localhost dhcpd: Internet Systems Consortium DHCP Server V3.0.5-RedHat
Jun  7 10:09:02 localhost dhcpd: Copyright 2004-2006 Internet Systems Consortium.
Jun  7 10:09:02 localhost dhcpd: All rights reserved.
Jun  7 10:09:02 localhost dhcpd: For info, please visit http://www.isc.org/sw/dhcp/
Jun  7 10:09:02 localhost dhcpd: Wrote 1 leases to leases file.
Jun  7 10:09:02 localhost dhcpd: Listening on LPF/eth0/00:23:7d:a2:2b:d0/name
Jun  7 10:09:02 localhost dhcpd: Sending on  LPF/eth0/00:23:7d:a2:2b:d0/name
Jun  7 10:09:02 localhost dhcpd: Sending on  Socket/fallback/fallback-net

What am I doing wrong, what am I missing?
Why does the system ask a declaration for eth0 0.0.0.0?



Thanks Jan-Willem.

dracuss 06-07-2010 03:51 AM

Jwsnl, you must first configure your DHCP server. Try http://www.yolinux.com/TUTORIALS/DHCP-Server.html, there you will find brief instructions about how to do this.
Good Luck!

jwsnl 06-07-2010 04:08 AM

Quote:

Originally Posted by dracuss (Post 3995118)
Jwsnl, you must first configure your DHCP server. Try http://www.yolinux.com/TUTORIALS/DHCP-Server.html, there you will find brief instructions about how to do this.
Good Luck!

:(:confused:
I don't understand.. I believe I configured it.
There is a dhcp.conf file (see my posts) and when it run manually in debug modus I receive proper IP configuartion on the client.

jwsnl 06-07-2010 06:47 AM

Hi all,

It's maybe not the best solution as I will never know what went wrong but I simply reinstalled CentOS from scratch and it works fine now.

For me: Case closed


All times are GMT -5. The time now is 10:53 PM.