LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 07-05-2008, 06:01 AM   #1
tanveer
Member
 
Registered: Feb 2004
Location: e@rth
Distribution: RHEL-3/4/5,Gloria,opensolaris
Posts: 489

Rep: Reputation: 37
Delay in SSH login & find apache server configure option


Hi all,
I have a server in which it takes long time like 10/15 seconds to get the ssh login prompt. But on the same ip block of that server I can login on others instantly. The server is running java based applications like tomcat and squid with a routing of two different networks; one for internal lan and other for external.

And one more thing how to find out with what options apache was configured on default installation of apache with redhat?
Like with squid -v we can with what options squid was configured, phpinfo() function for php.
With httpd -V it gives
PHP Code:
Server compiled with....
 -
D APACHE_MPM_DIR="server/mpm/prefork"
 
-D APR_HAS_SENDFILE
 
-D APR_HAS_MMAP
 
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -
D APR_USE_SYSVSEM_SERIALIZE
 
-D APR_USE_PTHREAD_SERIALIZE
 
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 
-D APR_HAS_OTHER_CHILD
 
-D AP_HAVE_RELIABLE_PIPED_LOGS
 
-D DYNAMIC_MODULE_LIMIT=128
 
-D HTTPD_ROOT="/etc/httpd"
 
-D SUEXEC_BIN="/usr/sbin/suexec"
 
-D DEFAULT_PIDLOG="logs/httpd.pid"
 
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 
-D DEFAULT_LOCKFILE="logs/accept.lock"
 
-D DEFAULT_ERRORLOG="logs/error_log"
 
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
 
-D SERVER_CONFIG_FILE="conf/httpd.conf" 
I wanted the configure option that we use to configure when compile manually.

Thanks.
 
Old 07-05-2008, 09:42 AM   #2
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,094
Blog Entries: 2

Rep: Reputation: 111Reputation: 111
Make sure your /etc/resolv.conf is pointing to real dns servers
 
Old 07-06-2008, 11:32 AM   #3
apnicservices
LQ Newbie
 
Registered: Jul 2008
Location: London, UK
Distribution: Debian
Posts: 23

Rep: Reputation: 16
This is nothing to do with httpd or ssh, it's your DNS config. As posted above make sure that your /etc/resolv.conf contains real working name servers and also make sure that the host can resolve it's own name, either through valid DNS lookup or preferably through /etc/hosts
 
Old 07-07-2008, 06:00 AM   #4
tanveer
Member
 
Registered: Feb 2004
Location: e@rth
Distribution: RHEL-3/4/5,Gloria,opensolaris
Posts: 489

Original Poster
Rep: Reputation: 37
On that same IP block there are other servers too which have the same resolv.conf as like that one. But only this is taking around 20 secs to login after entering password in ssh.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache configure option crash_override_me Linux - Software 6 06-20-2008 12:18 PM
can't login via ssh when apache is under heavy load SPGWhistler Linux - Software 2 03-31-2007 04:05 AM
C# delay option? itz2000 Programming 1 05-12-2006 02:50 AM
Delay in SSH login.. lingeek Linux - Security 2 04-04-2006 05:38 PM
xinetd + ssh = login delay Shawn_Lewis Linux - Networking 0 08-19-2005 03:26 PM


All times are GMT -5. The time now is 07:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration