LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 07-21-2010, 11:58 AM   #1
csterling
LQ Newbie
 
Registered: Jul 2010
Posts: 2

Rep: Reputation: 0
Debian 5.0.5 AMD64 unable to access Windows 7 shares via Samba/cifs


Good day,

My first post, all right well I've been crawling the web for ages and can't find out why this doesn't work.

I installed Debian AMD64, I did not fiddle too much with the samba packages except once removing them and reinstalling them in hope that it would reset some configuration.

The problem doesn't seem to entirely lie with Samba as it accessed Windows XP shares easily through the gnome "Connect to server" panel.
Windows 7 shares simply stop with an error.

I therefore tried mount.cifs //PC-NAME/Folder /mnt/folder -o username=user,password=usrpsswd
It then comes back with mount error 12 = Cannot allocate memory

Could somebody please help me understand and learn so that I can deploy Debian properly on my machine.
Thank you
 
Old 07-21-2010, 01:39 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
A quick google yielded this. It's a bit dated, but this makes it sound like it may be a problem on the windows side. Maybe check your log files on both systems and see if you have a similar error. The registry key fix might or might not apply to Win7 though...
 
Old 07-21-2010, 01:42 PM   #3
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
I also found this buried in a Ubuntu forum
Code:
darkkith
November 5th, 2009, 02:35 PM
I tried the fix indicated in this page, and it seems to have resolved the issue for me. I removed the IRPacket regkey from above, and applied this...

http://alan.lamielle.net/2009/09/03/windows-7-nonpaged-pool-srv-error-2017

basically:

set this to '1'
HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

set this to '3'
HKLM\SYSTEM\CurrentControlSet\Services\LanmanServe r\Parameters\Size
 
Old 07-21-2010, 02:24 PM   #4
csterling
LQ Newbie
 
Registered: Jul 2010
Posts: 2

Original Poster
Rep: Reputation: 0
FIXED:

http://alan.lamielle.net/2009/09/03/...srv-error-2017
"Apparently you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly. Set the following registry key to ‘1′:

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and set the following registry key to ‘3′:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size"

Although far from ideal, will test on other machines, hope the problem isn't universal with all Windows 7 PC's
 
Old 06-07-2011, 06:31 AM   #5
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,051

Rep: Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100
I just went through a similar problem, that seems to have the same solution. I was wondering if anyone has any more detail on what that parameter in W7 actually does.

Microsoft pages I read while researching the issue (but now can't find again) say something like: the default value of 1 optimizes the system for local use and 3 optimizes for use as a server.

My W7 system will be used almost exclusively as a local workstation and only occasionally have intensive use of a share by Windows or Linux computers on the LAN. I don't want to leave a setting that will reduce performance as a workstation.

This system has 8 cores and 12GB of ram. In prior versions of Windows, there were settings that tuned for better "server" performance that were described as giving worse "workstation" performance, but actually only gave worse performance on systems that were seriously short of physical ram. If this setting in W7 is like that, I don't need to worry about it, because this system has enough physical ram. But I would have thought in 64 bit Windows 7, Microsoft would no longer be expecting most users to have too little ram.

Background:

I have a large project directory with tens of thousands of source files and a complicated combination of shell script and build system to compile it all in any one of a large selection of tool sets (combination of compiler and target architecture), generating the intermediate files and binaries into subdirectories unique to each tool set (so the project can be built any combination of different ways coexisting in one directory tree from one set of source code).

Most of the tool sets run on the local Windows system. But I occasionally mount that entire Windows directory tree (via SMB) into Linux (running elsewhere in the LAN) and build with a tool set on Linux, but with all the build scripts, source files, intermediate files and final binaries kept within that directory on Windows.

After switching from a much less powerful computer running XP64 to the current computer running W7, it stopped working. The script started properly and ran about a thousand compiles then failed with
/bin/bash: ./makesim.sh: Cannot allocate memory
On subsequent restarts, it made significantly less further progress each time before hitting that error until it was making zero progress.

From that same time, I found in dmesg many errors looking like
kernel: CIFS VFS: Unexpected lookup error -12

After a lot of research, I changed the registry key
“HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size” to “3″ then restarted the "server" service.

The problem seems to be fixed. I ran a build session that averaged three times as much simultaneous file I/O as the original failing session and even that works.

So my main question is whether to set this registry setting back to 1 for the likely multi-week period before the next time I need to mount that directory on Linux, or whether it is OK to just leave it set to 3 all the time.
 
  


Reply

Tags
debian, smb, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to access Windows shares or printer over network MrCode Linux - General 4 12-20-2009 07:07 PM
[SOLVED] Windows Server 2003 clients periodically unable to read CIFS shares AdamDaughterson Linux - Server 3 08-10-2009 09:53 AM
Unable to see shares on samba server - no authentication access desired (open access) neoelf Linux - Networking 1 06-14-2009 03:18 PM
samba - unable to browse windows shares by name Aoxo Linux - Networking 2 04-30-2009 10:33 AM
LXer: Automatically mounting and unmounting Samba/Windows shares with CIFS LXer Syndicated Linux News 0 07-27-2007 11:01 AM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration