LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 06-24-2012, 06:03 AM   #1
Iyyappan
Member
 
Registered: Dec 2008
Location: Chennai, India
Distribution: CentOS 5, SLES 11
Posts: 229

Rep: Reputation: 4
Connection Refused error while sending mail using mutt and msmtp


Hi,
I have installed mutt and mstmp in a server. mutt and .msmtp conf is as follows

.muttrc
set sendmail="/usr/local/bin/msmtp -C /home/oracle/.msmtprc --logfile=/tmp/msmtp.log"
set realname="Alerts"
set from=alerts@domain.com
set envelope_from=yes

.msmtprc
account default
host *.*.*.*
from alerts@domain.com

Both have 600 rights and correct owner and group. But i am unable to receive mail.
I tried sending mail using telnet smtphost 25. In log i get the following error messages in mail server logs


Error
Jun 24 18:40:17 s608897hk7sl01 sendmail[13135]: q5OGeHfM013135: from=<alerts@domain.com>, size=328, class=0, nrcpts=1, msgid=<20120624083527.GA2267@domain.com>, proto=ESMTP, daemon=MTA, relay=[10.90.14.251]
Jun 24 18:40:18 s608897hk7sl01 sendmail[13139]: q5OGeHfM013135: to=<mail@mail.com>, delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=120328, relay=mail.domain.com. [*.*.*.*], dsn=4.0.0, stat=Deferred: Connection refused by mail.domain.com .


Kindly provide some help to solve this issue
 
Old 06-24-2012, 06:59 AM   #2
Zetec
Member
 
Registered: Jul 2006
Distribution: Debian, Ubuntu, W7, openSUSE, Centos
Posts: 152

Rep: Reputation: 25
Is sendmail installed? If it is disable it (unless mutt needs it).

What is the result of: telnet localhost 25
 
Old 06-30-2012, 04:49 AM   #3
Iyyappan
Member
 
Registered: Dec 2008
Location: Chennai, India
Distribution: CentOS 5, SLES 11
Posts: 229

Original Poster
Rep: Reputation: 4
Found the issue, actually the smtp server ip which i had used was a secondary ip. Afteer opening smtp port for the primary ip, it started to work. thanks a lot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
udevadm(13611) error sending message:connection refused pixo Mandriva 1 05-01-2011 03:46 PM
msmtp/mutt trouble sending mail (server message: 451 4.4.1) Phieth6o Linux - Software 1 12-23-2009 02:23 PM
ERROR: connect to mail.*******.com[*.*.*.*]:25: Connection refused advolente Linux - Server 4 03-30-2009 09:59 PM
cmdline: Sending email without mutt and with msmtp something? frenchn00b Linux - Newbie 3 03-02-2008 01:11 AM


All times are GMT -5. The time now is 07:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration