LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-02-2007, 07:09 AM   #1
eypros
Member
 
Registered: Jun 2005
Location: Salonica
Distribution: Xubuntu
Posts: 40

Rep: Reputation: 15
Conflict problem installing MySQL from rpm


Happy new year to everyone!

Well I am facing a problem with the installation MySQL.

Firstly I tried from source. Something went wrong and though installed
I could not run it. Anyway I couldn't find a solution and used

make unistall to unistall it.

It appeared to be working.

Then I tried rpm:

rpm -Uhv /media/CDRoot/mysql_dynamically/MySQL-client-5.0.27-0.glibc23.i386.rpm

I used it from a CD named CDRoot so that's the name.
Error message said it conflicted with some files:

file /usr/bin/mysql from install of MySQL-client-5.0.27-0.glibc23 conflicts with file from package mysql-5.0.18-2.1

And some other similar messages.

I manually deleted those files but the error message continues! Am I doing something wrong? I need to update some files to let them know that those files don't exist any more?

How am I going to install MySQL?

Any suggestion welcome!
 
Old 01-02-2007, 07:37 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Are you sure you haven't already installed MySQL by rpm earlier. For that message, it probably is in the rpm database. You listed both Fedora and SuSE as your distro. Look in the software manager program and see what it says.
 
Old 01-29-2007, 01:16 AM   #3
eypros
Member
 
Registered: Jun 2005
Location: Salonica
Distribution: Xubuntu
Posts: 40

Original Poster
Rep: Reputation: 15
I just wanted to say a delayed thanks to jschiwal!

After all it was installed a previous version of MySQL!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mysql dependency/conflict problem... danscrima Linux - Newbie 4 10-30-2006 06:13 PM
problem installing Mysql from rpm. hottdogg Slackware 8 06-24-2006 09:54 PM
installing mysql and php4 results in a conflict bshearer *BSD 3 04-29-2005 02:36 PM
Installing apt on c2t3 - rpm conflict - no clue? Pacifix Fedora 7 05-07-2004 03:31 AM
MySQL mysql-3.23.56-1.9, rpm install problem jacsmith510 Linux - Newbie 3 09-19-2003 02:02 PM


All times are GMT -5. The time now is 03:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration