LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Configuring and Email Server with Squirrelmail, sendmail and dovecot. (http://www.linuxquestions.org/questions/linux-server-73/configuring-and-email-server-with-squirrelmail-sendmail-and-dovecot-542535/)

ashesh0326 04-01-2007 11:35 PM

Configuring and Email Server with Squirrelmail, sendmail and dovecot.
 
Hi guys,
I'm new to linux (I'm using FC 6) and it's been quite a while since I've been trying to figure out a way to set up my email server on my own domain.
I wanted to work on it using Squirrelmail, dovecot, and sendmail. And I've done all the needful to get things up and working.
However, since the squirrelmail documentation tells people to test their configuration by typing http://mydomain/sqmail/configtest.php, I've done the same, and I get the following output:
SquirrelMail configtest
This script will try to check some aspects of your SquirrelMail configuration and point you to errors whereever it can find them. You need to go run conf.pl in the config/ directory first before you run this script.
SquirrelMail version: 1.4.9a
Config file version: 1.4.0
Config file last modified: 01 April 2007 22:37:53
Checking PHP configuration...
PHP version 5.1.6 OK.
PHP extensions OK.
Checking paths...
Data dir OK.
Attachment dir is the same as data dir.
Plugins are not enabled in config.
Themes OK.
Default language OK.
Base URL detected as: http://mail.ashesh.homeip.net/src (location base autodetected)
Checking outgoing mail service....
sendmail OK
Checking IMAP service....

ERROR: Error connecting to IMAP server "127.0.0.1:143".Server error: (13) Permission denied


I've tried fiddling with the dovecot.conf file, and I've checked and rechecked everything, but it's not going any further. I've even confirmed the port numbers and have fed all that in my squirrelmail configuration as well.

Can anyone please help me out here? What is wrong? Have I missed something? (thanks in advance. I'll look forward to your replies.)

ashesh0326 04-01-2007 11:59 PM

Ah, I think it was SELinux which was causing the problems. I disabled it and things work fine now.
However, I would like to keep SELinux working. Any ideas whats going wrong and where?

billymayday 04-02-2007 05:09 AM

You probably want to start a new thread (perhaps under security) with a thread highlighting dovecot/squirrelmail and SELinux

Au_Squirrel 04-02-2007 05:31 AM

You may wish to checkout www.brennan.id.au as it has a section that covers what you are talking about.

Regards

ashesh0326 04-02-2007 10:48 AM

Allright, so far so good. I visited the link you referred me to, and yes it was extremely helpful. For the first time, I can access my inbox etc. properly.
I can also send messages to all users, but cannot receive any email from any other domain (gmail for instance.)
Can you tell me whats the problem?

Thanks a lot for the advice, both of you.

Au_Squirrel 04-02-2007 02:52 PM

I am assuming that you have a domain name. If so have you pointed your internet domain name to your mail server?

Also I will need you to post a desciption of your network. Are you using a ADSL router modem? Do you have a static IP address? Are you using a DDNS service for your domain name? If your linux server is not your gateway, have you set up port forwarding to make port 25 visible to the internet? Check out the first network set-up chapters in the guide.

If not, you will need to register a domain name and then implement the DNS to refer to it.

As a test, determine your internet IP address and send a message to it.

Regards

ashesh0326 04-08-2007 01:15 AM

I'm really really sorry for the late response. I was out of town for a few days.
Anyways, that link really helped me a lot. It was fun at the same time. And I learnt a lot too.
Thank you so much.


All times are GMT -5. The time now is 01:23 AM.