LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 09-29-2010, 04:46 AM   #1
sokha
Member
 
Registered: Sep 2008
Posts: 46

Rep: Reputation: 15
Question CentOS + Qmailtoaster - how to disable clamd?


Hi,

I run CentOS (under OpenVZ). I setup qmailtoaster a few weeks ago and it is working fine with 386MB ram VPS (including mysql, lighttpd). I noticed that clamd process consumes much memory. I think it is not really needed.

Is it possible to disable it without reinstall qmailtoaster?

Thanks,
 
Old 10-12-2010, 01:59 PM   #2
amarand
LQ Newbie
 
Registered: Oct 2010
Location: Galloway, Ohio, USA
Distribution: CentOS
Posts: 16

Rep: Reputation: 7
Lightbulb Disable Clamd on Qmailtoaster

Quote:
Originally Posted by sokha View Post
Hi,

I run CentOS (under OpenVZ). I setup qmailtoaster a few weeks ago and it is working fine with 386MB ram VPS (including mysql, lighttpd). I noticed that clamd process consumes much memory. I think it is not really needed.

Is it possible to disable it without reinstall qmailtoaster?

Thanks,
I found mention of this on the qmailtoaster list:

http://www.mail-archive.com/qmailtoa.../msg17919.html

Check for the directory:

/var/qmail/supervise/clamd

If it exists, move or remove the directory (I would back it up to be safe).

Shutdown qmailtoaster and make sure clamd stopped. If clamd doesn't stop, kill the process nicely with the default TERM signal (kill pid) and then check again. If it still doesn't stop, you may wish to kill the process with the INT or KILL signals (kill -INT pid or kill -KILL pid).

Myself, I prefer to just restart the server, to make sure clamd won't start-up automatically after a system reboot, but that's just me.

Also, keep in mind that clamd can ship and execute separately from qmailtoaster, so make sure your clamd is being started by qmailtoaster and not from somewhere else (init.d, chkconfig, rc.d scripts).

Hope this helps!
 
Old 10-13-2010, 01:32 AM   #3
sokha
Member
 
Registered: Sep 2008
Posts: 46

Original Poster
Rep: Reputation: 15
Thank you for your solution. I have done that by rename that directory and reboot the server. It reduces some of the memory consumption but I still see the process from: /usr/sbin/clamd is running

Code:
clamav   29854  4.8 25.2 116488 99172 ?        Sl   13:28   0:10 /usr/sbin/clamd
 
Old 10-13-2010, 01:44 AM   #4
sokha
Member
 
Registered: Sep 2008
Posts: 46

Original Poster
Rep: Reputation: 15
I just figured it out, I have to completely move the directory /var/qmail/supervise/clamd to somewhere else. By just renaming it to /var/qmail/supervise/clamd_something, the clamd will still be running.

Thanks again.
 
  


Reply

Tags
centos, qmail


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
QmailToaster + Clamd + Spamassassin + LDAP furquan Linux - Server 2 09-28-2010 07:32 AM
Disable Disk Check - CentOS deibertine Linux - Newbie 4 08-09-2010 01:00 PM
LXer: How To Install Qmailtoaster (CentOS 5.3) LXer Syndicated Linux News 0 06-19-2009 01:12 PM
QmailToaster mschimidt Linux - Server 0 11-07-2008 10:23 PM
Help trying to set up Qmailtoaster on a Centos 5 box rptan2000 Linux - Newbie 1 02-08-2008 08:55 PM


All times are GMT -5. The time now is 02:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration