LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   CentOS 5 squid: error while loading shared libraries (http://www.linuxquestions.org/questions/linux-server-73/centos-5-squid-error-while-loading-shared-libraries-858095/)

ajitabhpandey 01-23-2011 01:13 AM

CentOS 5 squid: error while loading shared libraries
 
Hi,

I installed squid on the CentOS 5 server. When I try to start squid I am receiving following error:

# service squid start
init_cache_dir /var/spool/squid... Starting squid: [FAILED]

The logs indicate the following:

$ sudo tail /var/log/squid/squid.out
squid: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: Permission denied
squid: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: Permission denied
squid: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: Permission denied
squid: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: Permission denied
squid: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: Permission denied
squid: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: Permission denied

Although, all the libraries which are shown as missing are present, but still I am seeing the following.

$ ldd /usr/sbin/squid
linux-vdso.so.1 => (0x00007fffb95ff000)
libcrypt.so.1 => not found
libssl.so.6 => not found
libcrypto.so.6 => not found
libdl.so.2 => not found
libz.so.1 => not found
librt.so.1 => not found
libpthread.so.0 => not found
libm.so.6 => not found
libnsl.so.1 => not found
libc.so.6 => not found

I have tried setting the environment variable LD_LIBRARY_PATH

$ echo $LD_LIBRARY_PATH
/lib64:/usr/lib64:/lib:/usr/lib

But still no use.

Any help/pointers will be appreciated.

John VV 01-23-2011 03:46 AM

just HOW did you install squid ???
it is in the base repo

Code:

$ yum search squid
Loaded plugins: downloadonly, fastestmirror, priorities
rpmforge                                                            10152/10152
rpmforge-extras                                                        119/119
================================ Matched: squid ================================
squidguard-blacklists.noarch : Regularly updated blacklists for use with
                            : squidguard
squid.x86_64 : The Squid proxy caching server.
awstats.noarch : Powerful and fullfeatured server logfile analyzer
calamaris.noarch : Squid native log format (NLF) analyzer and report generator
sarg.x86_64 : Squid usage report generator per user/ip/name
squidguard.x86_64 : Combined filter, redirector and access controller plugin for
                  : squid
tinyproxy.x86_64 : Lightweight, non-caching, optionally anonymizing HTTP proxy


~]$ yum info squid
Loaded plugins: downloadonly, fastestmirror, priorities
Available Packages
Name      : squid
Arch      : x86_64
Epoch      : 7
Version    : 2.6.STABLE21
Release    : 6.el5
Size      : 1.3 M
Repo      : base
Summary    : The Squid proxy caching server.
License    : GPL
Description: Squid is a high-performance proxy caching server for Web clients,
          : supporting FTP, gopher, and HTTP data objects. Unlike traditional
          : caching software, Squid handles all requests in a single,
          : non-blocking, I/O-driven process. Squid keeps meta data and
          : especially hot objects cached in RAM, caches DNS lookups, supports
          : non-blocking DNS lookups, and implements negative caching of failed
          : requests.
          :
          : Squid consists of a main server program squid, a Domain Name System
          : lookup program (dnsserver), a program for retrieving FTP data
          : (ftpget), and some management and client tools.

and how did you set up the service ?
for gnome - if installed
Code:

su -
system-config-services

and but a check in it

ajitabhpandey 01-24-2011 09:30 PM

Quote:

Originally Posted by John VV (Post 4234721)
just HOW did you install squid ??

and how did you set up the service ?
for gnome - if installed

Yes I installed squid from base, a simple

Code:

# yum install squid
I configured the /etc/squid/squid.conf manually. No GUI on the server.

SELinux is enabled, but I have put it into permissive mode, which still gives me the same problem, so it is not an issue.


All times are GMT -5. The time now is 11:35 PM.