LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-10-2011, 06:36 AM   #1
yoachan
Member
 
Registered: Nov 2009
Posts: 107

Rep: Reputation: 16
CentOS 5.5 x64 PHP Upgrade


Dear all,

I have a new box using CentOS 5.5 64 bit.
Installed out of the box PHP 5.1.6.

I need to upgrade PHP to exactly 5.2.10.
Is there any way I can upgrade my PHP to this specific version, instead of the latest PHP 5.2.17?

The reason I need to have this specific version is I want to make a development environment that exactly the same with my production web host.

Any help appreciated.

regards,

Yoachan
 
Old 02-10-2011, 08:01 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,883

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Hi,

You can get the packages for php-5.2.10-1 from here.
But I think you should go with 5.2.17 if you absolutely need to use php-5.2.x. See the Changelog for any updates between those versions that might brake your development environment.

Regards
 
Old 02-10-2011, 09:06 AM   #3
yoachan
Member
 
Registered: Nov 2009
Posts: 107

Original Poster
Rep: Reputation: 16
@bathory:

thanks for your reply,
I will contact my vendor to upgrade their php, and when they are ready, we will upgrade our php directly to 5.2.17 as you suggested.
And if I were to upgrade to 5.2.17, which repository should I use? I think compiling from source would be a pain...

again, thanks for your help.

regards,

Yoachan
 
Old 02-10-2011, 11:03 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,883

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Hi,

You can use remi repo.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade from PHP Version 4.3.9 to PHP 5.2 on CentOS nuttynibbles Linux - Software 10 06-15-2010 02:35 PM
Firefox Update In CentOS x64 athomas Linux - Software 8 04-03-2010 08:06 PM
Can't get CentOS 5.4 x64 GUI to run Mustafa Ismail Mustafa Linux - General 12 01-19-2010 01:03 AM
LVM needs e2fsck after Upgrade from Kubuntu 8.10 x64 to 9.04 x64 don_wombat_73 Linux - Newbie 6 04-30-2009 04:13 PM


All times are GMT -5. The time now is 03:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration