LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 11-19-2012, 05:16 AM   #1
Usalabs
Member
 
Registered: Jan 2004
Distribution: Ubuntu Lucid (LTS)
Posts: 108

Rep: Reputation: 15
Cannot set apache to auto start at boot (OpenSuSe)


Up until yesterday, I didn't realize anything was wrong until someone emailed me and said they couldn't access my website (hosted on my home OpenSuSe server), so I checked and found apache had stopped, now here's the problem, I can manually start apache as root with:- /etc/init.d/apache2 start but, somehow it is not in the autostart sequence, using as root:- chkconfig -add apache2 results in:-

insserv: loop involving service apache at depth 4
insserv: exiting now, without changing boot order
/sbin/insserv failed, exit code 1
apache2 0:off 1:off 2:off 3:off 4:off 5:off 6:off

What file is used by chkconfig? So that I can manually add apache to it and force insserv to run apache at boot time.

Last edited by Usalabs; 11-19-2012 at 05:17 AM.
 
Old 11-19-2012, 06:54 AM   #2
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Slack14_64_Multilib
Posts: 2,720
Blog Entries: 3

Rep: Reputation: 626Reputation: 626Reputation: 626Reputation: 626Reputation: 626Reputation: 626
Have you tried setting it's start options in YaST?
 
Old 11-19-2012, 07:03 AM   #3
Usalabs
Member
 
Registered: Jan 2004
Distribution: Ubuntu Lucid (LTS)
Posts: 108

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Habitual View Post
Have you tried setting it's start options in YaST?
Yes, I set HTTPD as active and set it to run at boot time, then applied settings, but when I re-checked the settings in yast, the 'Run at boot time' box became unchecked, and chkconfig apache2 showed:- apache2 off and chkconfig -list showed apache2 off on all runlevels, I even rebooted the server, and usually apache2 is running on runlevel 3 and 5, even after the reboot, all runlevels show apache2 as off
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
opensuse 12.1 - how do I set up a dual sendmail service start? lpacor Suse/Novell 0 02-26-2012 08:57 AM
How to Set Service Start Priority in OpenSUSE 11.1 k_oudom Suse/Novell 6 11-04-2009 08:17 AM
Auto start problem Apache pronov Linux - Newbie 1 08-07-2009 02:49 AM
apache auto start-up aztek Linux - Newbie 3 05-29-2006 01:53 AM
How do I auto start modules that aren't auto loaded on boot? darkbluedrew Debian 2 09-18-2005 09:10 AM


All times are GMT -5. The time now is 01:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration