LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Cannot set apache to auto start at boot (OpenSuSe) (http://www.linuxquestions.org/questions/linux-server-73/cannot-set-apache-to-auto-start-at-boot-opensuse-4175437772/)

Usalabs 11-19-2012 05:16 AM

Cannot set apache to auto start at boot (OpenSuSe)
 
Up until yesterday, I didn't realize anything was wrong until someone emailed me and said they couldn't access my website (hosted on my home OpenSuSe server), so I checked and found apache had stopped, now here's the problem, I can manually start apache as root with:- /etc/init.d/apache2 start but, somehow it is not in the autostart sequence, using as root:- chkconfig -add apache2 results in:-

insserv: loop involving service apache at depth 4
insserv: exiting now, without changing boot order
/sbin/insserv failed, exit code 1
apache2 0:off 1:off 2:off 3:off 4:off 5:off 6:off

What file is used by chkconfig? So that I can manually add apache to it and force insserv to run apache at boot time.

Habitual 11-19-2012 06:54 AM

Have you tried setting it's start options in YaST?

Usalabs 11-19-2012 07:03 AM

Quote:

Originally Posted by Habitual (Post 4832525)
Have you tried setting it's start options in YaST?

Yes, I set HTTPD as active and set it to run at boot time, then applied settings, but when I re-checked the settings in yast, the 'Run at boot time' box became unchecked, and chkconfig apache2 showed:- apache2 off and chkconfig -list showed apache2 off on all runlevels, I even rebooted the server, and usually apache2 is running on runlevel 3 and 5, even after the reboot, all runlevels show apache2 as off


All times are GMT -5. The time now is 01:39 AM.