LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 03-19-2009, 06:05 PM   #1
htamayo
Member
 
Registered: Jan 2005
Location: san salvador, el salvador
Distribution: Debian Stable, UbuntuStudio Karmic Koala
Posts: 190

Rep: Reputation: 30
can't copy/paste files in samba share directory


Hi, I use Debian Lenny with Samba 3.2.4. I'm publishing a directory for my windows user, they can access to it, view the files, but can't copy/paste from /to the directory, surely is a permission related issue, but i don't get where to set the properly permission, this is my conf of the samba.conf:

Code:
[platform]
comment = Info solo para registrados
path = /media/virtso/platform
valid users = jacobo
read only = no
browsable = no
public = no
create mode = 0750
writable = yes
I think that settip writable to yes it will work, but it doesn't, my question is: what flag do I have to set up correctly to copy/paste execute files in this directoy?

all the best
 
Old 03-19-2009, 08:06 PM   #2
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
The user jacobo has to be a valid user on the linux system, and have a valid samba password which is the same as the windows password that the user is using when he/she logs in. So to setup a user in samba:

Code:
root@samba:# adduser jacobo
## if you don't want the user to have access to the linux box directly, do not enable the account. 
## look at man pages for adduser....
root@samba:# smbpasswd jacobo
Enter new password:
## Get the user to enter their valid windows password here, and confirm it again....
and thats more or less it! basically, you need to have a valid linux UID and GID which can be mapped by samba to a valid SMB UID and GID.

Last edited by irishbitte; 03-19-2009 at 08:08 PM.
 
Old 03-20-2009, 10:35 AM   #3
netman4ttm
Member
 
Registered: Aug 2007
Distribution: FreeBSD 8.0 xubuntu
Posts: 49

Rep: Reputation: 16
From the command prompt go to the shared directory
chmod 750 *
chown jacobo *
edit your smb.conf

add this line force user = jacobo to the [platform] definition
 
Old 03-20-2009, 02:34 PM   #4
htamayo
Member
 
Registered: Jan 2005
Location: san salvador, el salvador
Distribution: Debian Stable, UbuntuStudio Karmic Koala
Posts: 190

Original Poster
Rep: Reputation: 30
Well, I found the problem, it's all about file permissions, I thought that the config in samba was over the native permissions of linu, but that's wrong, All I needed was:
chmod g+r *

That's all

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant create or copy files to samba share Elnegro8 Linux - Server 27 07-16-2008 09:06 AM
[SOLVED] Bash Script to copy files to SAMBA Share bskrakes Linux - Newbie 4 07-03-2008 08:51 AM
copy files form windows app to samba share procfs General 1 07-19-2006 07:13 AM
How could i hide some files in the share directory(samba) whepin Linux - General 1 12-20-2001 08:10 AM


All times are GMT -5. The time now is 10:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration