LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 01-13-2009, 07:48 AM   #1
SimonT
Member
 
Registered: Oct 2004
Posts: 33

Rep: Reputation: 15
Can't Authenticate to squid proxy from XP machine


I am having to setup a proxy for the Office its been a while so please bare with me. I hope Maybe I am missing some thing easy :-)

I have setup and Installed squid but when I try and setup a windows xp SP2 FF3 user I am having problems Authenticating to the proxy. A user name and password box is displayed but the user is not Authenticated and the login pops up again. I am sure I am entering the correct user name and password.

Quote:
root@office:/etc/squid3# htpasswd /etc/squid3/squid_passwd NSWUSR
Re-type new password:
Updating password for user NSWUSR
This is my config file

Quote:
logfile_rotate 5
emulate_httpd_log yes
server_persistent_connections off
forwarded_for off

http_port 8080

auth_param basic program /usr/lib/squid3/ncsa_auth /etc/squid3/squid_passwd
acl ncsa_users proxy_auth REQUIRED
auth_param basic children 5
auth_param basic realm NSW2077 Office
auth_param basic credentialsttl 1 hours

acl user1 proxy_auth NSWUSR


tcp_outgoing_address 111.111.111.111 user1


acl manager proto cache_object

http_access allow ncsa_users
http_access allow user1
http_access allow all

request_header_access Allow allow all
request_header_access Authorization allow all
request_header_access WWW-Authenticate allow all
request_header_access Proxy-Authorization allow all
request_header_access Proxy-Authenticate allow all
request_header_access Cache-Control allow all
request_header_access Content-Encoding allow all
request_header_access Content-Length allow all
request_header_access Content-Type allow all
request_header_access Date allow all
request_header_access Expires allow all
request_header_access Host allow all
request_header_access If-Modified-Since allow all
request_header_access Last-Modified allow all
request_header_access Location allow all
request_header_access Pragma allow all
request_header_access Accept allow all
request_header_access Accept-Charset allow all
request_header_access Accept-Encoding allow all
request_header_access Accept-Language allow all
request_header_access Content-Language allow all
request_header_access Mime-Version allow all
request_header_access Retry-After allow all
request_header_access Title allow all
request_header_access Connection allow all
request_header_access Proxy-Connection allow all
request_header_access User-Agent allow all
request_header_access Cookie allow all
request_header_access All deny all


miss_access allow ncsa_users
http_reply_access allow ncsa_users
/etc/init.d/squid3 restart

But still can not login rejects the user each time


Quote:
root@vps:/etc/squid3# find / -name ncsa_auth
find: WARNING: Hard link count is wrong for /proc/sys/net: this may be a bug in
your filesystem driver. Automatically turning on find's -noleaf option. Earlie
r results may have failed to include directories that should have been searched.
/usr/lib/squid3/ncsa_auth
Running out of ideas Did I miss any thing :-) silly
 
Old 01-13-2009, 07:28 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
Have you checked Squid's access.log (cache.log and store.log might have info, but not as likely) for more info? I'm suspicious of an upper case username, but can't find any docs here to support that (you could also try qldusr since we're probably going to win State of Origin in a few months time )?

Sorry that's not more useful...
 
Old 01-13-2009, 09:24 PM   #3
SimonT
Member
 
Registered: Oct 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Its not true what they say about you guys from qld I think you cracked it looks like its a case issue with the user name ???


Not sure why
 
Old 01-15-2009, 12:29 AM   #4
SimonT
Member
 
Registered: Oct 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Is there any way to control the remote_port in Squid ?
 
Old 01-15-2009, 05:06 PM   #5
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
I'm not sure, did you mean this (from the Squid docs)?
Code:
Option Name:	htcp_port
Replaces:	
Requires:	--enable-htcp
Default Value:	htcp_port 0
Suggested Config: 	

#htcp_port 4827


	The port number where Squid sends and receives HTCP queries to
	and from neighbor caches.  To turn it on you want to set it to
	4827. By default it is set to "0" (disabled).
 
Old 01-16-2009, 06:03 PM   #6
SimonT
Member
 
Registered: Oct 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Hi Sorry this is the HTTP host header environment variable REMOTE_PORT


Quote:
<?php
echo $_SERVER['REMOTE_PORT'];
?>
 
  


Reply

Tags
proxy, squid, xp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wget with proxy,but authenticate fail willie118 Linux - Networking 9 01-17-2010 06:56 AM
Problem getting Ubuntu to authenticate through a proxy torgeir.nes Linux - Server 1 09-20-2007 04:25 AM
configure squid proxy with microsoft proxy as a parent proxy nintykola Linux - Software 1 08-28-2007 02:38 AM
wget won't authenticate with a MPS 2.0 Proxy graywind Linux - Networking 0 12-16-2003 02:49 AM


All times are GMT -5. The time now is 08:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration