LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-07-2010, 08:39 PM   #1
jhwilliams
Senior Member
 
Registered: Apr 2007
Location: Portland, OR
Distribution: Debian, Android, LFS
Posts: 1,168

Rep: Reputation: 207Reputation: 207Reputation: 207
BIND9: dig <hostname> doesn't work, dig <hostname.domain.tld> does.


Hi there.

I just setup a bind9 server. When I dig a hostname without a domain attached, I get no answer in response. When I dig hostname.domain.tld, I do get the correct response. nslookup, host, ping, etc. all work fine. But, they use resolv.conf. I think something is misconfigured with my zone files.

Any ideas?
 
Old 04-07-2010, 09:07 PM   #2
mweed
Member
 
Registered: Mar 2006
Posts: 33

Rep: Reputation: 17
by default dig does not use the domain / search domains in resolv.conf. Aside from the expected behaviour of dig is anything broken?
 
Old 04-09-2010, 01:01 PM   #3
jhwilliams
Senior Member
 
Registered: Apr 2007
Location: Portland, OR
Distribution: Debian, Android, LFS
Posts: 1,168

Original Poster
Rep: Reputation: 207Reputation: 207Reputation: 207
Hey mweed, thanks for the response. That's refreshing to hear, then. No -- I guess not. I have used systems where the following worked, however:

Code:
dig <hostname>
I guess I was just jealous. Since user's don't really use the dig command, it doesn't matter, I suppose.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Could someone explain to me the process of adding a hostname? (hostname.domain.com) brynjarh Linux - Server 2 10-18-2009 07:58 PM
bind9 - dig -x returns - status: SERVFAIL eliufoo Linux - Server 4 05-19-2008 10:29 AM
dig @ works, dig doesn't eelgueta Linux - Networking 6 07-09-2007 06:45 PM
"dig mx" and "ping google" do not work when bind9 runs.. why? alexxxis Linux - Software 4 01-07-2007 03:16 AM
dig will not work external to the bind nameserver stevemarci Linux - Newbie 4 06-12-2006 02:31 PM


All times are GMT -5. The time now is 08:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration