LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 04-17-2012, 07:00 AM   #1
newbiebd
LQ Newbie
 
Registered: Feb 2008
Posts: 18

Rep: Reputation: 0
Question Bind server not responding to client queries


Dear All,
Good Day.I have a linux server with CentOS release 5.4 (Final) in my network and i have installed Caching nameserver on it.It is working from that server. but when i use the server IP as DNS server on my windows client, it shows like follows,

C:\Users\Crown>nslookup
Default Server: UnKnown
Address: 192.168.1.15

> yahoo.com
Server: UnKnown
Address: 192.168.1.15

*** UnKnown can't find yahoo.com: No response from server

my config is like follows,

# resolve.conf
search dhakabd.net
nameserver 127.0.0.1

&
# named.conf

//
// named.caching-nameserver.conf
//
// Provided by Red Hat caching-nameserver package to configure the
// ISC BIND named(8) DNS server as a caching only nameserver
// (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//
// DO NOT EDIT THIS FILE - use system-config-bind or an editor
// to create named.conf - edits to this file will be lost on
// caching-nameserver package upgrade.
//
options {
listen-on port 53 { 127.0.0.1; };
listen-on-v6 port 53 { ::1; };
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";

// Those options should be used carefully because they disable port
// randomization
// query-source port 53;
// query-source-v6 port 53;

allow-query { localhost; };
allow-query-cache { localhost; };
// allow-query { any; };
// allow-query-cache { any; };
};
logging {
channel default_debug {
file "data/named.run";
severity dynamic;
};
};
view localhost_resolver {
match-clients { localhost; };
match-destinations { localhost; };
recursion yes;
include "/etc/named.rfc1912.zones";


Would you please give me solution for this problem?
 
Old 04-17-2012, 07:55 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Hi,

Comment out the following lines in named.conf:
Quote:
listen-on port 53 { 127.0.0.1; };
listen-on-v6 port 53 { ::1; };
allow-query { localhost; };
allow-query-cache { localhost; };
match-clients { localhost; };
match-destinations { localhost; };
Or you can replace any occurrence of localhost or 127.0.0.1 with any (if its an internal dns), or localnets

Regards
 
Old 04-17-2012, 08:54 AM   #3
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
Hi newbiebd,

In addition to bathory's answer
how it would be done:
Code:
/* You can allow specific networks like this if you need to */
allow-query { localnets; 192.168.1.0/24; };
allow-recursion { localnets; 192.168.1.0/24; };
this is just an example, adjust according to your needs.
 
Old 04-18-2012, 02:57 AM   #4
newbiebd
LQ Newbie
 
Registered: Feb 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by lithos View Post
Hi newbiebd,

In addition to bathory's answer
how it would be done:
Code:
/* You can allow specific networks like this if you need to */
allow-query { localnets; 192.168.1.0/24; };
allow-recursion { localnets; 192.168.1.0/24; };
this is just an example, adjust according to your needs.
thanks for your reply.I can resolve any domain from that server machine. but till not responding to client queries.
 
Old 04-18-2012, 03:47 AM   #5
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Quote:
thanks for your reply.I can resolve any domain from that server machine. but till not responding to client queries
Did you comment out those options from named.conf?
The way bind it's setup right now, it doesn't allow queries from hosts other than localhost
 
Old 04-18-2012, 09:07 AM   #6
newbiebd
LQ Newbie
 
Registered: Feb 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
Did you comment out those options from named.conf?
The way bind it's setup right now, it doesn't allow queries from hosts other than localhost
yes sir, i did it. but result is same as before .
 
Old 04-18-2012, 10:15 AM   #7
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Then check your firewall. It should allow port 53 udp/tcp traffic
 
Old 04-18-2012, 10:42 AM   #8
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
Of course you need to restart "named" too !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Caching-only name server to forward queries-Bind vwtech Linux - Software 1 02-14-2011 05:32 PM
Client computer not dig Bind server.Please help. gardenair Linux - Server 6 07-29-2010 09:06 AM
[SOLVED] named not responding to queries geek.ksa Linux - Server 3 02-24-2010 04:00 AM
Queries about bind... cj_cheema Linux - Server 1 04-11-2009 12:14 PM
Unable to bind client to server vathsan AIX 0 04-04-2009 10:04 AM


All times are GMT -5. The time now is 07:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration