LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   BIND reload (http://www.linuxquestions.org/questions/linux-server-73/bind-reload-738664/)

mario.almeida 07-08-2009 12:42 PM

BIND reload
 
Hi All,

When ever I make changes to the zone file either add or delete some entries and do a /etc/init.d/named reload changes are not taken place
Have to restart named for the changes to take effect.

OS = CentOS release 5.3 (Final)

Bind packages

bind-chroot-9.3.4-10.P1.el5
bind-utils-9.3.4-10.P1.el5
bind-9.3.4-10.P1.el5
system-config-bind-4.0.3-4.el5.centos
bind-libs-9.3.4-10.P1.el5
caching-nameserver-9.3.4-10.P1.el5_3.1

//Remy

rupertwh 07-08-2009 12:45 PM

Did you increase the serial number?

repo 07-08-2009 12:49 PM

Try to use
Code:

rndc reconfig
see also
man rndc and rndc -help

mario.almeida 07-08-2009 01:19 PM

Quote:

Originally Posted by repo (Post 3601204)
Try to use
Code:

rndc reconfig
see also
man rndc and rndc -help

Serial Number is increased

cat rndc.conf
# Start of rndc.conf
options {
default-key "rndckey";
default-server 127.0.0.1;
default-port 953;
};

server localhost {
key rndckey;
};

key "rndckey" {
algorithm hmac-md5;
secret "VVNS/NBXEoFat/B5GouL7A==";
};

cat rndc.key
# Use with the following in named.conf, adjusting the allow list as needed:
key "rndckey" {
algorithm hmac-md5;
secret "VVNS/NBXEoFat/B5GouL7A==";
};

What else could be the problem

//Remy

mario.almeida 08-03-2009 01:37 PM

Quote:

Originally Posted by mario.almeida (Post 3601243)
Serial Number is increased

cat rndc.conf
# Start of rndc.conf
options {
default-key "rndckey";
default-server 127.0.0.1;
default-port 953;
};

server localhost {
key rndckey;
};

key "rndckey" {
algorithm hmac-md5;
secret "VVNS/NBXEoFat/B5GouL7A==";
};

cat rndc.key
# Use with the following in named.conf, adjusting the allow list as needed:
key "rndckey" {
algorithm hmac-md5;
secret "VVNS/NBXEoFat/B5GouL7A==";
};

What else could be the problem

//Remy

had to remove
allow-update { localhost };
from the named.conf files under each zone
after that reload worked

any idea why after removing that entry it worked?


All times are GMT -5. The time now is 05:34 PM.