LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 06-26-2008, 03:06 PM   #1
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Rep: Reputation: 25
BIND and Unknown RR type "server"


Hi Guys,

Sorry Guys but disregard the title. It is a time out error message and not an unknown RR type

I am running ubuntu 8.04 server and I have installed BIND on it. I configured my named.conf.local file and my zones as well and everything seems to be ok. I checked with "named-checkconf /etc/bind/named.conf" and checked my zones and didn't get any error message.
Though my main PB at the moment, is that when I nslookup anaconda on my network which is my name server I get a time out error message and that is it. I have to say that I am really stuck so any type of help is much appreciated.

Regards,

I configured my zones as such

db.memoria.com
$TTL 7200
@ IN SOA anaconda.memoria.com. riganta.memoria.com. (
2008062400;
7200; Refresh
7200; Refresh
2419200; Expire
7200 ); Minimum

@ NS anaconda.memoria.com. ; name of server
@ORIGIN memoria.com.
anaconda IN A 172.16.203.128 ; IP Adress of the server

db.memoria.com.inv
$TTL 7200
@ IN SOA anaconda.memoria.com. riganta.memoria.com. (
2008062400 ; Serial
7200 ; refresh
7200 ; Retry
2419200 ; Expire
7200 ) ; Minimum

@ NS anaconda.memoria.com.

128 PTR anaconda.memoria.com.

db.127
$TTL 7200
@ IN SOA anaconda.memoria.com. riganta.memoria.com (
2008062400 ; Serial
7200 ; Refresh
7200 ; Retry
2419200 ; Expire
7200 ) ; Negative Cache TTL
;
@ IN NS anaconda.memoria.com
1.0.0 IN PTR localhost.

named.conf.local
zone "memoria.com" {
type master;
file "/etc/bind/db.memoria.com";
};

zone "203.16.172.in-addr.arpa" {
type master;
file "/etc/bind/db.memoria.com.inv";
};

zone "0.0.127.in-addr.arpa" {
type master;
file "/etc/bind/db.127";
};

I have changed my resolv.conf file. I put the nameserver anaconda with its IP address

This is how my resolv.conf looks like

search localdomain
nameserver 172.16.203.2
nameserver 172.16.203.128

I don't if this is a good at all so feel free to advise me on any change

Last edited by riganta; 06-26-2008 at 03:11 PM.
 
Old 06-27-2008, 08:18 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Quote:
Though my main PB at the moment, is that when I nslookup anaconda on my network which is my name server I get a time out error message and that is it.
You don't say if you're running nslookup on the box running bind, or from other computers in your network. Anyway make sure that bind is running and there is no firewall blocking access to port 53 (tcp/udp)
Also in order to be able to use nslookup using just the hostname and not the fqdn you should change the 1st line of /etc/resolv.conf to:
Code:
domain memoria.com
 
Old 06-27-2008, 08:50 AM   #3
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Original Poster
Rep: Reputation: 25
Thank you for your response.
I did change my resolv.conf as you said. I worked fine but for some unknown reasons, the resolv.conf changes back to its originals parameters.

Originals Parameters

search localdomain
nameserver 172.16.203.2

My Parameters for My DNS Server (which works fine)

domain memoria.com
searchlocal domain
nameserver 172.16.203.128
nameserver 172.16.203.128

My Parameters work fine. When I type nslookup anaconda i get a positive reply with the right IP adress. The PB that I dont understand is that those parameters come back to their original settings without me changing anything and then I come back to a time out error again.
That leads me to my next question
Would that be caused by the fact that I am running BIND on a NAT ?

Cheers

Riganta,
 
Old 06-27-2008, 09:08 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Usually resolv.conf changes if you're using dhcp. Read this thread that is for ubuntu to see how you can solve this problem.
Mind that if you have a "domain" and a "search" keyword in resolv.conf then the latter takes precedence.

Regards
 
Old 06-28-2008, 03:55 AM   #5
riganta
Member
 
Registered: May 2007
Location: Cork (Ireland)
Distribution: FreeBSD 9.1
Posts: 153

Original Poster
Rep: Reputation: 25
I read the link that you gave on your last reply. Basically if I got everything right, I would need to have a static IP address. Or, in some cases (as per link) users would just delete their resolv.conf file all together in order to solve their issue.
I want to have a static IP address but here is what I am trying to do
My Ubuntu Server 8.0.4 is running on a VM as a guest. The host being a Mac running leopard. The internet connection is rendered by a NAT on the host. In order for me to have a static IP address on my VM I want to run DHCP3-Server and assign to my guest (VM Ubuntu server) a static IP address through my local DHCP server.
How do I figure out the MAC address of my VM in order to asign it a static IP address in the DHCP Server?

Cheers

Riganta
 
Old 06-28-2008, 09:42 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Quote:
How do I figure out the MAC address of my VM in order to asign it a static IP address in the DHCP Server?
How about running:
Code:
ifconfig
You can also try the solutions mentioned here or just
Code:
chattr +i /etc/resolv/conf
to stop dhcp from overwriting it.
 
Old 04-20-2011, 07:21 AM   #7
nitjend
LQ Newbie
 
Registered: Apr 2011
Posts: 1

Rep: Reputation: 0
/etc/named/data/xyz.com.zone:10: unknown RR type 'rhel01.xyz.com.'

Hi ,
I am trying DNS Configuration setup in master and slave.

Master M/C
==========

First i tried editing /etc/named.conf file,
below is my named.conf file's contents.


options {
directory "/var/named";
dump-file "data/cache_dump.db";
statistics-file "data/named_mem_stats.txt";
memstatistics-file "data/named_mem_stats.txt";
query-source port 53;
query-source-v6 port 53;
allow-query {localhost;localnets;};
};

logging
{
channel default_debug{
file "data/named.run";
severity dynamic;
};
};

zone "." {
type hint;
file "named.ca";
};

zone "xyz.com"{
type master;
file "/etc/named/data/xyz.com.zone";
allow-transfer { 10.128.16.52; };
allow-update { key "rndckey"; };
allow-query { any; };
};

zone "16.128.10.in-addr.arpa"{
type master;
file "/etc/named/data/xyz.com.revzone";
allow-transfer { 10.128.16.52; };
allow-update { key "rndckey"; };
allow-query { any; };
};


Next i have created data dir under /etc/named/
Then i have created a file named "xyz.com.zone " (the contents of the file looks like)

$TTL 38400
@ IN SOA rhel01.xyz.com. root.xyz.com. (
2011042001 ; serial
10800 ; refresh
3600 ; retry
604800 ; expiry
38400 ; minimum
)

NS rhel01.xyz.com.
NS rhel02.xyz.com.

rhel01 IN A 10.128.16.51
rhel02 IN A 10.128.16.52


Then i tried creating another file "xyz.com.revzone" under /etc/named/data (the contents of the file )

$TTL 38400
@ IN SOA rhel01.xyz.com. root.xyz.com. (
2011042003 ; serial
10800 ; refresh
3600 ; retry
604800 ; expiry
38400 ; minimum
)

NS rhel01.xyz.com.
NS rhel02.xyz.com.

2 IN PTR rhel01.xyz.com
3 IN PTR rhel02.xyz.com

Then i have edited /etc/resolv.conf (contents of resolv.conf)

# Generated by NetworkManager
search rhel01.xyz.com
nameserver 10.128.1.1
nameserver 10.128.1.1


Finally i have started the DNS BIND setup using service named start


i got the below exception
Starting named:
Error in named configuration:
/etc/named/data/xyz.com.zone:10: unknown RR type 'rhel01.xyz.com.'
/etc/named/data/xyz.com.zone:11: unknown RR type 'rhel02.xyz.com.'
zone xyz.com/IN: loading from master file /etc/named/data/xyz.com.zone failed: unknown class/type
zone xyz.com/IN: not loaded due to errors.
_default/xyz.com/IN: unknown class/type
/etc/named/data/xyz.com.revzone:10: unknown RR type 'rhel01.xyz.com.'
/etc/named/data/xyz.com.revzone:11: unknown RR type 'rhel02.xyz.com.'
zone 16.128.10.in-addr.arpa/IN: loading from master file /etc/named/data/xyz.com.revzone failed: unknown class/type
zone 16.128.10.in-addr.arpa/IN: not loaded due to errors.
_default/16.128.10.in-addr.arpa/IN: unknown class/type
[FAILED]





Can anyone help on this?

Thanks in Advance.
 
Old 04-20-2011, 07:41 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
@nitjend

Please don't hijack a 3ys old thread.
Click "Report" and ask a moderator to move it to a new thread

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"FATAL: Unknown capture source type" error from Kismet atlantanewbie Linux - Wireless Networking 2 04-03-2010 06:34 AM
Directory shows as "unknown type" - any way to recover it? V@no Linux - General 6 09-28-2006 10:46 AM
nmap and service type "unknown" Woodsman Slackware 8 08-26-2006 08:30 PM
How do I import bind ".hosts" files into another BIND server chantman Linux - Software 0 06-30-2006 12:51 PM
Problems with mounting "unknown file system type 'ntfs' " turalo Fedora 2 12-21-2005 06:04 PM


All times are GMT -5. The time now is 11:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration