LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Bacula "Fatal error: VSS was not initialized properly" on Windows 7 backup (http://www.linuxquestions.org/questions/linux-server-73/bacula-fatal-error-vss-was-not-initialized-properly-on-windows-7-backup-939074/)

garydale 04-10-2012 08:02 AM

Bacula "Fatal error: VSS was not initialized properly" on Windows 7 backup
 
I've been struggling a bit to get Bacula to work but almost have it, I think.

I'm running Debian Squeeze on the server and have it successfully backing up /home. Unfortunately I can't get it to back up a Windows 7/Pro-64 client. The only error in the log is the one quoted in the subject line.

Any ideas?

Slackyman 04-11-2012 01:06 AM

First of all: make sure that on the Windows machine the Volume Shadow Copy Service (VSS) is not disabled.
Go to Administration Tools > Services and check if the service is disabled and, in case it is, enable it.
If this will not solve the issue it's maybe a permission problem and you have to modify some registry keys on the Windows machine to grant access to the user used by Bacula.
Open regedit and navigate to the key HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/VSS and add the key VssAccessControl if it doesn't exist.
Then add a value that is the name of the user and set it to 1.
Its name have to be in the form domain\username.
If you keep on having this issue check the registry log on Windows machine and follow this ugly guide from Microsoft: http://technet.microsoft.com/en-us/l...35(WS.10).aspx

garydale 04-11-2012 08:23 AM

VSS error
 
I upgraded to the newest Windows version of Bacula and that seems to have cured it.

AbyssMoon 12-18-2012 04:58 AM

I have the same problem.

Windows 2008 64bit
Bacula 5.2.10 x64
VSS Enabled and ready

JobId 7245: Fatal error: VSS was not initialized properly. ERR=�������� ������� ���������.
JobId 7245: Error: VSS API failure calling "BackupComplete". ERR=Object is not initialized; called during restore or not called in correct sequence.

I'm trying to solve the problem on their own for two weeks ...
How to get out of the situation?

Pomardako 01-11-2013 11:02 AM

Quote:

Originally Posted by AbyssMoon (Post 4851643)
I have the same problem.

Windows 2008 64bit
Bacula 5.2.10 x64
VSS Enabled and ready

JobId 7245: Fatal error: VSS was not initialized properly. ERR=�������� ������� ���������.
JobId 7245: Error: VSS API failure calling "BackupComplete". ERR=Object is not initialized; called during restore or not called in correct sequence.

I'm trying to solve the problem on their own for two weeks ...
How to get out of the situation?

I have the same problem, any solution? :?

Habitual 01-11-2013 01:47 PM

http://goo.gl/Rims

AbyssMoon 01-14-2013 01:50 AM

Quote:

Originally Posted by Pomardako (Post 4867878)
I have the same problem, any solution? :?

The solution was not found. Error still exists. :(

David.Gierlich 10-07-2013 08:56 AM

Any Ideas
 
Quote:

Originally Posted by AbyssMoon (Post 4869476)
The solution was not found. Error still exists. :(

Hi Guys,
Im currently working with Bacula and got the same issue today.
Maybe there are any helpful ideas?

Regards,
David

Habitual 10-07-2013 06:03 PM

David:

Welcome to LQ.
First order of business called "Necroposting". You don't want to reply to a thread that's older than 6 months.
Please note that this thread has not been replied to in over 6 months. Please ensure your reply is still relevant and timely.

Having said that, you should open your own thread, perhaps under
Linux Software or
Linux Server
since it could apply to either one. ;)

If you choose to do that, then tell us the bacula version you are using and on what OS.Build.Platform
(Ubuntu xx.xx LTS/64 bit usually works)

and the Windows version you are having issue with.

Quote:

Originally Posted by Slackyman (Post 4649860)
First of all: make sure that on the Windows machine the Volume Shadow Copy Service (VSS) is not disabled.

is still good advice.

Good Luck!


All times are GMT -5. The time now is 02:42 AM.