LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 02-07-2008, 10:02 PM   #1
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Rep: Reputation: 15
Question Backuppc configuration issue - see error


I have the backuppc up and running... i done a bit of cheating in that the 1st test client is listed in the servers hosts file. So hostname resolves, I can manually SSH to the client from the server... But manually kicking off a back on that client fails:

File /srv/backuppc/pc/csrhplt01/XferLOG.bad.z

Contents of file /srv/backuppc/pc/csrhplt01/XferLOG.bad.z, modified 2008-02-07 21:29:41

full backup started for directory /data/share
Running: /usr/bin/ssh -q -x -l root csrhplt01 /usr/bin/rsync --server --sender --numeric-ids --perms --owner --group -D --links --hard-links --times --block-size=2048 --rsh=ssh --recursive --ignore-times . /data/share/
Xfer PIDs are now 3977
Got remote protocol 1881173838
Fatal error (bad version): No protocol specified

Can't write 4 bytes to socket
fileListReceive() failed
Done: 0 files, 0 bytes
Got fatal error during xfer (fileListReceive failed)
Backup aborted by user signal
Not saving this as a partial backup since it has fewer files than the prior one (got 0 and 0 files versus 0)


Thanks!
 
Old 02-07-2008, 10:03 PM   #2
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Original Poster
Rep: Reputation: 15
CLIENT:

fuentej@CSRHPLT01:~$ sudo apt-get install rsync
[sudo] password for fuentej:
Reading package lists... Done
Building dependency tree
Reading state information... Done
rsync is already the newest version.
The following packages were automatically installed and are no longer required:
libboost-thread1.34.1 libboost-date-time1.34.1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
fuentej@CSRHPLT01:~$
 
Old 02-07-2008, 11:44 PM   #3
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Original Poster
Rep: Reputation: 15
I tweaked the arguments list a bit and the error has now changed:

Contents of file /srv/backuppc/pc/csrhplt01/XferLOG.bad.z, modified 2008-02-07 23:41:23

full backup started for directory /data/share/*
Running: /usr/bin/ssh -q -x -l root csrhplt01 /usr/bin/rsync --server --sender --recursive --perms --owner --links --block-size=2048 --verbose --ignore-times . /data/share/\\\*/
Xfer PIDs are now 15409
Got remote protocol 1869771333
Fatal error (bad version): Error: Can't open display: csrbakup01.barn.yard:1.0

Sent include: /
Read EOF:
Tried again: got 0 bytes
fileListReceive() failed
Done: 0 files, 0 bytes
Got fatal error during xfer (fileListReceive failed)
Backup aborted (fileListReceive failed)
Not saving this as a partial backup since it has fewer files than the prior one (got 0 and 0 files versus 0)
 
Old 02-08-2008, 10:01 AM   #4
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
Your tweaking did more harm than good. You absolutely should not have removed the -D modifier from the rsync arguments. That was added in about a year ago, and without the -D modifier, it won't work at all.

You keep trying to run before you can walk. Get it working, then try changing one thing at a time. You need to go back several steps to correct your problems. Go back to the original rsync line, and don't monkey with it until you get it working.

Something is very off in the rsync connection. Do you have libfile-rsyncp-perl installed on the BackupPC server? I had to add that in for mine to work. The version number of rsync is completely screwed up. You have this:

Code:
Got remote protocol 1869771333
When it should look like this:

Code:
full backup started for directory ivc (baseline backup #20)
Connected to my.hidden.machine:873, remote version 29
Negotiated protocol version 28
Connected to module ivc
Sending args: --server --sender --numeric-ids --perms --owner --group -D --links --hard-links --times --block-size=2048 --recursive --ignore-times . .
Sent exclude: /archive
Xfer PIDs are now 28474
Now that host is rsyncd instead of rsync, but rsync connections look similar:

Code:
Running: /usr/bin/ssh -q -x -l root another.hidden.host /usr/bin/rsync --server --sender --numeric-ids --perms --owner --group --devices --links --times --block-size=2048 --recursive --include=/usr --include=/usr/local --include=/etc --include=/home --include=/var --include=/var/log --include=/var/www --exclude=/\\\* --exclude=/usr/\\\* --exclude=/var/\\\* --ignore-times . /
Xfer PIDs are now 20470
Got remote protocol 29
Xfer PIDs are now 20470,20487
The rsync communications between the client and server are a mess. I can't imagine how you have rsync claiming to be version 1869771333. I believe version 2.6.9 is the newest.

Peace,
JimBass
 
Old 02-09-2008, 09:05 AM   #5
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Original Poster
Rep: Reputation: 15
OK - back to default config (you assume that I just change things half hazard.. I never make a change I can not revert)

Contents of file /srv/backuppc/pc/csrhplt01/XferLOG.bad.z, modified 2008-02-09 08:52:33

full backup started for directory /data/share
Running: /usr/bin/ssh -q -x -l root csrhplt01 /usr/bin/rsync --server --sender --numeric-ids --perms --owner --group -D --links --hard-links --times --block-size=2048 --recursive --ignore-times . /data/share/
Xfer PIDs are now 4418
Got remote protocol 1881173838
Fatal error (bad version): No protocol specified

Read EOF:
Tried again: got 0 bytes
fileListReceive() failed
Done: 0 files, 0 bytes
Got fatal error during xfer (fileListReceive failed)
Backup aborted (fileListReceive failed)
Not saving this as a partial backup since it has fewer files than the prior one (got 0 and 0 files versus 0)

Rsync is installed on all machines version 2.6.9...

Server is suse 10.3
client is ubuntu 7.10

I have attempted to run it manually from the server...

CSRBAKUP01:~ # ssh -q -x -l root csrhplt01 /usr/bin/rsync -D /data/share/*
root@csrhplt01's password:
skipping directory /data/share/Downloads
skipping directory /data/share/incomp
skipping directory /data/share/PICS
CSRBAKUP01:~ #


I have no experience with rsync, so I experiment...

got a better command?
 
Old 02-09-2008, 10:27 AM   #6
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Original Poster
Rep: Reputation: 15
I was able to get this command to work from server to client...

rsync -e ssh -avz 172.18.10.100:/data/share/PICS /srv/data

It appears to have worked, and wow was it fast. 165M in less than 30 secs.


(works with the name hostname too)

Last edited by bunadm; 02-09-2008 at 10:28 AM.
 
Old 02-09-2008, 02:26 PM   #7
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
Code:
root@csrhplt01's password:
There is your problem! How is BackupPC supposed to know and input the password for root on the other machine? You need to follow this guid from the BackupPC FAQ to have host based key authorization. BackupPC is never even making the connection to your host.

http://backuppc.sourceforge.net/faq/..._setup_openssh

Peace,
JimBass
 
Old 02-09-2008, 04:13 PM   #8
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Original Poster
Rep: Reputation: 15
Nevermid that, I know how to setup to keys.

AS I already stated, the command:

rsync -e ssh -avz 172.18.10.100:/data/share/PICS /srv/data

synced 165mb of data between the same client and server as is failing with backuppc...

no password requested... The pub key is setup...

Problems persists, same error.

while, I am no expert, I am also not an ID10T either.
 
Old 02-09-2008, 04:17 PM   #9
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Original Poster
Rep: Reputation: 15
just to confirm:

CSRBAKUP01:/home/fuentej # ssh root@csrhplt01
Last login: Sat Feb 9 09:21:52 2008 from csrbakup01.local
Linux CSRHPLT01 2.6.22-14-generic #1 SMP Fri Feb 1 04:59:50 UTC 2008 i686

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.
root@CSRHPLT01:~#
 
Old 02-09-2008, 05:15 PM   #10
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
Quote:
just to confirm:

CSRBAKUP01:/home/fuentej # ssh root@csrhplt01
Last login: Sat Feb 9 09:21:52 2008 from csrbakup01.local
Linux CSRHPLT01 2.6.22-14-generic #1 SMP Fri Feb 1 04:59:50 UTC 2008 i686

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.
root@CSRHPLT01:~#
That isn't confirmation that user backuppc can ssh in as root without a key, that is confirmation that user root can ssh in as root without a key. BackupPC doesn't run as root, it runs as backuppc.

The way to confirm that the key exists and is good for user backuppc is to do the following steps:

1) become root
2) su backuppc
3) ssh -q -x -l root csrhplt01

As to your comment about me thinking you're an idiot, lets stop and think about that for a moment. I'm here with my free time trying to help you accomplish something I've already done a dozen or more times. You're not paying me to be here. When you have a problem and I give you the answer to it, I expect what I say to be followed. I gave you a link on how to accomplish the password free ssh process, and you respond back by telling me everything is set fine, and you'll prove it. Well you didn't in any way prove it, in fact, all you did was show that you don't understand what should be/is happening. Showing that root can ssh to another machine without password is pointless. Root isn't the user running this process, backuppc is. You get so uptight and defensive. Step back, breathe, and then follow the directions step by step.

Peace,
JimBass
 
Old 02-10-2008, 12:30 AM   #11
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Original Poster
Rep: Reputation: 15
Ya, sorry, bout that I was in a bad mood otherwise... just vented here for some reason..

I see what your are saying though, I can fix that...

Ill post back what happens.

Thanks!
 
Old 02-10-2008, 01:16 AM   #12
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Original Poster
Rep: Reputation: 15
Well, ill be HOT DAM!

It works!!!

I backed-up the same 165mb using backuppc and it is compressed down to 92mb. not bad!

Now to setup all the clients....!! And with the DHCP flag, Im not so sure I really need DNS server... Or just a DNS cache server.

But thanks for the help!

ADDING STEPS I TOOK:

su -s /bin/bash backuppc

pwd (too make sure im in backuppc's home directory - if not cd to it)

ssh-keygen -t dsa

when asked to enter a passphrase, I did not enter one, just hit enter 3 times.(I did enter one once, but then it asks for it when you connect)

then:

ssh-copy-id ~/.ssh/id_dsa.pub root@csrhplt01

DONE!

run this to test:

ssh -q -x -l root csrhplt01 - you should log right in, with no password request.

It works!

Last edited by bunadm; 02-10-2008 at 01:31 AM.
 
Old 02-10-2008, 01:25 AM   #13
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
You don't need either type of DNS server, just make sure you have the DHCP parameters set on the main config.pl file. For example, if all of your machines are 192.168.1.X, and X is between 100 and 150, BackupPC needs to know that. You'll see the DHCP config somewhere, and for the addresses I listed, it should look like this:

Code:
$Conf{DHCPAddressRanges} = [
  {
    'ipAddrBase' => '192.168.1',
    'first' => '100',
    'last' => '150'
  }
];
If that isn't set, BackupPC won't even look.

Peace,
JimBass
 
Old 02-10-2008, 10:29 AM   #14
bunadm
Member
 
Registered: Jan 2008
Posts: 34

Original Poster
Rep: Reputation: 15
Its all good, I had already started using it...

I have one more small annoyance.. My interface does not look as slick as the screen shots... It seems like I am missing gifs for the web server or something.

Here is a link so you view a screen shot.

http://docs.google.com/Doc?id=df482x4p_129hp6g45cv

its not a big deal... but I think we would all rather have the slicker looking interface.

Thanks.
 
Old 02-10-2008, 11:37 AM   #15
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
Check the apache error logs. I don't know about Suse, but in Debian they are in /var/log/apache2/. The error log will either tell you that it is missing .gif images, or possibly the .css info that sets the background colors and such.

I can't solve that without seeing the logs. I have no idea where you have the files, and where your computer expects them to be. You've got to check the logs.

Peace,
JimBass
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble with BackupPC configuration/setup - issues with config.pl bunadm Linux - Server 12 06-12-2008 05:47 AM
Suse10.3 - BackupPC - apache configuration bunadm Linux - Server 21 02-06-2008 04:34 AM
BackupPC help tsaravan Linux - Networking 1 12-20-2007 06:46 PM
LXer: BackupPC Installation And Configuration LXer Syndicated Linux News 0 06-19-2006 11:33 AM
BackupPC uselpa Slackware 1 01-24-2005 11:19 AM


All times are GMT -5. The time now is 01:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration