LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 09-13-2010, 02:52 AM   #1
ramadas88
LQ Newbie
 
Registered: Mar 2010
Posts: 24

Rep: Reputation: 0
Unhappy autofs configuration


hai... All

I want to know how can we configure autofs

I searched in Google found some articile but it is not helped me
So Please help me to configuer autofs for simple nfs mounting
 
Old 09-13-2010, 03:38 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
More information please. You should tell us the following, at least.
  • What you have
    Your distribution, desktop, network configuration... everything that's relevant to your setup.
  • What you want
    Detail exactly what you are trying to accomplish. Show us what the final result should be. Be specific.
  • What you did
    What have you tried already? (You did make some attempts to do it yourself, didn't you?) Which web pages did you visit? What commands did you use?
  • What you got
    What are the results of the things you've tried already? What error messages did you get, if any?
In short, give us details about everything. Don't just assume we know what you are talking about.
 
Old 09-14-2010, 07:27 AM   #3
ramadas88
LQ Newbie
 
Registered: Mar 2010
Posts: 24

Original Poster
Rep: Reputation: 0
i have already searched in Google for solution but i cant find the proper way
So kindly help me to mount simple nfs share through autofs


please help
 
Old 09-14-2010, 03:52 PM   #4
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
I understood your request the first time. It doesn't do any good to simply repeat it.

Unless you give us some details, there's not much we can tell you that isn't already available on other sites. Read my last post again and give us the information I asked you for.
 
Old 09-19-2010, 01:52 AM   #5
ramadas88
LQ Newbie
 
Registered: Mar 2010
Posts: 24

Original Poster
Rep: Reputation: 0
find my auto.master file



#
# $Id: auto.master,v 1.4 2005/01/04 14:36:54 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#
/misc /etc/auto.misc
/net -hosts
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master


auto.misc File


#
# $Id: auto.misc,v 1.2 2003/09/29 08:22:35 raven Exp $
#
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

cd -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom

# the following entries are samples to pique your imagination
#linux -ro,soft,intr ftp.example.org:/pub/linux
#boot -fstype=ext2 :/dev/hda1
#floppy -fstype=auto :/dev/fd0
#floppy -fstype=ext2 :/dev/fd0
#e2floppy -fstype=ext2 :/dev/fd0
#jaz -fstype=ext2 :/dev/sdc1
#removable -fstype=ext2 :/dev/hdd
misc -fstype=nfs server: /testshare/ttt


Please help me why am mot able to mound ttt shate on misc directory from server


Please
 
Old 09-19-2010, 02:31 AM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 13,531

Rep: Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807
please reread the second post and answer the questions
from what little you posted it is some very old operating system ( using ext2) i can only guess as to the os - rhel3 ? ( unsupported) or the much older rh9

to recap post two
Quote:
What you have
Your distribution, desktop, network configuration... everything that's relevant to your setup.
1) WHAT is your OS ?
"everything that's relevant to your setup"
2) your hardware - very relevant
"desktop, network configuration"
3) this changes settings .

Quote:
What you want
Detail exactly what you are trying to accomplish. Show us what the final result should be. Be specific.
What is it you want to do
without that we CAN NOT even try to answer , or even GUESS .
Quote:
What you did
What have you tried already? (You did make some attempts to do it yourself, didn't you?) Which web pages did you visit? What commands did you use?
what have you already done so we do not have you do something that you HAVE already done .
 
Old 09-19-2010, 09:40 AM   #7
flakblas
Member
 
Registered: Jun 2009
Location: Maryland
Distribution: Fedora, CentOS, RHEL, Ubuntu
Posts: 41

Rep: Reputation: 3
Here's my auto.master file:
Code:
/home	/etc/auto.home	--timeout=60
/mnt	/etc/auto.mnt	--timeout=60
+auto.master
Here's my auto.home:
Code:
*	-fstype=nfs,rw,nosuid,soft	192.168.1.101:/usr/home/&
And not to be a jerk, but you obviously can't read very well which is probably why you can't find autofs help on Google which is where I learned how to do this. So I'm not sure if me posting my working config will even help. Good luck though.
 
Old 09-20-2010, 03:48 AM   #8
ramadas88
LQ Newbie
 
Registered: Mar 2010
Posts: 24

Original Poster
Rep: Reputation: 0
MY OS is RHEL5
and i want to auto mount a shared folder(ttt NFS) from server


when am searching in Google am not getting the exact command (what i got never works)


Help me to do this
 
Old 09-21-2010, 05:50 AM   #9
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
As per the post #7, there should be no space between the server name and the shared dir on the server.
You may also find this useful http://www.linuxtopia.org/online_boo...ig-autofs.html
 
  


Reply

Tags
autofs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] autofs yuanjunliang Linux - Newbie 4 04-06-2010 10:11 PM
autofs under / Micro420 Red Hat 9 03-04-2010 05:00 PM
Autofs/Automount configuration problems Ccielogs Linux - Server 2 09-11-2009 03:21 AM
Is there a way to include winbind/ntp/autofs configuration in redhat kickstart file? wirelessgirl21 Linux - Newbie 1 06-14-2009 08:58 AM
Autofs tefal Linux - Software 4 07-20-2004 11:58 AM


All times are GMT -5. The time now is 10:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration