LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-22-2012, 03:51 PM   #1
spezticle
Member
 
Registered: May 2010
Distribution: Ubuntu 10.04
Posts: 30

Rep: Reputation: 0
atftpd


how do you configure atftpd?
no matter what I do, i can not get the path to be anything except /srv/tftp

/tftpboot exists and has 777

also,
--no-blksize doesn't work either.
i've edited /etc/default/atftpd
as well as /etc/inetd.conf

i can't find any other configuration files. I've even just tried to run atftpd standalone, but that doesn't work, either.

Code:
[15:35:12]root@server:~$ atftpd --tftpd-timeout 300 --retry-timeout 5 --mcast-port 1758 --mcast-addr 239.239.239.0-255 --no-blksize --mcast-ttl 1 --maxthread 100 --verbose=5 /mytftpdirecrory777
Usage: tftpd [options] [directory]
 [options] may be:
  -t, --tftpd-timeout <value>: number of second of inactivity before exiting
  -r, --retry-timeout <value>: time to wait a reply before retransmition
  -m, --maxthread <value>    : number of concurrent thread allowed
  -v, --verbose [value]      : increase or set the level of output messages
  --trace                    : log all sent and received packets
  --no-timeout               : disable 'timeout' from RFC2349
  --no-tsize                 : disable 'tsize' from RFC2349
  --no-blksize               : disable 'blksize' from RFC2348
  --no-multicast             : disable 'multicast' from RFC2090
  --logfile <file>           : logfile to log logs to ;-)
  --pidfile <file>           : write PID to this file
  --listen-local             : force listen on local network address
  --daemon                   : run atftpd standalone (no inetd)
  --no-fork                  : run as a daemon, don't fork
  --user <user[.group]>      : default is nobody
  --group <group>            : default is nogroup
  --port <port>              : port on which atftp listen
  --bind-address <IP>        : local address atftpd listen to
  --mcast-ttl                : ttl to used for multicast
  --mcast-addr <address list>: list/range of IP address to use
  --mcast-port <port range>  : ports to use for multicast transfer
  --pcre <file>              : use this file for pattern replacement
  --pcre-test <file>         : just test pattern file, not starting server
  --mtftp <file>             : mtftp configuration file
  --mtftp-port <port>        : port mtftp will listen
  --no-source-port-checking  : violate RFC, see man page
  --mcast-switch-client      : switch client on first timeout, see man page
  -V, --version              : print version information
  -h, --help                 : print this help

 [directory] must be a world readable/writable directories.
 By default /tftpboot is assumed.
Code:
[15:44:30]root@server:~$ tail -n 1000 /etc/default/atftpd 
USE_INETD=false
OPTIONS="--tftpd-timeout 300 --no-blksize --retry-timeout 5 --mcast-port 1758 --mcast-addr 239.239.239.0-255 --mcast-ttl 1 --maxthread 100 --verbose=5 /mytftpdirecrory777 "
as you can see, i've searched for every instance of /srv/tftp and it only comes up once in that file

Code:
[15:48:07]root@server:/etc$ ls -a |grep /srv/tftp * -R
grep: blkid.tab: No such file or directory
default/atftpd:OPTIONS="--tftpd-timeout 300 --retry-timeout 5 --no-blksize --mcast-port 1758 --mcast-addr 239.239.239.0-255 --mcast-ttl 1 --maxthread 100 --verbose=5 /mytftpdirecrory777 "
grep: fonts/conf.d/30-defoma.conf: No such file or directory
i also tried dpkg-reconfigure atftpd
which prompted me for many configuration options including port number, and server path, and log file. i changed the path of the log file. this worked. nothing else did. wtf atftpd?

Last edited by spezticle; 04-22-2012 at 04:02 PM.
 
Old 04-23-2012, 03:02 AM   #2
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,929

Rep: Reputation: 1306Reputation: 1306Reputation: 1306Reputation: 1306Reputation: 1306Reputation: 1306Reputation: 1306Reputation: 1306Reputation: 1306Reputation: 1306
I cannot say more than:
[directory] must be a world readable/writable directories.
By default /tftpboot is assumed.

maybe /mytftpdirecrory777 is not ok.
also can you explain the grep command you tried
 
Old 04-23-2012, 07:33 AM   #3
spezticle
Member
 
Registered: May 2010
Distribution: Ubuntu 10.04
Posts: 30

Original Poster
Rep: Reputation: 0
I tried adding /tftpboot with 777 permissions. files sent to the tftp server still go to /srv/tftp.

The grep was a search through /etc to find any mention of "/srv/tftp" to see if another config file is telling atftp to still use that path. I came up with only the results in the original post.
 
Old 12-11-2012, 01:27 PM   #4
dedec0
Member
 
Registered: May 2007
Posts: 57

Rep: Reputation: 3
Did you got this one?

If you are running atftpd with INETD, you need to send inetd a signal (SIGHUP) to reread the configuration file (see manual page of inetd).

Else, you need to do something like
Code:
/etc/init.d/atftd restart
I'm using it with inetd and it works (changed my served directory to /home/user/Documents). To avoid my own future confusion I have changed a bit of /etc/init.d/atftd file:
Code:
if [ "$USE_INETD" = "true" ]; then
    echo "atftpd is using inetd!!!!"
    exit 0;
fi
 
Old 12-11-2012, 01:35 PM   #5
dedec0
Member
 
Registered: May 2007
Posts: 57

Rep: Reputation: 3
Quote:
Originally Posted by dedec0 View Post
Did you got this one?
Else, you need to do something like
Code:
/etc/init.d/atftd restart
[/code]
And apparently I cannot run atftpd without inetd. Don't know why.
 
  


Reply

Tags
tftp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
atftpd (v0.7) - tftp server on ubuntu. vrode Linux - Networking 1 12-12-2012 08:48 AM
tftpd problems with both tftpd-hpa and atftpd spitting image Linux - Server 1 10-05-2010 04:40 PM
tftpd problems with both tftpd-hpa and atftpd spitting image Debian 0 10-05-2010 11:04 AM
Problem starting atftpd mpmackenna Linux - Software 2 03-06-2008 08:10 AM


All times are GMT -5. The time now is 11:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration