LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 05-06-2007, 09:40 AM   #1
vargadanis
Member
 
Registered: Sep 2006
Posts: 248

Rep: Reputation: 30
Apache2 mod_rewrite isn't working


Hi!

I installed Apache2 on Ubuntu Feisty Fawn as a developement environment. I knew that mod_rewrite is one of the default modules that are installed. It is there in the mods-available dir but somehow I cannot load it.
I have this in my apache2.conf file:
Quote:
<IfModule mod_rewrite.c>
RewriteEngine On
</IfModule>
Supposingly it did not find is because the .htaccess stuff is not working at all. I installed wordpress and joomla too just to make sure that the problem is not with me (I know that they are using mod_rewrite) and of course they didn't work.
What do I have to do to enable that function of Apache2?
Quote:
apache2 -v
Server version: Apache/2.2.3
Server built: Jan 15 2007 18:14:50
I have MySQL, PHP5 and some other stuff installed but I don't think that they would interfere with Apache2.
Would it solve if I linked the rewrite mod to the mods-enabled dir?

Thanx for your help!
 
Old 05-06-2007, 10:17 AM   #2
vargadanis
Member
 
Registered: Sep 2006
Posts: 248

Original Poster
Rep: Reputation: 30
I tried to link the rewrite.load to the mods-enabled dir. I reloaded apache and then restarted, killed the pid and did everything but didn't work. Maan... I am getting super frustrated because it should not be that difficult.
 
Old 05-06-2007, 10:29 AM   #3
vargadanis
Member
 
Registered: Sep 2006
Posts: 248

Original Poster
Rep: Reputation: 30
Maybe and error log will help:
Quote:
[Sun May 06 11:27:57 2007] [error] [client 127.0.0.1] File does not exist: /var/www/joomla/content, referer: http://localhost/joomla/
 
Old 11-09-2009, 08:21 PM   #4
JanusPaul
Member
 
Registered: Nov 2004
Location: Houston, Texas
Distribution: Ubuntu, Debian, Solaris, Free BSD
Posts: 82

Rep: Reputation: 15
I just solved for myself your issue, sorry had to wait 2 years for somebody lol.

The VirtualHost/sites-enabled-conf files, well enable "AllowOverride" directive to override "FileInfo" & "Options", ex:

AllowOverride FileInfo Options

That'll enable your .htaccess rules!
 
  


Reply

Tags
apache, conf, htaccess, rewrite, virtualhost


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mod_rewrite not working in Slack 10 -10.1 Bwongar Slackware 3 01-16-2009 01:53 PM
apache2 recompile with mod_rewrite -- without losing any of the current config! scabrous1 Linux - Software 1 07-28-2006 04:56 PM
how to add mod_rewrite to apache2 scabrous1 Linux - Software 1 07-07-2006 09:48 AM
Does anyone have apache2.0 working? canegames Linux - General 9 04-10-2006 07:48 PM
Apache mod_rewrite not working? KillerCheeto Linux - Software 2 05-23-2004 10:26 PM


All times are GMT -5. The time now is 10:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration