LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 05-22-2007, 04:25 AM   #1
PhilA
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
Unhappy apache : localhost/ works localhost/index.html does not


I would be very grateful for some help with an issue I have with a SUSE 10.2 web server (using apache and samba) I'm trying to set up on a windows network. The is my first attempt at this so if you know the answer please explain clearly.

The problem is that if a browse http://localhost/ I get the usual message "It works!" on the index.html page, but when I try browsing http://localhost/index.html I get an "unable to connect message" in firefox. I also have swat running on this server which runs ok (localhost:901/).

I can't browse the page from another machine on the network either.

I did have this working before, but it seemed to go wrong after I created a share in samba to srv/www/ and changed the permissions on the www and htdocs folders so other users on the network could add/edit/delete files in these areas... This may have someting to do with it but I'm unable to work that out at the moment. I've tried various adjustments.

 
Old 05-22-2007, 05:31 AM   #2
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
I believe your srv/www folder permission have something wrong,
u can see the msg probably because of your browser cache the content, so when u change to http://localhost/index.html it give you trouble.
make sure anonymous have permission.
 
Old 05-22-2007, 07:11 AM   #3
PhilA
LQ Newbie
 
Registered: May 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the speedy response.

You're correct that the page had been cached.. now I've cleared the cache and I receive the same error when just browsing localhost.

I'm now trying to correct the permissions on the www folder. I'm not used to using the command line so i'm just right clicking on the folder to get the properties and going to the permissions tab and trying to find a 'group' called 'anonymous' in the list but there isn't one.

Any ideas?

***edited***

I've managed to resolve my problem, but I'm too embaressed to admit what the problem was :-) (it wasn't permissions). Thanks very much for the help!

Last edited by PhilA; 05-22-2007 at 08:50 AM.
 
Old 05-27-2007, 04:35 PM   #4
funky86
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
Hello!

I found this thread per google. Actually I installed apache with wamp5 (wampserver) ver. 1.7.1 on my Windows XP sp2 corporated system. When I'm trying to reach http://localhost in my mozilla firefox browser, I can't. Like it's loading all the time and no error message is shown.

Any sugestions ?

Thanks
 
Old 05-27-2007, 08:32 PM   #5
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
Quote:
Originally Posted by PhilA
I've managed to resolve my problem, but I'm too embaressed to admit what the problem was :-) (it wasn't permissions). Thanks very much for the help!
I believe it's because of permission, all webpage must everybody readable (linux divide permission to 3 group of user, owner, group,and others). You need to set other can read.

Ks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Viewing html pages on localhost threelions66 Linux - Newbie 3 08-05-2006 07:22 PM
apache http://localhost/mysite ---> http://localhost/mysite/index.php how? ilnli Linux - General 8 06-04-2005 04:23 PM
Message from syslogd@localhost localhost kernel: Disabling IRQ #21 ylts Linux - Hardware 0 02-26-2005 09:01 AM
Apache only works on localhost Airwaves Linux - Networking 8 07-12-2004 03:29 AM
Apache works localhost but not over the internet newuser455 Red Hat 4 05-22-2004 12:04 PM


All times are GMT -5. The time now is 09:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration