LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 08-14-2012, 12:00 PM   #1
oscargim
LQ Newbie
 
Registered: Mar 2011
Location: Argentina
Distribution: CentOS 5.8 32 Bits
Posts: 27

Rep: Reputation: 0
Apache error with Python on CentOS 5.8


Hi, I just have installed an application to broadcast voice using freeswitch (http://www.freeswitch.org)

The app have a section where I can upload a CSV file containing phone numbers to broadcast, but Im having an error uploading the CSV file.

Looking at the server logs I found Python errors on Apache logs and I guess that could be the reason of the upload error (I just guess, Im not an expert)

Here is the apache log paste: http://pastebin.com/0FEJuV2d


I tried with google to find a solution but nothing :/

thanks
 
Old 08-15-2012, 03:23 AM   #2
Valery Reznic
ELF Statifier author
 
Registered: Oct 2007
Posts: 668

Rep: Reputation: 134Reputation: 134
Quote:
Originally Posted by oscargim View Post
Hi, I just have installed an application to broadcast voice using freeswitch (http://www.freeswitch.org)

The app have a section where I can upload a CSV file containing phone numbers to broadcast, but Im having an error uploading the CSV file.

Looking at the server logs I found Python errors on Apache logs and I guess that could be the reason of the upload error (I just guess, Im not an expert)

Here is the apache log paste: http://pastebin.com/0FEJuV2d


I tried with google to find a solution but nothing :/

thanks

From your log file:
Code:
[Sat Aug 11 22:31:59 2012] [error] python_init: Python version mismatch, expected '2.6.5', found '2.6.6'.
Can you downgrade your python to 2.6.5, as expected by Apache?
 
Old 08-16-2012, 02:53 PM   #3
oscargim
LQ Newbie
 
Registered: Mar 2011
Location: Argentina
Distribution: CentOS 5.8 32 Bits
Posts: 27

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Valery Reznic View Post
From your log file:
Code:
[Sat Aug 11 22:31:59 2012] [error] python_init: Python version mismatch, expected '2.6.5', found '2.6.6'.
Can you downgrade your python to 2.6.5, as expected by Apache?


Guess I can try, do you know how to do it??
 
Old 08-19-2012, 03:41 AM   #4
Valery Reznic
ELF Statifier author
 
Registered: Oct 2007
Posts: 668

Rep: Reputation: 134Reputation: 134
Quote:
Originally Posted by oscargim View Post
Guess I can try, do you know how to do it??
Find python package with required version for your CentOS 5.8, then (as root)
Code:
rpm -U --oldpackage your_python.rpm
 
  


Reply

Tags
apache, centos5, error, python


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache on centos, php4 - config error kiekie Linux - Newbie 12 06-13-2010 10:08 PM
Unable to start apache on CentOS Linux with error Starting httpd: Syntax error on lin pkumar2533 Linux - Newbie 9 08-26-2009 08:48 AM
Error while executing python CGI in apache for wireless application srinuweb86 Linux - Wireless Networking 0 04-29-2009 11:42 AM
Apache Error 403 - CentOS 5.2 with Apache 2.2.3 gordymann Linux - Newbie 2 04-08-2009 09:57 AM
Centos 5 Apache error swhitehead Linux - Newbie 2 04-09-2008 02:10 PM


All times are GMT -5. The time now is 12:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration