LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 06-05-2007, 04:50 AM   #1
Azzath
Member
 
Registered: Jan 2005
Location: Russia
Distribution: Mandrake, CentOS
Posts: 138

Rep: Reputation: 16
Question Apache compilation error


Hi All,
I am trying to install Apache 1.3 (for a specific requirement of my own)and I am getting the following message, could someone help me out here please.

Code:
[xxx@RHEL5 apache_1.3.37]$ ./configure --prefix=/data/AS/apache/ \
> --enable-shared=max
Configuring for Apache, Version 1.3.37
 + using installation path layout: Apache (config.layout)
Creating Makefile
Creating Configuration.apaci in src
 + enabling mod_so for DSO support
Configuration.tmpl is more recent than Configuration.apaci;
Make sure that Configuration.apaci is valid and, if it is, simply
'touch Configuration.apaci' and re-run ./Configure again.
PS:I had Apache 2.xx already and I uninstalled it and then tried to install 1.3 from source.

Thanks in-advance,
Azzath.
 
Old 06-05-2007, 10:00 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
Did you try running the commands that the message suggests? It looks like you need to run touch Configuration.apaci and then to re-run your original ./configure command.
 
Old 06-06-2007, 02:37 AM   #3
Azzath
Member
 
Registered: Jan 2005
Location: Russia
Distribution: Mandrake, CentOS
Posts: 138

Original Poster
Rep: Reputation: 16
@gilead,
I did do a touch and then ran ./Counfigure, but the outcome is still the same.

If anyone comes accross with a solution please let me know.

Thanks.
 
Old 12-20-2007, 09:35 PM   #4
ikuwara
LQ Newbie
 
Registered: Dec 2007
Posts: 1

Rep: Reputation: 0
It is related to your server time&date mismatch. Try to adjust the time&date properly using date command then untar the apachexxx.tar.gz file again. Run ./configure

That's all...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel compilation error: Error 15: File not found Niceman2005 Linux - General 9 10-04-2007 03:45 AM
Apache module compilation problem the-chains Linux - Software 1 07-22-2004 11:20 AM
problems during apache+php compilation jogurt666 Linux - Software 1 11-11-2003 11:25 AM
Apache and PHP compilation WiWa Linux - Software 1 10-05-2003 11:30 AM
Problem with Apache compilation gr8geezer Linux - Software 0 03-13-2003 11:25 PM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration