LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 04-09-2008, 10:55 PM   #1
Linuxfrog
Member
 
Registered: Jan 2004
Location: Dallas
Distribution: Debian 4.0, Centos and Fedora
Posts: 30

Rep: Reputation: 15
Apache 2.2 issues with NFS mounts and displaying images etc.


Hello, this is probably something very simple I have overlooked but it is driving me crazy. I have two servers, one that is Debian etch 4.0 and the other that is Fedora 8. If I mount a cifs share on Debian and change my vhost directive to serv docs from the cifs share, it works perfectly. If I use Fedora 8, images and text files and various other files types fail to work when mounted (images only display the path, and text files show blank). I am sure this is a option in httpd.conf that stops this cifs mount weirdness. Anyone have any Ideas? I am using the stock apache configuration for the Fedora 8 machine and Debian machine.
# apachectl configtest
Syntax OK

Thanks, Dustin
 
Old 04-10-2008, 02:50 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,389

Rep: Reputation: 97
i dont know whether this helps but i would copy the <Directory/></Directory> section (of httpd.conf or other conf) from Debian to RH...
cheers
J
 
Old 04-10-2008, 01:47 PM   #3
Linuxfrog
Member
 
Registered: Jan 2004
Location: Dallas
Distribution: Debian 4.0, Centos and Fedora
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks for the suggestion. I had actually tried this and strangely it still has the issues. This baffles the heck out of me. This issue only seems to occur with redhat based distros and I have replicated it on CentOS 4, 5, and Fedora 8. I am now sure why this is happening?
 
Old 04-11-2008, 01:48 AM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Anything in the apache error logs of your RH based systems?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quick way of displaying images Hydroksyde Linux - Software 0 10-02-2005 08:24 PM
displaying jpeg images Dave31836 Programming 2 01-25-2005 10:28 AM
apache not displaying images tlgates Linux - Networking 0 01-24-2005 03:06 PM
Displaying images in CGI scripts dodger-newbie Programming 9 03-22-2004 01:28 PM
Simultaneously displaying Images with different depths yrraja Linux - General 0 04-25-2003 05:17 AM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration