LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-18-2009, 01:14 AM   #1
JamesScottSomers
LQ Newbie
 
Registered: Dec 2009
Location: Ottawa, Canada
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Apache 2.2


So I have been trying to set up Apache all day, you can even go to the website.

www.karleton.ca

On my network, on the second computer, call it the client, I can access the server by IP call it 192.168.0.1. So I can access that in the browser and it will load, but that website there does not load from the external DNS. The DNS is setup by a company called EasyDNS, it is not hard to set up the IP but I will take another look at it in the morning. Port 80 is being forward to the server computer by the Router, it even has a setting for it. Technically I have a dynamic IP but has remained static, you can even ping it although I suppose it could change, 64.231.185.175.

This is what I have.

ports.conf
NameVirtualHost *:80
Listen 80

did not touch apache2.conf but everything looks OK.

httpd.conf is empty.

in sites-enabled I have this, same as many tutorials. I appreciate responses, in the morning I will probably go get a book from the library.

<VirtualHost *.80>
ServerAdmin admin@karleton.ca
ServerName karleton.ca
ServerAlias www.karleton.ca
DocumentRoot /var/www/karleton.ca/htdocs
...
</VirtualHost>

I have three other sites, or two other and one duplicate but their configurations are disabled atm.

Thanks in advance,

James Scott Somers

Last edited by JamesScottSomers; 12-18-2009 at 01:13 PM.
 
Old 12-18-2009, 01:23 AM   #2
JamesScottSomers
LQ Newbie
 
Registered: Dec 2009
Location: Ottawa, Canada
Distribution: Ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Here is my /etc/hosts file on the server computer. I was trying both of them.

127.0.0.1 localhost localhost.gateway.__.net
192.168.0.1 servername.gateway.__.net
#64.231.185.175 servername.gateway.__.net
 
Old 12-18-2009, 01:14 PM   #3
JamesScottSomers
LQ Newbie
 
Registered: Dec 2009
Location: Ottawa, Canada
Distribution: Ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
You know you guys aren't really helping much, I am going to the library. I am going to look into finding logs on my router/modem.
 
  


Reply

Tags
apache, configuration


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache Webserver on Slackware - Failed to Start Apache - 'no listening sockets .." CCTVGuru Linux - Server 4 10-11-2009 01:14 AM
Mail from Apache being rejected - Cannot route to sender apache@localhost.localdomain jimwillsher Linux - Networking 2 01-19-2006 12:41 AM
Apache 1.3.33 (debian built) and Apache SSL does not respond to the proper ports lqorg_user Linux - Networking 0 11-06-2005 04:11 PM
Apache Webserver 403 Forbidden Errors (User not in apache group?) Mankind75 Mandriva 4 07-08-2004 05:30 AM
apache benchmarks (apache v13 / apache v20) ; large differences between benchmarking markus1982 Linux - Software 0 02-08-2003 10:53 AM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration