LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-25-2009, 05:24 PM   #1
jonnytabpni
Member
 
Registered: Sep 2008
Posts: 68

Rep: Reputation: 16
Amavis doesn't check for spam on some emails


Hi folks,

I set up my email server and Amavis spame/virus checker according to this article:
http://workaround.org/articles/ispma...he-dovecot-lda

For the most part, all works well except that Spamassian won't add the headers to some of the email (I'm not sure if it's checking them).

It adds them to most of them, just from my hotmail account it won't. It hasn't let any Spam though yet which doesn't have the special headers.

Is this a bug?

Cheers
 
Old 04-25-2009, 05:26 PM   #2
jonnytabpni
Member
 
Registered: Sep 2008
Posts: 68

Original Poster
Rep: Reputation: 16
THis is the logs from the hotmail email which didn't get the spamassian headers attached to it:

Apr 25 23:19:13 mail2 postfix/smtpd[7033]: connect from snt0-omc2-s34.snt0.hotmail.com[65.55.90.109]
Apr 25 23:19:14 mail2 postfix/smtpd[7033]: 677D31BFDF: client=snt0-omc2-s34.snt0.hotmail.com[65.55.90.109]
Apr 25 23:19:14 mail2 postfix/cleanup[7038]: 677D31BFDF: message-id=<SNT103-W6669118C5924D483B2A1F292730@phx.gbl>
Apr 25 23:19:14 mail2 postfix/qmgr[6256]: 677D31BFDF: from=<my_email_address@hotmail.com>, size=1362, nrcpt=1 (queue active)
Apr 25 23:19:14 mail2 postfix/smtpd[7033]: disconnect from snt0-omc2-s34.snt0.hotmail.com[65.55.90.109]
Apr 25 23:19:17 mail2 postfix/smtpd[7044]: 47C251BFE3: client=localhost[127.0.0.1]
Apr 25 23:19:17 mail2 postfix/cleanup[7038]: 47C251BFE3: message-id=<SNT103-W6669118C5924D483B2A1F292730@phx.gbl>
Apr 25 23:19:17 mail2 postfix/smtpd[7044]: disconnect from localhost[127.0.0.1]
Apr 25 23:19:17 mail2 postfix/qmgr[6256]: 47C251BFE3: from=<my_email_address@hotmail.com>, size=1810, nrcpt=1 (queue active)
Apr 25 23:19:17 mail2 amavis[7030]: (07030-02) Passed CLEAN, [65.55.90.109] [65.55.90.73] <my_email_address@hotmail.com> -> <my_email_address@mydomain.co.uk>, Message-ID: <SNT103-W6669118C5924D483B2A1F292730@phx.gbl>, mail_id: hCazSiMe10e7, Hits: 0, size: 1362, queued_as: 47C251BFE3, 2545 ms
Apr 25 23:19:17 mail2 postfix/smtp[7039]: 677D31BFDF: to=<my_email_address@mydomain.co.uk>, relay=127.0.0.1[127.0.0.1]:10024, delay=3.1, delays=0.51/0/0/2.5, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=07030-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 47C251BFE3)
Apr 25 23:19:17 mail2 postfix/qmgr[6256]: 677D31BFDF: removed
Apr 25 23:19:17 mail2 postfix/smtp[7045]: 47C251BFE3: to=<my_email_address@mydomain.local>, orig_to=<my_email_address@mydomain.co.uk>, relay=mydomain.local[10.87.0.10]:25, delay=0.05, delays=0.01/0/0/0.04, dsn=2.6.0, status=sent (250 2.6.0 <SNT103-W6669118C5924D483B2A1F292730@phx.gbl> Queued mail for delivery)
Apr 25 23:19:17 mail2 postfix/qmgr[6256]: 47C251BFE3: removed
Apr 25 23:22:34 mail2 postfix/anvil[7036]: statistics: max connection rate 1/60s for (smtp:10.87.0.220) at Apr 25 23:17:22
Apr 25 23:22:34 mail2 postfix/anvil[7036]: statistics: max connection count 1 for (smtp:10.87.0.220) at Apr 25 23:17:22
Apr 25 23:22:34 mail2 postfix/anvil[7036]: statistics: max cache size 2 at Apr 25 23:18:10
Apr 25 23:23:12 mail2 postfix/smtpd[7049]: timeout after END-OF-MESSAGE from localhost[127.0.0.1]
Apr 25 23:23:12 mail2 postfix/smtpd[7049]: disconnect from localhost[127.0.0.1]


Looks fine to me...

Last edited by jonnytabpni; 04-25-2009 at 05:27 PM.
 
Old 04-25-2009, 05:48 PM   #3
jonnytabpni
Member
 
Registered: Sep 2008
Posts: 68

Original Poster
Rep: Reputation: 16
ok, it pretty much *doesn't* check any emails from hotmail.

I set up a new live.com account to test and amavis/spamassian doesn't add teh headers to this email..
 
Old 04-25-2009, 05:51 PM   #4
jonnytabpni
Member
 
Registered: Sep 2008
Posts: 68

Original Poster
Rep: Reputation: 16
OK, one bit of good news is that it seems to be at least checking the email because if I send a "spam" email from my hotmail account to my amavis server, is flag it as spam and correctly writes the headers (which is good). It's just when the email is ok tha tit doesn't add anything to the headers...
 
Old 04-25-2009, 06:19 PM   #5
jonnytabpni
Member
 
Registered: Sep 2008
Posts: 68

Original Poster
Rep: Reputation: 16
Fixed it.

There is a setting in the amavis configs that say when to write the headers above a certain limit
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amavis/spamd/postfix not dropping spam emails akistam Linux - Server 6 12-16-2008 12:50 AM
AMAVIS-NEW skip certain emails from check +Yan Linux - Software 0 03-19-2007 09:15 AM
amavis not filtering spam exodist Linux - Software 1 12-16-2005 11:44 PM
Amavis X-spam-status ncp Linux - Newbie 0 11-25-2005 03:27 AM
Rejecting Spam Emails vk1985 Linux - Networking 3 04-11-2003 04:36 AM


All times are GMT -5. The time now is 08:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration