LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 09-03-2008, 12:38 AM   #1
kideyse
LQ Newbie
 
Registered: May 2008
Posts: 15

Rep: Reputation: 0
Unhappy 12GB RAM installed in Dell Poweredge4600 but Fedora9 only sees 4GB


We have a Dell Poweredge server with two Xeon CPUs and 12GB of PC1600 RAM installed. We use Fedora9 as the enterprise OS server.
We cannot seem to get the system to use/see more than 4GB of RAM.

Can anyone provide a step-by-step procedure to resolve this?

We have done searches and received bits and pieces of advice but still see only 4GB. 8GB of RAM is sitting idle except for the BIOS memory count during boot.
 
Old 09-03-2008, 01:16 AM   #2
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 120Reputation: 120
What version of F9 is installed (32 or 64 bit)?

If 32 bit, do you use the pae kernel? If not, there should be a kernel-pae package available for you to use.

Last edited by billymayday; 09-03-2008 at 01:17 AM.
 
Old 09-03-2008, 08:55 AM   #3
kideyse
LQ Newbie
 
Registered: May 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Unhappy 32 bit

The Fedora9 OS we are using is 32bit. We did download the pae module and tried to follow the Red Hat documentation on performing the upgrade. Obviously we did something wrong because we still only see 4GB.

What we need is a step-by-step procedure on how to upgrade to pae with verifications on each step. Any URLs, links, suggestions would be appreciated.
 
Old 09-03-2008, 03:18 PM   #4
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 120Reputation: 120
I don't use it myself, but start with

yum list available kernel-pae (or maybe kernel* if that doesn't work)

I believe you can just install with yum and reboot to the pae kernel
 
Old 09-04-2008, 01:29 PM   #5
kideyse
LQ Newbie
 
Registered: May 2008
Posts: 15

Original Poster
Rep: Reputation: 0
installed pae kernel, rebooted and still only 4GB

I did exactly as you stated
yum list available kernel-pae

I did a
yum install
on the pae kernel, rebooted

but still only see 4GB

below is the result I got for 'uname -srvo'

Linux 2.6.25.14-108.fc9.i686 #1 SMP Mon Aug 4 14:08:11 EDT 2008 GNU/Linux

I don't see any hint of pae in the above output

In my humble opinion, there was a necessary step that we skipped between the 'yum install nnnnnnpae' and the reboot.
I did disable the SELINUX before doing any of the above.
Please advise.
 
Old 09-04-2008, 01:36 PM   #6
kideyse
LQ Newbie
 
Registered: May 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Unhappy How to boot to the kernel of choice?

I just noticed that you said boot to the pae kernel.

How do I direct the booting process to boot to the pae kernel?

I was not offered a choice of which kernel to boot to during the reboot.

Below is the contents of the /etc/grub.conf file, should I comment out all kernel images except the pae image?

default=1
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.25.14-108.fc9.i686.PAE)
root (hd0,0)
kernel /vmlinuz-2.6.25.14-108.fc9.i686.PAE ro root=/dev/VolGroup00/LogVo
l00 rhgb quiet
initrd /initrd-2.6.25.14-108.fc9.i686.PAE.img
title Fedora (2.6.25.14-108.fc9.i686)
root (hd0,0)
kernel /vmlinuz-2.6.25.14-108.fc9.i686 ro root=/dev/VolGroup00/LogVol00
rhgb quiet
initrd /initrd-2.6.25.14-108.fc9.i686.img
title Fedora (2.6.25.9-76.fc9.i686)
root (hd0,0)
kernel /vmlinuz-2.6.25.9-76.fc9.i686 ro root=/dev/VolGroup00/LogVol00 rh
gb quiet
initrd /initrd-2.6.25.9-76.fc9.i686.img

Last edited by kideyse; 09-04-2008 at 02:50 PM.
 
Old 09-04-2008, 03:31 PM   #7
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 120Reputation: 120
Selecting the first option (Fedora (2.6.25.14-108.fc9.i686.PAE)) will boot it for you. Selecting "Fedora (2.6.25.14-108.fc9.i686)" will boot the standard kernel.

I don't see why you need to comment out any other kernels.

I'm pretty sure grub numbers things from zero, so the default boot will be the second entry (default=1) which is non PAE. I'd make sure everything works though before I changed it (to default=0).

When the grub menu comes up, hitting any key should bring the menu with various boot options up.


Rgds

Edit - I don't recall the exact effect of "hiddenmenu". I think this just means the menu is hidden unless you hit a key when the first grub message comes up, but you may need to comment this line out - try it first.

Last edited by billymayday; 09-04-2008 at 03:32 PM.
 
Old 09-04-2008, 03:57 PM   #8
kideyse
LQ Newbie
 
Registered: May 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Smile Resolved

I just commented out hiddenmenu from grub.conf, rebooted,

this time the pae kernel showed up as one of the options (since the menu was no longer hidden)

I chose it, and voila, all the memory is now available for use.

The whole problem was booting to the pae kernel which was not the default but we couldn't see the grub boot menu because it was set to "hiddenmenu"

I wonder why they put 'hiddenmenu' in there by default?

Last edited by kideyse; 09-04-2008 at 03:58 PM.
 
Old 09-04-2008, 04:02 PM   #9
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
I think the reason they put in the hiddenmenu option is in order to make the machine act like a windows bootloader? Anyone changing this setting obviously knows what they are doing...
 
Old 09-04-2008, 04:04 PM   #10
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 120Reputation: 120
I think you'll find when you boot with hiddenmenu, that you get a message along the lines of:

Booting OSxxxxx in 5/4/3/2/1 seconds

(or something like that).

Hit any key during this process and the menu will come up. It's just neater I guess, especially if you tend to always boot the latest kernel.
 
Old 09-05-2008, 04:09 PM   #11
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
Didn't realise that billymayday, all my clients have full menu at boot up. hmmm. might have to change that! cheers.
 
Old 09-06-2008, 12:40 PM   #12
kideyse
LQ Newbie
 
Registered: May 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks Billymayday and Irishbite for your inputs.

Now that the original pae kernel issue is resolved, would there be any complications if I re-enabled SELINUX?

I had disabled it because I read somewhere that it doesn't work well when installing the pae kernel.
 
Old 09-06-2008, 04:58 PM   #13
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 120Reputation: 120
I don't know the answer to that I'm afraid
 
Old 09-07-2008, 12:02 AM   #14
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
I don't use SELinux anywhere, I don't have any need for it! Are you sure you do? SELinux is, IMHO, overkill for most applications. Do you need it for something specific?
 
Old 09-07-2008, 10:28 AM   #15
kideyse
LQ Newbie
 
Registered: May 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Although I have not yet succeeded in doing so, I have read that we can use SELINUX to create security policies across a network of Linux client-server, similar to what is used in a Windows domain. This feature would understandably be of great importance to our clients who may need more than just the file permissions security.
Unfortunately the Fedora documentation on the subject is hard to follow. In our limited experience with them, the pre-installed SELINUX policies seem to hinder normal operations. For example, we couldn't get SELINUX to allow the normal operation of SpamAssassin with our Sendmail and Cyrus email server setup. I had to set SELINUX to permissive.

I suppose this would/should be a topic for a separate thread.

Is there a another/better way to accomplish security policies in Linux networks?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3.6GB RAM instead of 4GB ??? masterross Slackware 11 09-04-2008 08:07 AM
utilize 4gb of ram cynick Linux - General 2 04-20-2006 11:42 AM
RHEL4 sees only 1GB out of 4GB RAM saarb16 Linux - General 1 02-21-2006 10:36 AM
RHEL3 on a Dell Precision 370 with 4GB RAM sub_pop_culture Linux - Enterprise 3 06-14-2005 05:41 PM
4GB RAM not showing eddie0uk Linux - Hardware 5 03-12-2005 07:08 AM


All times are GMT -5. The time now is 02:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration