LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-23-2012, 06:22 PM   #1
TheGorf
LQ Newbie
 
Registered: Feb 2009
Posts: 11

Rep: Reputation: 0
[solved] dhcpd incorrectly dynamically updating reverse zone information


Distro: CentOS 6.3
Bind version: 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.5
DHCP version: dhcp-4.1.1-31.0.1.P1.el6.centos.1.x86_64

I have dynamic DNS running just fine in a small environment with one exception. dhcpd updates the target zones, however, when it goes to update the reverse zone for the subnet, it is incorrectly formatting the update such that the whole IP is appended to the zone as opposed to just the last octet which would be correct for my /24 zone. You can see this in the logfiles:

Code:
Nov 23 14:25:52 willy named[2430]: client 127.0.0.1#42786: updating zone '8.168.192.in-addr.arpa/IN': deleting rrset at '50.8.168.192.8.168.192.in-addr.arpa' PTR
Nov 23 14:25:52 willy named[2430]: client 127.0.0.1#42786: updating zone '8.168.192.in-addr.arpa/IN': adding an RR at '50.8.168.192.8.168.192.in-addr.arpa' PTR
Nov 23 14:25:52 willy dhcpd: added reverse map from 50.8.168.192.8.168.192.in-addr.arpa to android_b37930cdc250e9b0.my_zone.com
Instead of adding a PTR for the mapping 50.8.168.192.in-addr.arpa it is adding 50.8.168.192.8.168.192.in-addr.arpa.

The zone info in dhcpd.conf is, as best I can tell, correct:

Code:
zone my_zone.com
{
        primary 127.0.0.1;
        key rndc-key;
}

zone 8.168.192.in-addr.arpa
{
        primary 127.0.0.1;
        key rndc-key;
}
And the zones in named appear correct as well:
Code:
zone "my_zone.com" {
        type master;
        file "data/my_zone.com.zone";
        allow-transfer { none; };
        allow-update { key "rndc-key"; };
        allow-query { any; };
        check-names ignore;
};

zone "8.168.192.in-addr.arpa" {
        type master;
        file "data/8.168.192.in-addr.arpa.zone";
        allow-transfer { none; };
        allow-update { key "rndc-key"; };
        allow-query { any; };
        check-names ignore;
};
So I am kind of stumped as to why the last octet isn't getting correctly set in the zone by DHCPd. Thoughts?

Last edited by TheGorf; 11-23-2012 at 06:26 PM.
 
Old 11-23-2012, 06:49 PM   #2
TheGorf
LQ Newbie
 
Registered: Feb 2009
Posts: 11

Original Poster
Rep: Reputation: 0
This is so odd, but I guess it makes sense in a way. So I left my zone files the same in dhcpd.conf:
Code:
# forward zone to update
zone myzone.com.
{
        primary 127.0.0.1;
        key rndc-key;
}
 
zone 8.168.192.in-addr.arpa.
{
        primary 127.0.0.1;
        key rndc-key;
}
BUT I altered the ddns-rev-domainname entry in my subnet section to be just "in-addr.arpa." I got this idea from this post:
http://www.linuxquestions.org/questi...-entry-867266/

So even though the zone statement doesn't match, somewhere between dhcpd and named they figure out what zone it goes into. Seems to work just fine now.

Code:
# No service will be given on this subnet, but declaring it helps the 
# DHCP server to understand the network topology.
 
subnet 192.168.8.0 netmask 255.255.255.0
{
        # pool for dhcp leases
        pool {
                option routers 192.168.8.1;
                option domain-name "my_zone.com";
                option domain-name-servers 192.168.8.20;
                option subnet-mask 255.255.255.0;
                range 192.168.8.50 192.168.8.200;
        }
 
        ddns-domainname "my_zone.com.";
        ddns-rev-domainname "in-addr.arpa.";
}
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which zone bind dns work either in forward zone are reverse zone sanjay87 Linux - Server 2 06-05-2012 05:21 AM
[SOLVED] bind reverse zone; no name with reverse lookup deadeyes Linux - Server 3 10-12-2009 10:54 AM
BIND forward zone OK, reverse zone NOT OK! n03x3c Linux - Server 2 11-05-2008 11:31 PM
why is bind updating reverse zone with updating zone 202.1.168.192.1.168.192.in-addr marcobjorge Linux - Networking 5 10-12-2008 05:53 AM
How DNS can be configured , to update records dynamically; when using DHCPd?????????? mwj Linux - Software 3 03-20-2004 12:01 PM


All times are GMT -5. The time now is 12:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration