LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   [OpenSUSE 10.3] virtual network interface (http://www.linuxquestions.org/questions/linux-server-73/%5Bopensuse-10-3%5D-virtual-network-interface-677684/)

noir911 10-19-2008 10:41 PM

[OpenSUSE 10.3] virtual network interface
 
Does anyone know how to have a virtual interface and make it permanent?
This cannot be done via yast.

I can do ifconfig eth0:0 192.168.25.25 - but once I reboot, it's gone.

I have also tried creating a file /etc/sysconfig/network-scripts/ifcfg-eth0:1

Code:

DEVICE=eth0:1
BOOTPROTO=static
IPADDR=192.168.25.25
NETMASK=255.255.255.0
NETWORK=192.168.25.0
BROADCAST=192.168.25.255
ONBOOT=yes

but when I restart the network (/etc/init.d/network restart) I get the
following and I don't get any eth0:1 interface when I do ifconfig -a.

Code:

Shutting down the NetworkManager                                      done
Shutting down the DHCP DBUS Daemon                                    done
Shutting down the NetworkManagerDispatcher                            done
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
    lo
    lo        IP address: 127.0.0.1/8
Checking for network time protocol daemon (NTPD):                    doneing
    eth0      device: Broadcom Corporation NetXtreme BCM5722 Gigabit Ethernet PCI Express
    eth0      IP address: 203.10.1.21/24
    eth0:zeus IP address: 203.10.1.21/24
Checking for network time protocol daemon (NTPD):                    doneing
Setting up service network  .  .  .  .  .  .  .  .  .  .  .  .  .  .  done

Would someone know how to set this up?

Thanks.

megerdin 10-20-2008 12:15 AM

-

check this it may solve your problem


-

noir911 10-20-2008 03:45 AM

Quote:

Originally Posted by megerdin (Post 3316129)

it doesn't.

megerdin 10-23-2008 03:26 AM

I don't know anymore about that. Somebody may help you more


All times are GMT -5. The time now is 11:05 PM.