LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 07-02-2012, 12:32 PM   #1
sanjay87
Member
 
Registered: Oct 2011
Posts: 164

Rep: Reputation: Disabled
[notice] suEXEC mechanism enabled (wrapper:/usr/sbin/suexec):Apache is not listening


Hi
Apache is starting But it not listening to tomcat.when i look out mod_jk
log, i could find mod_jk initialsed.I tried out by disable selinux,But even im facing out same problem .when i look apache status it thows error
Quote:
httpd dead but subsys locked
.i have tried out all possiblity pls any help me.
Quote:

step1:uncommented mod_unique_id.so module
uncommented the below module in httpd.conf .
LoadModule unique_id_module modules/mod_unique_id.so
step2:Killed httpd in subsys
Quote:
root@localhost subsys]# ls
abrt-ccpp cgconfig ip6tables messagebus rpcbind
abrtd cpuspeed ksmtuned mysqld rpc.idmapd
abrt-oops crond libvirtd netfs rpc.statd
acpid cups libvirt-guests network rsyslog
atd h libvirt-qmf NetworkManager sshd
autofs haldaemon local postfix tog-pegasus
avahi-daemon httpd lvm2-monitor qpidd
[root@localhost subsys]# rm -rf h
[root@localhost subsys]# rm -rf httpd
[root@localhost subsys]# service httpd start
Starting httpd: [Mon Jul 02 21:45:30 2012] [warn] module php5_module is already loaded, skipping
(98)Address already in use: make_sock: could not bind to address [::]:80
[ OK ]
[root@localhost subsys]# service httpd status
httpd dead but subsys locked

[root@localhost subsys]#
Quote:
Mon Jul 02 21:08:07 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

Quote:
[root@localhost logs]# service httpd restart
Stopping httpd: [FAILED]
Starting httpd: [Mon Jul 02 21:30:13 2012] [warn] module php5_module is already loaded, skipping
(98)Address already in use: make_sock: could not bind to address [::]:80
[ OK ]
[root@localhost logs]# lsof -i :80
[root@localhost logs]# netstat -apn | grep :80
[root@localhost logs]# httpd -t
[Mon Jul 02 21:30:29 2012] [warn] module php5_module is already loaded, skipping
Syntax OK
[root@localhost logs]# httpd -S
[Mon Jul 02 21:30:32 2012] [warn] module php5_module is already loaded, skipping
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80 Server (/etc/httpd/conf/httpd-external.conf:1)
Syntax OK


[root@localhost logs]# setenforce 0
setenforce: SELinux is disabled
[root@localhost logs]#


Quote:
Mon Jul 02 21:08:07 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jul 02 21:08:07 2012] [warn] No JkShmFile defined in httpd.conf. Using default /etc/httpd/logs/jk-runtime-status
[Mon Jul 02 21:08:07 2012] [warn] module php5_module is already loaded, skipping
[Mon Jul 02 21:12:41 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jul 02 21:12:41 2012] [warn] No JkShmFile defined in httpd.conf. Using default /etc/httpd/logs/jk-runtime-status
[Mon Jul 02 21:12:41 2012] [warn] module php5_module is already loaded, skipping
[Mon Jul 02 21:13:31 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jul 02 21:13:31 2012] [warn] No JkShmFile defined in httpd.conf. Using default /etc/httpd/logs/jk-runtime-status
[Mon Jul 02 21:13:31 2012] [warn] module php5_module is already loaded, skipping
[Mon Jul 02 21:15:30 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

[Mon Jul 02 21:15:30 2012] [warn] No JkShmFile defined in httpd.conf. Using default /etc/httpd/logs/jk-runtime-status
[Mon Jul 02 21:15:30 2012] [warn] module php5_module is already loaded, skipping
[Mon Jul 02 21:16:03 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
@
Quote:
#vi mod_jk.log

[Mon Jul 02 21:17:54 2012] [3904:140108632647648] [info] init_jk::mod_jk.c (3189): mod_jk/1.2.30 initialized
~
~
~

Last edited by sanjay87; 07-02-2012 at 12:52 PM.
 
Old 07-02-2012, 01:18 PM   #2
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,565

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
The warnings and notices should not prevent httpd from starting. Do you not see anything reported as an error in the error_log for Apache or your messages file?

You can try to run the following to get as much info as possible:

Code:
sudo apachectl -e "debug"
Pipe it to less/more or redirect to a file as you will get ALOT of info.

Log Levels:

LogLevel adjusts the verbosity of the messages recorded in the error logs (see ErrorLog directive). The following levels are available, in order of decreasing significance:
Level Description Example
emerg Emergencies - system is unusable. "Child cannot open lock file. Exiting"
alert Action must be taken immediately. "getpwuid: couldn't determine user name from uid"
crit Critical Conditions. "socket: Failed to get a socket, exiting child"
error Error conditions. "Premature end of script headers"
warn Warning conditions. "child process 1234 did not exit, sending another SIGHUP"
notice Normal but significant condition. "httpd: caught SIGBUS, attempting to dump core in ..."
info Informational. "Server seems busy, (you may need to increase StartServers, or Min/MaxSpareServers)..."
debug Debug-level messages "Opening config file ..."

When a particular level is specified, messages from all other levels of higher significance will be reported as well. E.g., when LogLevel info is specified, then messages with log levels of notice and warn will also be posted.

Using a level of at least crit is recommended.
 
Old 07-02-2012, 01:21 PM   #3
arun5002
Member
 
Registered: Aug 2011
Location: Chennai,India
Distribution: Redhat,Centos,Ubuntu,Dedian
Posts: 549
Blog Entries: 5

Rep: Reputation: Disabled
Hi
BACKUP your httpd.conf file and then upgrade the apache (OR else ) Reinstall httpd package and configure apache once again .
 
Old 07-02-2012, 01:26 PM   #4
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,565

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
Quote:
Originally Posted by arun5002 View Post
Hi
BACKUP your httpd.conf file and then upgrade the apache (OR else ) Reinstall httpd package and configure apache once again .
Why would you suggest an upgrade or entire recompile at this point? From the output displayed you can't determine what version the OP is on, he may already be on the most current/stable for his distro. If you are going to make a suggestion such as this please give some background info as to the why so others can understand.

Remember the teach a man to fish analogy...
 
Old 07-02-2012, 01:31 PM   #5
sanjay87
Member
 
Registered: Oct 2011
Posts: 164

Original Poster
Rep: Reputation: Disabled
Thanks arun

Backuped up httpd.conf file and Reinstall httpd Package .solved the problem

Thanks man saved my life .Im marking these problem as resolved
 
Old 07-02-2012, 01:36 PM   #6
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,565

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
Sanjay make sure to verify that any dependency modules that were removed during the uninstall got re-intsalled. Things like mod_ssl might have been removed.

I still don't agree with this solution as its a nuke as opposed to a real diagnoses of the problem. I would not suggest this route to any one else experiencing the problem until a proper review of the actual error is complete.
 
Old 07-02-2012, 01:47 PM   #7
arun5002
Member
 
Registered: Aug 2011
Location: Chennai,India
Distribution: Redhat,Centos,Ubuntu,Dedian
Posts: 549
Blog Entries: 5

Rep: Reputation: Disabled
Hi Kustom42,
For httpd dead but subsys locked problem .I had faced out few many time in my production environmental .In few cases uncommenting mod_unique module in httpd.conf , Removal of httpd file /var/lock/subsys/httpd is the only options is repeatly found on google search few cases the both the things never works.Lots more google search says the same resolvation method you can find in google many never find both seems to work in there conditions .As sanjay87 he had posted that he had tried out both the options.So i recommended to upgrade the apache .

Quote:
Quote:
step1:uncommented mod_unique_id.so module
[root@localhost subsys]# rm -rf httpd
[root@localhost logs]# httpd -t
[Mon Jul 02 21:30:29 2012] [warn] module php5_module is already loaded, skipping
Syntax OK
[root@localhost logs]# httpd -S
[Mon Jul 02 21:30:32 2012] [warn] module php5_module is already loaded, skipping
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80 Server (/etc/httpd/conf/httpd-external.conf:1)
Syntax OK

Last edited by arun5002; 07-02-2012 at 01:49 PM.
 
Old 07-02-2012, 01:59 PM   #8
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,565

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
Your solution is completely incorrect. The amount of things that will cause a httpd dead but subsys locked error goes well beyond the two steps you provided. It could be something as simple as permissions on /var/run that would re-occur after a re-install.

Setting your log level to debug and reviewing the information should tell you exactly where the error is occurring.

I'm not trying to put you down Arun, just give some education from someone who has seen and resolved this error many times, but this solution should not be provided unless a full review has occurred. If this poster was using a control panel like cPanel you would have just broke their server as it uses a custom compiled version of httpd.

I'm happy that it worked for you Sanjay but don't go re-posting this as a solution for this error without digging into the actual root cause as you could make things much worse without fixing the problem this route.
 
1 members found this post helpful.
Old 05-28-2013, 01:19 AM   #9
gunasaikia
LQ Newbie
 
Registered: Dec 2012
Posts: 2

Rep: Reputation: Disabled
your certificate expired

may be suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) error comes when https certificate expires. In my case I edited the nss.conf file as below and the problem resolved.

Add NSSEnforceValidCerts off
in /etc/httpd/conf.d/nss.conf

and then restart the httpd. while restarting it generates a new secret for digest authentication and httpd starts
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2, suexec error: command not in docroot (/usr/bin/php-cgi) chris_J_W Linux - Server 1 07-17-2010 02:57 PM
httpd-2.2.3 | error - suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) jmahto Linux - Enterprise 3 07-14-2010 01:53 AM
apache suexec hassan2 Linux - Software 0 08-03-2005 07:01 PM
Apache Suexec Maze the Kid Linux - Software 0 04-05-2005 04:05 PM
Apache suexec Rachel Carter Linux - Software 0 01-31-2003 03:27 PM


All times are GMT -5. The time now is 07:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration