LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 02-09-2010, 11:52 PM   #1
gregnorc
LQ Newbie
 
Registered: Jul 2009
Posts: 29

Rep: Reputation: 15
wireshark on ubuntu doesn't want to save .pcaps (even as root)


I've run into a sort of catch 22.

I installed wireshark via apt-get on my Eee 1008HA, but when it is launched, it does not allow any capture interfaces.

I think this is because the shortcut created in my applications paneldoes not start it as root. Other distros always had two shortcuts, one to run as root, one to run as a normal user. Anyways, this isn't a big deal, I can sudo.

So I went into terminal, typed in "sudo wireshark" and it popped up, as root - everything seems in order.

I was then able to capture on my wireless interface with no issues.

However, saving that data presents a problem. If I try and specify my usual home folder as the location for the capture to be saved, I get an error that permission was denied, which seems odd since while that folder is not the root user's home folder, wireshark is running as root and should be able to do pretty much whatever it wants.

How can I get wireshark set up so I can both capture _and_ save the .pcap files I generate? I don't want to save them in /

I'm running karmic koala, the full output of uname -a is: Linux ruckus-laptop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux.
 
Old 02-10-2010, 12:16 AM   #2
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
You need to su to root within the normal user account and setup airmon-ng and use airodump-ng.

It took me a few to find the answer when I first started.

Code:
airodump-ng --showack -g -e -b abg -t WEP -t WPA -t WPA2 -t WPA1 eth1 --output-format pcap -w d5
Code:
airmon-ng start eth1
 
Old 02-10-2010, 12:21 AM   #3
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
You don't have SELinux installed and enabled, do you?

One workaround might be to create a folder that's accessible to both "root" and your normal user.

Another workaround might be to run "sudo bash", then do whatever you want (as "root"), instead of "sudo wireshark".
 
Old 02-10-2010, 10:22 AM   #4
gregnorc
LQ Newbie
 
Registered: Jul 2009
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Mr-Bisquit View Post
You need to su to root within the normal user account and setup airmon-ng and use airodump-ng.

It took me a few to find the answer when I first started.

Code:
airodump-ng --showack -g -e -b abg -t WEP -t WPA -t WPA2 -t WPA1 eth1 --output-format pcap -w d5
Code:
airmon-ng start eth1
Is it possible to use a similiar command to put the card into promosicuous mode?

Most of the time I'm capturing, I only want traffic from one AP. (My logic is that way would save space on the HD and processor overhead, but if you think it's better to grab everything floating around.

Also, I plan to mess around with arp spoofing, and correct me if I'm wrong, but doesn't airmon only create wireless interfaces?
 
Old 02-10-2010, 05:20 PM   #5
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
It should be. I had to look for the commands myself with the aircrack suite forums and mailing lists.
 
Old 02-11-2010, 12:17 AM   #6
gregnorc
LQ Newbie
 
Registered: Jul 2009
Posts: 29

Original Poster
Rep: Reputation: 15
I mean - would it even be the aircrack suite that puts the card in promiscuous mode if I'm going to be using it to sniff wired traffic? Or is such a distinction irrelevant?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu does not save wallpaper. jmilb10053 Linux - Newbie 1 09-30-2009 09:54 PM
Save root filesystem consty Red Hat 1 03-05-2008 02:58 PM
Wireshark does not have permission to save files? sgware Linux - Software 11 01-05-2008 12:02 PM
save file as root from x console? rockets Linux - Newbie 5 10-25-2004 09:27 AM
save as root johntramp Linux - Newbie 3 04-07-2004 05:16 AM


All times are GMT -5. The time now is 06:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration